Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER for Video Editing/Mangling

Reply
 
Thread Tools Display Modes
Old 11-27-2019, 04:22 PM   #1
nofish
Human being with feelings
 
nofish's Avatar
 
Join Date: Oct 2007
Location: home is where the heart is
Posts: 9,291
Default VLC decoder uses considerably more RAM than ffmpeg

I noticed that with the project I'm currently working on which contains only video items and jpg's, when I use ffmpeg as decoder it (according to Task Manager) consumes ~1GB, while with VLC it consumes ~4.7GB.

Is this whopping difference normal/expected?

using ffmpeg:


same project using VLC:


Video info (same item):
using ffmpeg:


using VLC:


(I only have 8 GB installed, so Windows warned me about running low on RAM when using VLC, that's how I noticed.)

Last edited by nofish; 11-27-2019 at 04:32 PM.
nofish is offline   Reply With Quote
Old 11-27-2019, 10:04 PM   #2
JamesPeters
Human being with feelings
 
JamesPeters's Avatar
 
Join Date: Aug 2011
Location: Near a big lake
Posts: 2,830
Default

When I used Windows I noticed sometimes using VLC as the decoder would make Reaper unresponsive after loading a video until things "settled", but I didn't think about RAM use being the culprit. I switched to FFMPEG at that time. (I'm using Linux now and just settled on FFMPEG as the decoder for Reaper since VLC didn't work as a decoder when I first got Linux set up.)

There is a preference in VLC player which I wonder about: "preload MKV files in the same directory" (under "input/codecs", "files"). If this setting also applies when using VLC as a decoder in Reaper, and you have MKV files in the same directory as whatever video you're loading, that might explain the extra RAM use.
__________________
https://petersamplification.com
Using REAPER for Linux
JamesPeters is offline   Reply With Quote
Old 11-28-2019, 05:44 AM   #3
nofish
Human being with feelings
 
nofish's Avatar
 
Join Date: Oct 2007
Location: home is where the heart is
Posts: 9,291
Default

Thanks for the reply.
No MKV files in use (neither in that project nor in the same directory as the other videos), only using h264/mp4 and png's, but I've disabled the "preload MKV files in the same directory" nonetheless just in case.

The issue I have (and why I posted in the first place) with these videos it only runs smoothly when using VLC as decoder unfortunately, using ffmpeg it's stuttery.
While I can work on that project currently, RAM use is really on the edge, as soon as I open another application (e.g. Firefox) Windows gives me a warning about RAM maxing out and loosing data. And that's not even having all videos for the project imported.

So the question boils down to:
Is there any way to reduce the 'hefty' RAM usage with VLC?
nofish is offline   Reply With Quote
Old 11-29-2019, 12:00 PM   #4
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 12,623
Default

Try using ffmpeg, and right clicking in the video window, experimental performance options, and enabling video pre-fetch, that might help ffmpeg perform better
Justin is offline   Reply With Quote
Old 11-30-2019, 05:29 AM   #5
nofish
Human being with feelings
 
nofish's Avatar
 
Join Date: Oct 2007
Location: home is where the heart is
Posts: 9,291
Default

Thanks Justin, but no luck so far with ffmpeg (still stuttery also with pre-fetch).
I've noticed that the render timings are also largely different.

VLC:


ffmpeg (same video item):


Specs (admittedly not the newest..):
Intel DP43BF/Q9550/8GB RAM/Win 8.1/R6rc8 x64/VLC x64 latest/ffmpeg x64 latest Zeranoe build

edit:
Here's one of the used videos, if it helps.. (~190MB)
https://www.dropbox.com/s/4bv9di5ixr...C0040.MP4?dl=1

Last edited by nofish; 11-30-2019 at 06:03 AM.
nofish is offline   Reply With Quote
Old 11-30-2019, 01:24 PM   #6
JamesPeters
Human being with feelings
 
JamesPeters's Avatar
 
Join Date: Aug 2011
Location: Near a big lake
Posts: 2,830
Default

That CPU is probably borderline acceptable for video editing when you're not using GPU for it at all (Reaper doesn't use GPU for video or any of its own functionality). And your chosen video resolution is pretty high.

That being said...

On my main computer running Xubuntu: with that one video file (with a file size of 188 MB) in a project by itself as a test, Reaper uses approximately 700 MB RAM with VLC (3.0.8) as the decoder and it plays smoothly with "video load" around 45% (max 200%). Using FFMPEG however (ffmpeg/libav DLL decoder v58.35.100), it uses about half that amount of RAM (around 350 MB) and it plays glitchy (video CPU spiking way too high, average 200% and max around 1000%) no matter what I try to help it (the settings Justin mentioned, plus "ignore audio", plus changing audio buffer size, setting frame rate to 25 fps to match the item's frame rate, etc.)

Considering my system has a Ryzen 7 3700X CPU, I'm a bit surprised at the performance of FFMPEG in this case.
__________________
https://petersamplification.com
Using REAPER for Linux

Last edited by JamesPeters; 11-30-2019 at 01:32 PM.
JamesPeters is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 09:40 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.