Old 08-01-2019, 02:01 AM   #1
4Eyes
Human being with feelings
 
Join Date: Jan 2012
Posts: 5
Default Hackintosh Mojave - Reaper crashing since v5.97

Hi there,

I hope you'll be able to track down where's problem with my Hackintosh/Ryzentosh, seems I got all basic stuff working. but I'm experiencing Reaper crashes right on the launch, I've found out that v5.965 is working fine, v5.97 is where it starts with the same errors, following all the later versions.

My MacBookPro (early 2015 13" Retina) running the same version of Mojave 10.14.6 is running the latest Reaper v5.981 fine.

attached is crash report, if you see something suspicious that'll help me to fix it I'll really appreciate it. I tried different memory UEFI drivers without success, it's probably something like that or some kext I'm missing.
Attached Files
File Type: txt reaper.txt (86.5 KB, 103 views)
4Eyes is offline   Reply With Quote
Old 08-01-2019, 11:39 AM   #2
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 12,631
Default

Ah Ryzen... Seems the version of ICC we're using is probably incompatible (since officially it's not a supported CPU on the mac). I suppose we could make a clang-only macOS build once in a while, if that would be helpful...
Justin is offline   Reply With Quote
Old 08-01-2019, 12:46 PM   #3
4Eyes
Human being with feelings
 
Join Date: Jan 2012
Posts: 5
Default

ah..that would help, if it's not too much hassle.. I know of some other people trying to get Reaper working on a Ryzentosh, too.
4Eyes is offline   Reply With Quote
Old 12-04-2019, 05:49 PM   #4
ViktorNova
Human being with feelings
 
Join Date: Jun 2015
Posts: 8
Default

Quote:
Originally Posted by Justin View Post
Ah Ryzen... Seems the version of ICC we're using is probably incompatible (since officially it's not a supported CPU on the mac). I suppose we could make a clang-only macOS build once in a while, if that would be helpful...
I'm having this same exact problem on an AMD FX 6300 Hackintosh, the lastest version of Reaper I can use is 5.965 =(

Are there alternate builds out right now that might work better on AMD Hackintosh systems? That would be SUPER awesome! It would be nice to not have to build a new Intel Hackintosh from the ground up to run Reaper, but I will save up and do it if I have to

I have attached my crash log from trying to run v6.0, it looks nearly identical to 4Eyes
Attached Files
File Type: txt reaper-crash.txt (80.0 KB, 56 views)
ViktorNova is offline   Reply With Quote
Old 12-06-2019, 01:43 PM   #5
lemorse
Human being with feelings
 
Join Date: Nov 2018
Posts: 18
Default

Hi everyone,
I've been using a homemade hackintosh since the end of Reaper v.4 and I've never had any compatibility issues except since ... V.6 Arggg since I watched it from corner of the eye I strongly hope for an update that will allow me to use it. Fortunately I have no problem with v5.99.
I'm using osx10.11.1 and everything is very stable until now!

Thank you in advance for a future update allowing the use of the V.6 hackintosh owner
lemorse is offline   Reply With Quote
Old 12-07-2019, 01:57 AM   #6
Ideosound
Human being with feelings
 
Ideosound's Avatar
 
Join Date: Oct 2017
Location: U.K
Posts: 188
Default

Quote:
Originally Posted by lemorse View Post
Hi everyone,
I've been using a homemade hackintosh since the end of Reaper v.4 and I've never had any compatibility issues except since ... V.6 Arggg since I watched it from corner of the eye I strongly hope for an update that will allow me to use it. Fortunately I have no problem with v5.99.
I'm using osx10.11.1 and everything is very stable until now!

Thank you in advance for a future update allowing the use of the V.6 hackintosh owner
You'll need to state your hardware, especially CPU and what the actual problem is.
Ideosound is offline   Reply With Quote
Old 12-07-2019, 01:03 PM   #7
lemorse
Human being with feelings
 
Join Date: Nov 2018
Posts: 18
Default

Hi Ideosound,thank you for your interest in this problem.
OK, The features of my hackintosh are :
- Motherboard :Gigabyte Z78pds3
- CPU:Core i5 2500K / 3.3 GHz (LGA1155 Socket)
- GPU: PNY GeForce GT 610 (PCIe, 1024 MB) (double screen: 27"HDMI & 21"vga)
- RAM 8G
-Soundcard : RME UC

I'm on OSX10.11.1 bootloader and kexts found on https://www.tonymacx86.com/
The system is very stable and I have no problem with Reaper v5.99 but when I launch Reaper v6 (portable or not) launch fail on "initializing Main windows"

Here is the informations about my config and the problem of launching V.6
I do not know if it's because of the CPU of the video card but so far I have no problem with any other program even apple.

If this can help below the early of error report:
Thanks for your help.
Attached Files
File Type: txt Reaper Crash v6 .txt (903 Bytes, 64 views)

Last edited by lemorse; 12-07-2019 at 01:41 PM.
lemorse is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 04:51 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.