Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 12-27-2019, 12:31 PM   #1
jnif
Human being with feelings
 
jnif's Avatar
 
Join Date: Dec 2008
Posts: 2,090
Default MIDI playback sending extra note at the end of loop

At some tempos, for example at 110 bpm, Reaper is incorrectly sending an extra note at the end of loop.

The extra note starts at the same position where loop selection ends, but it should not be sent during loop playback. The loop playback works correctly at 120 bpm tempo.

The extra note might not be a problem in instruments where the immediatelly following 'Note Off' will silence the note. But for example in many drum samplers in one-shot mode, samples are triggered by 'Note On' and then played to the end regardless of the following 'Note Off'. In those cases the extra note at end of loop is clearly audible.

Tested on Reaper 4.77, 5.99, and 6.02.
Same bug in all versions.

jnif
jnif is offline   Reply With Quote
Old 12-29-2019, 09:38 AM   #2
jnif
Human being with feelings
 
jnif's Avatar
 
Join Date: Dec 2008
Posts: 2,090
Default

A workaround to this issue is to enable "Force project tempo/time signature changes to occur on whole samples" in project settings.
With that option enabled, the 110 BPM tempo is automatically changed to 109.998 BPM (at 44.1 kHz sample rate), and the extra note at the end of loop is not sent anymore.

jnif
jnif is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 09:27 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.