Old 06-27-2022, 05:08 AM   #241
norbury brook
Human being with feelings
 
norbury brook's Avatar
 
Join Date: Mar 2007
Location: London UK
Posts: 2,643
Default

Quote:
Originally Posted by Judders View Post
Did you check the meter speed in preferences? Did you have a plugin GUI open? Was there a lot of plugins in the project?
I can't find it, where is it?

edit: found it. Set them to 100hz and 20dB/sec respectively, nice smooth appearance

M
__________________
https://www.marcuscliffe.com/

Last edited by norbury brook; 06-27-2022 at 05:14 AM.
norbury brook is offline   Reply With Quote
Old 06-27-2022, 07:27 AM   #242
Judders
Human being with feelings
 
Join Date: Aug 2014
Posts: 10,724
Default

Quote:
Originally Posted by norbury brook View Post
I can't find it, where is it?

edit: found it. Set them to 100hz and 20dB/sec respectively, nice smooth appearance

M
Excellent 😊
Judders is offline   Reply With Quote
Old 06-27-2022, 01:14 PM   #243
IVL Nørdum
Human being with feelings
 
IVL Nørdum's Avatar
 
Join Date: Nov 2017
Location: Siberian
Posts: 20
Default

Quote:
Originally Posted by White Tie View Post
With my [url=https://forum.cockos.com/showthread.php?t=230623]Default V6 Modders' Supplies[/list]
wow, its very awesome!
Definitely the right way, thought about it back in 2017 when I started developing ) thnx
__________________
_Inquasar_DM _ |
IVL Nørdum is offline   Reply With Quote
Old 06-28-2022, 01:10 PM   #244
Judders
Human being with feelings
 
Join Date: Aug 2014
Posts: 10,724
Default

So, White Tie asked to see what we've done with this...

I assembled a very boring but legible theme

Judders is offline   Reply With Quote
Old 06-29-2022, 08:17 AM   #245
User41
Human being with feelings
 
Join Date: Aug 2020
Posts: 75
Default

Quote:
Originally Posted by Judders View Post
So, White Tie asked to see what we've done with this...

I assembled a very boring but legible theme

I love this theme. I'm always focused on practicality. Can I download it somewhere?
User41 is offline   Reply With Quote
Old 06-29-2022, 03:26 PM   #246
Judders
Human being with feelings
 
Join Date: Aug 2014
Posts: 10,724
Default

Quote:
Originally Posted by User41 View Post
I love this theme. I'm always focused on practicality. Can I download it somewhere?
I'm not sure it would work, but it took me all of 5 minutes with the theme assembler, 5 minutes with the theme adjuster and 10 minutes with the theme tweaker (just to change fonts and a few colours).
Judders is offline   Reply With Quote
Old 06-30-2022, 12:23 AM   #247
White Tie
Pixel Pusher
 
White Tie's Avatar
 
Join Date: Mar 2007
Location: Blighty
Posts: 4,160
Default

Well said Judders; my hope is that if anyone likes the a screenshot of what someone has done with the script, they will be inspired to download the script and have a go themselves.
__________________
The House of White Tie
White Tie is offline   Reply With Quote
Old 07-04-2022, 02:08 PM   #248
EduSerra
Human being with feelings
 
EduSerra's Avatar
 
Join Date: Apr 2021
Location: Colombia
Posts: 80
Default Pan Knobs NOT aligned

Hello

I´ve been working on a new theme usisng this fantastic script. I´ve found that the pan knobs are not aligned when panned in oposite direction, for example -60 (to the left) vs (+60 to the right). As you can see in this pic

https://stash.reaper.fm/44831/pan.PNG

In order to have them aligned the right pan knob has to be set at +64 which visually is accurate with -60 but not sonnically. This happens with all the stack files and did not happened with other themes I checked and not in the default theme.

https://stash.reaper.fm/44830/pan%20corrected.PNG
EduSerra is offline   Reply With Quote
Old 07-05-2022, 04:48 AM   #249
White Tie
Pixel Pusher
 
White Tie's Avatar
 
Join Date: Mar 2007
Location: Blighty
Posts: 4,160
Default

Thanks for spotting this, its not something I'd noticed before. Here's what's happening:



Reaper is choosing which frame to show by rounding down. When a stack has a low frame count like this (I think 35 frames is low but adequate for a small pan knob) then there's an offset throughout because the first frame covers all the way from 0 to 95%L, but the last frame is only used for exactly and only exactly 100%R.

The default theme uses the code pointers, not bitmap stacks, because they may not look very good but they are flawlessly accurate at any size.
__________________
The House of White Tie
White Tie is offline   Reply With Quote
Old 07-05-2022, 05:51 AM   #250
User41
Human being with feelings
 
Join Date: Aug 2020
Posts: 75
Default

Quote:
Originally Posted by White Tie View Post
Well said Judders; my hope is that if anyone likes the a screenshot of what someone has done with the script, they will be inspired to download the script and have a go themselves.
Thank you both.

Yeah, I've downloaded the theme adjuster and had fun with it. I'm just not as good at "seeing" color schemes so have a lot of trouble coming up with themes that look good. (To be clear, I am not visually impaired, just not great at picking colors).

I thought Judders was really clean.
User41 is offline   Reply With Quote
Old 07-05-2022, 06:06 AM   #251
Judders
Human being with feelings
 
Join Date: Aug 2014
Posts: 10,724
Default

Quote:
Originally Posted by User41 View Post
Thank you both.

Yeah, I've downloaded the theme adjuster and had fun with it. I'm just not as good at "seeing" color schemes so have a lot of trouble coming up with themes that look good. (To be clear, I am not visually impaired, just not great at picking colors).

I thought Judders was really clean.
I didn't really do any choosing; I just used what was already there.

Transport display and timeline are just greens close to the toolbar buttons. Send font colour is an orangy yellow close to the send colour from the mixer routing button. Fx are light blue to stand out as contrast to those colours, also close to the blue in the mixer routing button. All elements from the theme assembler are dark, except the faders which are white to stand out (API style).

I also changed the time selection colour to a similar green to the toolbar buttons.
Judders is offline   Reply With Quote
Old 07-05-2022, 06:19 AM   #252
Judders
Human being with feelings
 
Join Date: Aug 2014
Posts: 10,724
Default

... and I'm not deliberately being mean by not giving it in a download. I don't know if the theme assembler works that way, I don't think elements save with the theme file, and I had to rename the theme to save the theme tweaker changes so it won't be recognised as the theme assembler theme. That's why I said I wasn't sure if it would work for you to download it.
Judders is offline   Reply With Quote
Old 07-05-2022, 08:07 AM   #253
EduSerra
Human being with feelings
 
EduSerra's Avatar
 
Join Date: Apr 2021
Location: Colombia
Posts: 80
Default

Quote:
Originally Posted by White Tie View Post
Thanks for spotting this, its not something I'd noticed before. Here's what's happening:



Reaper is choosing which frame to show by rounding down. When a stack has a low frame count like this (I think 35 frames is low but adequate for a small pan knob) then there's an offset throughout because the first frame covers all the way from 0 to 95%L, but the last frame is only used for exactly and only exactly 100%R.

The default theme uses the code pointers, not bitmap stacks, because they may not look very good but they are flawlessly accurate at any size.
Yes I thought that maybe with more frames the drawing would be more precise. It´s a minor thing that only obsessive compulsive people like me get´s bothered about. Hehaha. I will post my theme design the next week. Thanks for making this possible for us.
EduSerra is offline   Reply With Quote
Old 07-05-2022, 10:00 AM   #254
White Tie
Pixel Pusher
 
White Tie's Avatar
 
Join Date: Mar 2007
Location: Blighty
Posts: 4,160
Default



Fixed in the latest pre-release, so hopefully should be in the next release
__________________
The House of White Tie
White Tie is offline   Reply With Quote
Old 07-07-2022, 10:36 AM   #255
BPBaker
Human being with feelings
 
BPBaker's Avatar
 
Join Date: Oct 2013
Location: Brooklyn, NY
Posts: 113
Default

Hi White Tie - a few other minor things:

Phase button disappears on the mixer when enabled


Minor shadow misalignment on some TCP/MCP boxes (more noticeable on light backgrounds)
BPBaker is offline   Reply With Quote
Old 07-11-2022, 07:39 AM   #256
EduSerra
Human being with feelings
 
EduSerra's Avatar
 
Join Date: Apr 2021
Location: Colombia
Posts: 80
Default

Quote:
Originally Posted by White Tie View Post


Fixed in the latest pre-release, so hopefully should be in the next release
you mean Reaper install pre-release or Theme Assembler pre-release?
EduSerra is offline   Reply With Quote
Old 07-13-2022, 09:49 PM   #257
rotors
Human being with feelings
 
Join Date: Oct 2021
Posts: 6
Default

[QUOTE=White Tie;2572903]Thanks folks.

Yes, and there always has been, just not with this script. Look in the rtconfig.txt file for the instructions "MODDING WITH 'THEN'".



Thanks for the info White Tie, but unfortunately I have no idea about this kind of stuff and unsure of how what to do.

I am not sure how hard this is, but could you please add this to your theme script so that is easy to change / rearrange the master button buttons, just like the track buttons?
rotors is offline   Reply With Quote
Old 07-14-2022, 01:04 AM   #258
White Tie
Pixel Pusher
 
White Tie's Avatar
 
Join Date: Mar 2007
Location: Blighty
Posts: 4,160
Default

Quote:
Originally Posted by BPBaker View Post
Phase button disappears on the mixer when enabled
Ah yes, 200%, right? I've left a mcp_phase_inv.png in there when its supposed to be inheriting from the tcp, great catch thanks.

My up to date version of the script is currently extremely broken (I'm teaching it to speak pink lines!) so there won't be a fix up for a while, but if you go into your themes folder, to Assembled_Theme_Resources > 200 and delete the mcp_phase_inv.png file in there, that'll fix it for now while I get my nonsense sorted.

Quote:
Originally Posted by BPBaker View Post
Minor shadow misalignment on some TCP/MCP boxes (more noticeable on light backgrounds)
Yeah that's a known issue (see post #1) and I think its a Reaper issue but need to find the time to get really really sure about that before I report it. Sorry about that.

Quote:
Originally Posted by EduSerra View Post
you mean Reaper install pre-release or Theme Assembler pre-release?
Now in full Reaper release:

v6.64 - July 13 2022
  • + Theme: improve rounding for knob stacks [p=2575187]

Quote:
Originally Posted by rotors View Post
could you please add this to your theme script so that is easy to change / rearrange the master button buttons, just like the track buttons?
Probably not, I'd like to keep the script focussed to the core features. I have provided this functionality, you just need to swap some lines in a text file which is very easy, or perhaps you could use Sexan's script.
__________________
The House of White Tie
White Tie is offline   Reply With Quote
Old 07-14-2022, 03:03 AM   #259
rotors
Human being with feelings
 
Join Date: Oct 2021
Posts: 6
Default

Quote:
Originally Posted by rotors View Post
Could someone please tell me if there is a option / way to change the button order positions for the master track? (FX, routing etc)
Yes, and there always has been, just not with this script. Look in the rtconfig.txt file for the instructions "MODDING WITH 'THEN'".

Thanks White Tie, I followed your advice, it took me a little while to figure it out, but swapped the lines in each section and its done. Thanks again for the info.
rotors is offline   Reply With Quote
Old 07-16-2022, 04:20 AM   #260
permeke
Human being with feelings
 
Join Date: Dec 2019
Posts: 443
Default

working well on OSX , except for the panning icon that doesn't show up in the tcp, no matter what layout I choose
permeke is offline   Reply With Quote
Old 07-16-2022, 06:24 AM   #261
daeavelwyn
Human being with feelings
 
daeavelwyn's Avatar
 
Join Date: Dec 2014
Posts: 434
Default

Hello,

How to get the last version 6.64 ? I downloaded the version linked in the first post but it seems to be the 6.23 and I just can't get the installation to work.

It seems related to a malformed path, as futher users already mentioned.
daeavelwyn is offline   Reply With Quote
Old 07-16-2022, 09:42 PM   #262
cool
Human being with feelings
 
Join Date: Dec 2017
Location: Sunny Siberian Islands
Posts: 597
Default

Quote:
Originally Posted by daeavelwyn View Post
How to get the last version 6.64 ? I downloaded the version linked in the first post but it seems to be the 6.23 and I just can't get the installation to work.

6.64 is about Reaper's version. This improvement is added in the Reaper.
cool is offline   Reply With Quote
Old 07-17-2022, 05:28 AM   #263
son.us
Human being with feelings
 
Join Date: Aug 2021
Location: germany
Posts: 5
Default showing off

Hello, all you fine people.

Since it was asked showing what we came up with, here we go..
Big thanks to White Tie for all the effort you put into the assembler, it`s exactly what I was looking for.
I kept it default-ish besides digging into the coloring of individual elements - of course I wasn`t a Logic-User before
I`m not 100% done yet though..

Kind Regards,
Filius


Last edited by son.us; 07-18-2022 at 03:12 AM. Reason: Keep post Up2Date
son.us is offline   Reply With Quote
Old 07-17-2022, 06:50 AM   #264
daeavelwyn
Human being with feelings
 
daeavelwyn's Avatar
 
Join Date: Dec 2014
Posts: 434
Default

Quote:
Originally Posted by cool View Post
6.64 is about Reaper's version. This improvement is added in the Reaper.
Oh, sorry, I misunderstood it. BTW, I still can't install the theme assembler...

Here is the error output for portable install: https://imgur.com/a/LqJrpa0

and here is the result for standard install ; https://imgur.com/a/BN98Bn7

I'm using Reaper 6.64 on windows10 1809 as a portable install AND as a default installation mode on the default Reaper path. and none of those work.

Any idea to debug this ?
daeavelwyn is offline   Reply With Quote
Old 07-17-2022, 07:37 AM   #265
daeavelwyn
Human being with feelings
 
daeavelwyn's Avatar
 
Join Date: Dec 2014
Posts: 434
Default

Ok, so, digging into the code and finally get it to work. Here are the stuff I change :

First of all, there are still path parsing issues. At line 1154 I put this :

Code:
local str = themes_path.."\\"..themeFolder.."\\"..'rtconfig.txt'
and at line 6 I put this :

Code:
themes_path = reaper.GetResourcePath() .. "\\ColorThemes"
So clearly, as a windows user, I manage backslashes manualy, which is a bad practice I know ^_^'

So, once I made this, the path was correctly reported by reaconsole BUT, rtconfig.txt was still not found, so I had to copy the files/folder from initial/* to reaper default colors and themes folder.

Then I ran the script and it worked.

My suggsestion would be to remove every slashs and backslashes hardcoded and find a better way to manage them. I know string parsing is just a PITA in Lua, so good luck

NOTE : of course it doesn't really work for portable install if you have also a standard install as the script will always report the standard install even when loaded into the portable install...
daeavelwyn is offline   Reply With Quote
Old 07-18-2022, 11:29 AM   #266
EduSerra
Human being with feelings
 
EduSerra's Avatar
 
Join Date: Apr 2021
Location: Colombia
Posts: 80
Default Meter not wide enough in MCP

Hello

I discovered this little error when changing the meter reading from Peaks to LUFS. When having 3 digits, the last one appears incomplete.

Maybe something I can fix in the rtconfig file?

Thanks

EduSerra is offline   Reply With Quote
Old 07-28-2022, 10:20 AM   #267
Gaetano
Human being with feelings
 
Join Date: Sep 2021
Posts: 17
Default

Quote:
Originally Posted by alxgvr View Post
This should be included in stock Reaper
I agree 100%. I hope in the near future this would be part of in stock Reaper!
__________________
i7-6700 CPU 3.40 GHz, 16GB Ram, Windows 10 Pro 20H2
Gaetano is offline   Reply With Quote
Old 08-10-2022, 06:05 PM   #268
persy
Human being with feelings
 
Join Date: Mar 2021
Posts: 13
Default cant find these

nevermind.. im dumb

Last edited by persy; 08-11-2022 at 02:58 AM.
persy is offline   Reply With Quote
Old 08-11-2022, 07:37 AM   #269
Chris Hurst Music
Human being with feelings
 
Chris Hurst Music's Avatar
 
Join Date: Mar 2017
Location: Wales, UK
Posts: 75
Default

Quote:
Originally Posted by Pink Wool View Post
Here's the theme I made:

https://stash.reaper.fm/theme/2833/D...ReaperThemeZip



It's bound to be a little wonky!
This is great. The mute button in the mixer isn't flat when I download it though..is it something that I have done wrong, or can I change it to match the rest?
Attached Images
File Type: png Screenshot 2022-08-11 at 15.36.12.png (15.5 KB, 31 views)
Chris Hurst Music is offline   Reply With Quote
Old 08-13-2022, 03:09 AM   #270
Pink Wool
Human being with feelings
 
Pink Wool's Avatar
 
Join Date: Apr 2020
Posts: 1,052
Default

Quote:
Originally Posted by Chris Hurst Music View Post
This is great. The mute button in the mixer isn't flat when I download it though..is it something that I have done wrong, or can I change it to match the rest?
It is but only on 100%. I'll see if I get the time to make it work on other sizes!
Pink Wool is offline   Reply With Quote
Old 08-13-2022, 04:00 AM   #271
Chris Hurst Music
Human being with feelings
 
Chris Hurst Music's Avatar
 
Join Date: Mar 2017
Location: Wales, UK
Posts: 75
Default

Quote:
Originally Posted by Pink Wool View Post
It is but only on 100%. I'll see if I get the time to make it work on other sizes!
Thanks.

I may have missed it in the thread, but is there a way for me to tweak this “tweaked” version using the script? If I run it from within this theme it asks me to load the original theme and switch to that, which I do not want to do, since I want to tweak this one.

This is all amazing though and thanks to White Tie and all for helping Reaper look more aesthetically pleasing, which was about the only think I didn’t like about it.
Chris Hurst Music is offline   Reply With Quote
Old 08-15-2022, 12:51 PM   #272
sonictim
Human being with feelings
 
sonictim's Avatar
 
Join Date: Feb 2020
Location: Los Angeles
Posts: 455
Default

I had to darken up the tracks a bit to make the icons more visible, but I'm loving this (mostly) default flat icon theme I made with the White Tie Script! Sharing per White Tie's request....

__________________
My Reapack Repository: I write scripts for my own personal use.
I offer no support, but if you find one that helps you, go for it!
sonictim is offline   Reply With Quote
Old 08-16-2022, 06:40 AM   #273
cool
Human being with feelings
 
Join Date: Dec 2017
Location: Sunny Siberian Islands
Posts: 597
Default

sonictim, looks great! And most of the elements are close to what I used in my theme. I love this flat minimalism.

This is how the beta version of my theme looks like. White Tie did a really impressive job!

I just added my volume and pan faders using KnobMan and changed some things in the code and recolored some elements. But the basis was given by WT Theme Assembler and it was very easy.

The only things I'm missing now are the flat Route elements in the mixer and the flat Mono button on the master bus.

cool is offline   Reply With Quote
Old 08-17-2022, 02:43 AM   #274
persy
Human being with feelings
 
Join Date: Mar 2021
Posts: 13
Default

dump question, but how do you get only the track number bar colored and keep the main tcp body grey?
persy is offline   Reply With Quote
Old 08-17-2022, 02:44 AM   #275
White Tie
Pixel Pusher
 
White Tie's Avatar
 
Join Date: Mar 2007
Location: Blighty
Posts: 4,160
Default

Quote:
Originally Posted by Chris Hurst Music View Post
Thanks.

I may have missed it in the thread, but is there a way for me to tweak this “tweaked” version using the script? If I run it from within this theme it asks me to load the original theme and switch to that, which I do not want to do, since I want to tweak this one.
The script has no intelligence, it checks you are using a theme called "Assembled_Theme.ReaperTheme" and if so it just reads and writes stuff to/from whatever it finds in a folder called "Assembled_Theme_Resources".

If you unpack a theme and give it those names, the script will believe you and carry on as normal.

Quote:
Originally Posted by cool View Post
Mono button on the master bus.
Ah yes, don't let me forget this exists.
__________________
The House of White Tie
White Tie is offline   Reply With Quote
Old 08-17-2022, 02:47 AM   #276
White Tie
Pixel Pusher
 
White Tie's Avatar
 
Join Date: Mar 2007
Location: Blighty
Posts: 4,160
Default

Quote:
Originally Posted by persy View Post
dump question, but how do you get only the track number bar colored and keep the main tcp body grey?
Click on the box to the right of the T-Shirt and the 88 number, choose 0 for both selected and unselected.

Note to self : change that number to almost anything else, good grief.
__________________
The House of White Tie
White Tie is offline   Reply With Quote
Old 08-17-2022, 10:54 AM   #277
permeke
Human being with feelings
 
Join Date: Dec 2019
Posts: 443
Default

Quote:
Originally Posted by cool View Post
sonictim, looks great! And most of the elements are close to what I used in my theme. I love this flat minimalism.

This is how the beta version of my theme looks like. White Tie did a really impressive job!

I just added my volume and pan faders using KnobMan and changed some things in the code and recolored some elements. But the basis was given by WT Theme Assembler and it was very easy.

The only things I'm missing now are the flat Route elements in the mixer and the flat Mono button on the master bus.


nice one. possible to share this to the really lazy ones like me ?
permeke is offline   Reply With Quote
Old 08-17-2022, 10:19 PM   #278
cool
Human being with feelings
 
Join Date: Dec 2017
Location: Sunny Siberian Islands
Posts: 597
Default

Quote:
Originally Posted by permeke View Post
nice one. possible to share this to the really lazy ones like me ?

Yeah why not. But some things may not work correctly, this is still an unfinished version.

Here: https://drive.google.com/file/d/1cXp...ew?usp=sharing
cool is offline   Reply With Quote
Old 08-17-2022, 11:14 PM   #279
Ricgus3
Human being with feelings
 
Join Date: May 2020
Posts: 12
Default

Can't get it to work I put the content into the folder but there is nothing showing up in the Actions menu?

EDit: Clicked on "New action and then load Script". Now it works I just missedf that small step!

Thanks a ton !"!!

Last edited by Ricgus3; 08-17-2022 at 11:20 PM.
Ricgus3 is offline   Reply With Quote
Old 08-18-2022, 03:29 PM   #280
permeke
Human being with feelings
 
Join Date: Dec 2019
Posts: 443
Default

Quote:
Originally Posted by cool View Post
Yeah why not. But some things may not work correctly, this is still an unfinished version.

Here: https://drive.google.com/file/d/1cXp...ew?usp=sharing
I like it so far. thanks
permeke is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 02:39 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.