Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER for macOS X

Reply
 
Thread Tools Display Modes
Old 12-24-2011, 08:41 AM   #1
123bpm
Human being with feelings
 
Join Date: Dec 2011
Posts: 39
Default hanging note after midi recording in OsX Snow Leopard

I am using a Kontrol 49, a Fireface UFX and record midi data for Trillian using Reaper, 32 Bit on a Macbook Pro with snow leopard.

I get a hanging note all the time after recording with input quantisation.

This makes the software unusable for me.

Any help?
123bpm is offline   Reply With Quote
Old 12-24-2011, 01:50 PM   #2
mrelwood
Human being with feelings
 
mrelwood's Avatar
 
Join Date: Nov 2006
Location: Finland
Posts: 1,281
Default

Does it help if you uncheck "Quantize note-offs" in the Track recording settings?
__________________
______Announcing__mrelwood plugins______
.. MacBook Pro 15" Late '13 .. Focusrite: Scarlett 6i6, Saffire Pro 24 DSP (+ADA8000) .. Behringer FCA610 .. Focal: Alpha 65, CMS 40, Listen Pro ..
mrelwood is offline   Reply With Quote
Old 12-24-2011, 02:31 PM   #3
123bpm
Human being with feelings
 
Join Date: Dec 2011
Posts: 39
Default

Quote:
Originally Posted by mrelwood View Post
Does it help if you uncheck "Quantize note-offs" in the Track recording settings?
This option wasn't active.

With the same audio interface and controller, but a win laptop,
no issues.
123bpm is offline   Reply With Quote
Old 12-24-2011, 03:55 PM   #4
mrelwood
Human being with feelings
 
mrelwood's Avatar
 
Join Date: Nov 2006
Location: Finland
Posts: 1,281
Default

Quote:
Originally Posted by 123bpm View Post
This option wasn't active.
What if you try with the option activated?
__________________
______Announcing__mrelwood plugins______
.. MacBook Pro 15" Late '13 .. Focusrite: Scarlett 6i6, Saffire Pro 24 DSP (+ADA8000) .. Behringer FCA610 .. Focal: Alpha 65, CMS 40, Listen Pro ..
mrelwood is offline   Reply With Quote
Old 12-24-2011, 11:56 PM   #5
123bpm
Human being with feelings
 
Join Date: Dec 2011
Posts: 39
Default

Quote:
Originally Posted by mrelwood View Post
What if you try with the option activated?
Meanwhile I have given up and de-installed Reaper on my MAC. Apart from this killing issue, the GUI of some plugins was not rendered. This program seems to be a PC program and the MAC version is like an adaptation, but it doesn't really work.

The point is that you don't always want the note off commands to be quantized and on a PC it simply works without hanging notes.

I had high hopes, because some plugins seem to work more CPU efficient in Reaper on a MAC compared to Logic. Now I will have to use Logic only on the MAC.
123bpm is offline   Reply With Quote
Old 12-25-2011, 04:00 AM   #6
mrelwood
Human being with feelings
 
mrelwood's Avatar
 
Join Date: Nov 2006
Location: Finland
Posts: 1,281
Default

Quote:
Originally Posted by 123bpm View Post
Meanwhile I have given up and de-installed Reaper on my MAC. Apart from this killing issue, the GUI of some plugins was not rendered. This program seems to be a PC program and the MAC version is like an adaptation, but it doesn't really work.
Reaper really does work. There are quite a few users using it professionally on a daily basis. Yes, there might be issues with some plugins, and if faced with a problem, some troubleshooting is needed. This is no different from any other DAW, or any software for that matter.

Quote:
Now I will have to use Logic only on the MAC.
No you don't. You can troubleshoot the issue.
__________________
______Announcing__mrelwood plugins______
.. MacBook Pro 15" Late '13 .. Focusrite: Scarlett 6i6, Saffire Pro 24 DSP (+ADA8000) .. Behringer FCA610 .. Focal: Alpha 65, CMS 40, Listen Pro ..
mrelwood is offline   Reply With Quote
Old 12-25-2011, 07:33 AM   #7
123bpm
Human being with feelings
 
Join Date: Dec 2011
Posts: 39
Default

Quote:
Originally Posted by mrelwood View Post
No you don't. You can troubleshoot the issue.
Troubleshooting in what kind of way? In this case,
I see a clear bug in the software, one very fundamental
one with no workaround (or if there is one, this would
likely kill the workflow).

Of course there are professional users, but

a) are they using Reaper on a Mac?
b) Do they work with Midi? Some of them might mostly record life music or mix music, where only audio processing is required.

Most people I know use a PC with Reaper.
On a PC it works great.

cheers.
123bpm is offline   Reply With Quote
Old 12-25-2011, 03:35 PM   #8
mrelwood
Human being with feelings
 
mrelwood's Avatar
 
Join Date: Nov 2006
Location: Finland
Posts: 1,281
Default

Quote:
Originally Posted by 123bpm View Post
Troubleshooting in what kind of way?
Try different options related to quantizing, try a different Midi source, try an older version of Reaper, and report the issue in the bug reports forum. What makes Reaper spectacular is how fast bugs are sometimes fixed. A few ones I have reported were fixed in two days.

Quote:
I see a clear bug in the software, one very fundamental
one with no workaround
I made some tests, and I was able to confirm the issue. The issue seems to be related to playback only (the notes play longer than they actually last), and can be avoided in atleast a few ways:
1) Enable "Quantize note-offs".
2) After recording, quantize the recorded Midi notes manually. This will make no difference to timing since the notes are already quantized anyway.

Quote:
Of course there are professional users, but
a) are they using Reaper on a Mac?
b) Do they work with Midi?
Yes, and yes. For example me. Must admit though, I have had no need for input quantize, so this issue has not bothered me.

I recommend you file a bug report in the discussion forum:
http://forum.cockos.com/forumdisplay.php?f=22
__________________
______Announcing__mrelwood plugins______
.. MacBook Pro 15" Late '13 .. Focusrite: Scarlett 6i6, Saffire Pro 24 DSP (+ADA8000) .. Behringer FCA610 .. Focal: Alpha 65, CMS 40, Listen Pro ..
mrelwood is offline   Reply With Quote
Old 12-26-2011, 08:12 AM   #9
123bpm
Human being with feelings
 
Join Date: Dec 2011
Posts: 39
Default

Quote:
Originally Posted by mrelwood View Post
I made some tests, and I was able to confirm the issue. The issue seems to be related to playback only (the notes play longer than they actually last), and can be avoided in atleast a few ways:
1) Enable "Quantize note-offs".
2) After recording, quantize the recorded Midi notes manually. This will make no difference to timing since the notes are already quantized anyway.
[/url]
thanks for taking time to confirm the bug!

I can send a report to that subforum.
123bpm is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 10:37 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.