Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 02-06-2024, 04:41 AM   #1
Human being with feelings
Join Date: Jan 2024
Location: Canada
Posts: 4
Default MIDI humanize bug when there's overlapping notes

Hey, I’ve been encountering what seems to be a bug in MIDI lately. So when there’s more than one of a given note, overlapping, this happens when humanizing other notes: it messes the timing of the overlapping notes, even when they're not selected. It doesn’t seem to matter which notes are selected for humanize (with the humanization window set to “selected notes”). It messes up the timing of the overlapping notes anyway. Interestingly enough, when I try to humanize only the overlapping notes by themselves, it doesn’t mess up the timing. Also, quantize doesn't have this bug either, regardless of if the overlapping notes are selected or not.

Please watch this Dropbox video for a better demonstration of the bug

This has to be a bug. I had seen it first in Reaper 6.83, and thought maybe it's fixed in R7. It is not. I'm on the latest version at the moment (7.09) and the issue is still there. I have also confirmed this bug with another Reaper user (also in R7) on his own machine.

To reproduce the bug, create a new MIDI item and open the MIDI editor. Insert some notes with snap on (doesn't matter where or what notes). Then, go to rectangular notes mode, and insert a note, let's say this is a snare hit (no VST needed tho). And say you want to create a snare flam. Ctrl+click drag to duplicate the note to the next grid space (has to be on the same note), then shift+click drag to offset it back a little bit, so its note on is after the initial "snare" note, but it's not on the next grid space either, it's somewhere in between, and this creates the overlap between the two. And again, the overlapping notes have to be on the same note to reproduce the bug. Then, select ANY note in the MIDI item, other than the two overlapping notes. Watch what happens to the latter of the two overlapping notes as you open up humanize (H by default). You'll see the bug happen before even touching any of the humanize settings. An important note, if you have the setting in MIDI Options, "Automatically correct overlapping notes" checked, you won't see this bug, but it is unchecked by default. Leaving it checked seems to be a decent workaround, but it can cause some other problems when copying notes over, in some situations.

I have also attached a Reaper project (it seems to be part of the bug report requirements). Open up the MIDI item, select any notes other than the D#2's on measure 2, and watch what happens to the 2nd D#2 on measure 2 when you bring up the humanize window.

And lastly, I'm on Windows 10 Pro, and Reaper 7.09 at the moment.

Thanks in advance!
Attached Files
File Type: rpp MIDIHumanizeBug.rpp (4.5 KB, 30 views)
TheFlyingWhale is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT -7. The time now is 05:19 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.