Old 02-27-2017, 06:50 AM   #2241
gpunk_w
Human being with feelings
 
Join Date: Dec 2010
Posts: 3,144
Default

Quote:
Originally Posted by EvilDragon View Post
Ah, sorry I had it confused then. Well then - cool work on that theme of yours, I say!
Cant take much credit, it looks like Maschine, credit to NIs designers
__________________
Reaper scripters, that is all !!!!!!!!!!!!!!!!
gpunk_w is offline   Reply With Quote
Old 02-27-2017, 07:16 AM   #2242
Gerry P
Human being with feelings
 
Gerry P's Avatar
 
Join Date: Jan 2009
Location: Ontario, Canada
Posts: 1,327
Default

Quote:
Originally Posted by gpunk_w View Post
This is a Maschine theme because i prefer Maschine... no its not available because i only fix things on it when i use a particular feature of Reaper and something jumps out at me, so it really isn't a full theme yet.
too bad... I agree, Maschine is very nice to work with and very easy on the eyes.
__________________
The future ain't what it used to be. Yogi Berra
Gerry P is offline   Reply With Quote
Old 02-28-2017, 02:21 AM   #2243
Prophet08
Human being with feelings
 
Join Date: Mar 2015
Location: London, UK
Posts: 18
Default Issue with Reaper 5.34 and SWS 2.8.3.0

Hi

I installed Reaper v5.34 abd SWS 2.8.3.0 last night to try out Marker Macros but the SWS extentions are not loading. It was installed into the C:/Program Files/REAPER/Plugins folder but the extentions menu does not appear in Reaper when restarted so I guess Reaper does not know it is there. There are no error messages or warnings either on startup or during or installation alsthough I am using this on and XP machine as a tryout before trying on my main machine (Windows 10)

Any help appreciated. I suspect I must be doing something stupid.

Many thanks - Mark

I have also now tired Repear versions v5.1 and v4.78 and SWS 2.4.0.10and 2.5.2.0 all with the same results

Hi, I have tried removing REAPER and SWS and redownloading and enstalling again.Reapers works fine, no issues there at all. Just no sign of the SWS extentions. I have SP2 and I am the administrator and the files are listed as owner "Everyone". My guess is Reaper can't see the SWS DLL or execute it but I cannot work out why :/

I want to try using using Marker Actions with ReaMididCOntrol to make a cue list for reconfiguring Midi devices during a show.In principle it looks to be possible, if I can get SWS Extentions working.

Is there another directory the SWS DLL should be in other than the /REAPER/Plugins directory? I would have though this DLL should be with the other REAPER DLL as SWS is not a VST?

ATB - M

Last edited by Prophet08; 02-28-2017 at 05:05 AM.
Prophet08 is offline   Reply With Quote
Old 02-28-2017, 06:10 AM   #2244
Prophet08
Human being with feelings
 
Join Date: Mar 2015
Location: London, UK
Posts: 18
Default SWS DLL appears to be falling over

Hi ,

I been watching the scanning information on first startup after installing both Reaper 5.34 and SWS 2.8.3.0 and I can see that Reaper tries to load the SWS DLL so I now think the DLL is falling over. Does anyone know where to look for an error log or how to switch on error logging ?

ATB - M
Prophet08 is offline   Reply With Quote
Old 03-01-2017, 01:27 AM   #2245
declan32001
Human being with feelings
 
Join Date: Feb 2017
Posts: 11
Default

Quote:
Originally Posted by Prophet08 View Post
Hi ,

I been watching the scanning information on first startup after installing both Reaper 5.34 and SWS 2.8.3.0 and I can see that Reaper tries to load the SWS DLL so I now think the DLL is falling over. Does anyone know where to look for an error log or how to switch on error logging ?

ATB - M
I was wondering about that too. Also where can I find the Sample Project Files for SWS?
declan32001 is offline   Reply With Quote
Old 03-01-2017, 02:33 AM   #2246
amagalma
Human being with feelings
 
Join Date: Apr 2011
Posts: 1,076
Default

Did you install the appropriate sws version? (x86, x64) It has to match with your version of Reaper
amagalma is online now   Reply With Quote
Old 03-01-2017, 06:54 AM   #2247
Prophet08
Human being with feelings
 
Join Date: Mar 2015
Location: London, UK
Posts: 18
Default

Quote:
Originally Posted by amagalma View Post
Did you install the appropriate sws version? (x86, x64) It has to match with your version of Reaper
Yes, I made sure I downloaded the correct version(s)
Prophet08 is offline   Reply With Quote
Old 03-01-2017, 11:29 AM   #2248
vitalker
Human being with feelings
 
vitalker's Avatar
 
Join Date: Dec 2012
Posts: 3,003
Default

Quote:
Originally Posted by Prophet08 View Post
Hi

I installed Reaper v5.34 abd SWS 2.8.3.0
Try to use the last version (2.8.7): http://forum.cockos.com/showthread.php?t=153702
vitalker is offline   Reply With Quote
Old 03-01-2017, 01:19 PM   #2249
Prophet08
Human being with feelings
 
Join Date: Mar 2015
Location: London, UK
Posts: 18
Default

Quote:
Originally Posted by vitalker View Post
Try to use the last version (2.8.7): http://forum.cockos.com/showthread.php?t=153702
Tried 2.8.7.0 no difference. Still not loading.
Prophet08 is offline   Reply With Quote
Old 03-01-2017, 01:33 PM   #2250
lachrimae
Human being with feelings
 
lachrimae's Avatar
 
Join Date: May 2010
Location: Austin, TX
Posts: 741
Default

It sounds like you've installed in the correct location, but just to double check:

Options -> Show Reaper resource path in explorer/finder

Is that the directory where you pointed SWS when installing? Was Reaper closed when you installed SWS?
lachrimae is offline   Reply With Quote
Old 03-01-2017, 03:28 PM   #2251
Pet
Human being with feelings
 
Pet's Avatar
 
Join Date: Nov 2015
Location: Germany
Posts: 930
Default

My 2 cents: I started the SWS-Installer (latest pre 64bit) to look what it does, and it wants to install it here: "C:\Program Files\REAPER (x64)" by default. I just installed it without changing anything.

I then looked in that folder and it is in: "C:\Program Files\REAPER (x64)\Plugins\reaper_sws64.dll".

HTH
__________________
If the v5 Default Theme is too bright for you take a gander at my mod of it: Default v5 Dark Theme
Pet is offline   Reply With Quote
Old 03-01-2017, 03:45 PM   #2252
EvilDragon
Human being with feelings
 
EvilDragon's Avatar
 
Join Date: Jun 2009
Location: Croatia
Posts: 19,771
Default

^^^^

That's where it has to be, yep.
EvilDragon is online now   Reply With Quote
Old 03-02-2017, 06:11 AM   #2253
Prophet08
Human being with feelings
 
Join Date: Mar 2015
Location: London, UK
Posts: 18
Default

Quote:
Originally Posted by lachrimae View Post
It sounds like you've installed in the correct location, but just to double check:

Options -> Show Reaper resource path in explorer/finder

Is that the directory where you pointed SWS when installing? Was Reaper closed when you installed SWS?
The Install directory is the default. So C:/Program Files/REAPER and the file is in C:/Program Files/REAPER/Plugins after installation.
Prophet08 is offline   Reply With Quote
Old 03-02-2017, 11:41 AM   #2254
Pet
Human being with feelings
 
Pet's Avatar
 
Join Date: Nov 2015
Location: Germany
Posts: 930
Default

Quote:
Originally Posted by Prophet08 View Post
The Install directory is the default. So C:/Program Files/REAPER and the file is in C:/Program Files/REAPER/Plugins after installation.
Just to clarify: which installation is this? 32bit on XP or 64bit on Win10? Or something else?
BTW, the dll is NOT in the Reaper resource path!
__________________
If the v5 Default Theme is too bright for you take a gander at my mod of it: Default v5 Dark Theme
Pet is offline   Reply With Quote
Old 03-03-2017, 02:56 AM   #2255
Prophet08
Human being with feelings
 
Join Date: Mar 2015
Location: London, UK
Posts: 18
Default

Quote:
Originally Posted by Pet View Post
Just to clarify: which installation is this? 32bit on XP or 64bit on Win10? Or something else?
BTW, the dll is NOT in the Reaper resource path!
Yes this is a 32bit installation on XP. Where should the DLL be then if it is not in the correct place?
Prophet08 is offline   Reply With Quote
Old 03-03-2017, 05:52 AM   #2256
Pet
Human being with feelings
 
Pet's Avatar
 
Join Date: Nov 2015
Location: Germany
Posts: 930
Default

On my XP it's in "C:\Program Files\REAPER\Plugins" and the name is "reaper_sws.dll".
I just started my old XP machine, updated to Reaper v5.35 and installed "sws-v2.8.7.0-install.exe" without any problems. Had still SWS v2.8.3.0 on it, but the latest pre works.
BTW, the latest SWS that works with Reaper v4.78 is v2.7.0.0. (Portable Reaper v4.78 64bit on my system)

If I where you, I would completely uninstall all SWS stuff that may be there meanwhile (you mentioned that you tried several Reaper and SWS versions). Then install it again. DO NOT copy/paste something you find somewhere! Start from scratch.

HTH, good luck, and tell us what happens.
__________________
If the v5 Default Theme is too bright for you take a gander at my mod of it: Default v5 Dark Theme

Last edited by Pet; 03-03-2017 at 05:58 AM.
Pet is offline   Reply With Quote
Old 03-03-2017, 06:05 AM   #2257
Prophet08
Human being with feelings
 
Join Date: Mar 2015
Location: London, UK
Posts: 18
Default

Quote:
Originally Posted by Pet View Post
On my XP it's in "C:\Program Files\REAPER\Plugins" and the name is "reaper_sws.dll".
I just started my old XP machine, updated to Reaper v5.35 and installed "sws-v2.8.7.0-install.exe" without any problems. Had still SWS v2.8.3.0 on it, but the latest pre works.
BTW, the latest SWS that works with Reaper v4.78 is v2.7.0.0.

If I where you, I would completely uninstall all SWS stuff that may be there meanwhile (you mentioned that you tried several Reaper and SWS versions). Then install it again. DO NOT copy/paste something you find somewhere! Start from scratch.

HTH, good luck, and tell us what happens.
Thanks for the information PET, I have completely uninstalled Reaper and SWS and reinstalled properly several times now. I can see the reaper_sws.dll named in the startup scan so I know Reaper is finding the DLL. There must be something unusual about this machine I guess causing it to fail. I can use Reaper ok so I just have to live without the benefits of SWS.
Prophet08 is offline   Reply With Quote
Old 03-03-2017, 08:24 AM   #2258
WyattRice
Human being with feelings
 
WyattRice's Avatar
 
Join Date: Sep 2009
Location: Virginia
Posts: 1,789
Default

Quote:
Originally Posted by Prophet08 View Post
Thanks for the information PET, I have completely uninstalled Reaper and SWS and reinstalled properly several times now. I can see the reaper_sws.dll named in the startup scan so I know Reaper is finding the DLL. There must be something unusual about this machine I guess causing it to fail. I can use Reaper ok so I just have to live without the benefits of SWS.
Have you tried to reset Reaper to the default settings?

Start> Programs> Reaper, then choose "REAPER (reset configuration to factory defaults)"
WyattRice is offline   Reply With Quote
Old 03-03-2017, 09:39 AM   #2259
EvilDragon
Human being with feelings
 
EvilDragon's Avatar
 
Join Date: Jun 2009
Location: Croatia
Posts: 19,771
Default

Quote:
Originally Posted by Prophet08 View Post
I can use Reaper ok so I just have to live without the benefits of SWS.
Or you can ditch XP
EvilDragon is online now   Reply With Quote
Old 03-03-2017, 09:43 AM   #2260
richie43
Human being with feelings
 
Join Date: Dec 2009
Location: Minnesota
Posts: 8,462
Default

Quote:
Originally Posted by EvilDragon View Post
Or you can ditch XP
Best advice ever.

__________________
Quote:
Originally Posted by serr
Stay the heck away from Geek Squad and Worst Purchase.
http://soundyaudio.com/ The Sounds of the Hear and Now
richie43 is offline   Reply With Quote
Old 03-03-2017, 09:47 AM   #2261
wjmwpg
Human being with feelings
 
wjmwpg's Avatar
 
Join Date: Feb 2017
Location: Winnipeg, Manitoba, Canada
Posts: 122
Default

I'm just curious, but does Windows sometimes suffer from the same file/folder permission issues that can cause these kinds of hiccups in OSX?
__________________
Switched to Reaper on 19FEB17 after a decade+ on Logic Pro.
wjmwpg is offline   Reply With Quote
Old 03-03-2017, 01:01 PM   #2262
Pet
Human being with feelings
 
Pet's Avatar
 
Join Date: Nov 2015
Location: Germany
Posts: 930
Default

Quote:
Originally Posted by Prophet08 View Post
...I have completely uninstalled Reaper and SWS and reinstalled properly several times now...
Have you also deleted or at least removed your Reaper User Folder? Recommended to an USB stick which you then unplug, with all files, cause the ini-files may include some orphaned entries. Then a fresh Reaper install.

My last idea...
__________________
If the v5 Default Theme is too bright for you take a gander at my mod of it: Default v5 Dark Theme
Pet is offline   Reply With Quote
Old 03-05-2017, 01:51 AM   #2263
Prophet08
Human being with feelings
 
Join Date: Mar 2015
Location: London, UK
Posts: 18
Default

Thanks for trying Guys.

1. Permissions checked ok
2. Reset to default tried
3. Complete removal including user folders tried
4. Ditch XP - done

I have to maintain this laptop as XP due to some legacy software but have acquired a cheep i3 with Windows 7 64 from eBay which works fine.
Prophet08 is offline   Reply With Quote
Old 03-05-2017, 01:12 PM   #2264
Vincent Sermonne
Human being with feelings
 
Vincent Sermonne's Avatar
 
Join Date: Feb 2009
Location: Marseille France
Posts: 5,077
Default The Snapshot recall delete the sends

When I call a snapshot, sends for the track are deleted. Here is the track template, without the samples it works.

https://dl.dropboxusercontent.com/u/...RTrackTemplate



Someone can try and confirm ? thank's !
__________________
Vincent
http://www.tchackpoum.fr

Last edited by Vincent Sermonne; 03-06-2017 at 06:06 AM.
Vincent Sermonne is offline   Reply With Quote
Old 03-13-2017, 09:23 PM   #2265
sws
Code Monkey
 
sws's Avatar
 
Join Date: Sep 2007
Location: Madison, WI
Posts: 850
Default

Check check... testing 123... Is this thing on?

I figured before the lynch mob arrived at my front door I should post an updated build. So I did.
sws is offline   Reply With Quote
Old 03-13-2017, 09:40 PM   #2266
zappadave
Human being with feelings
 
zappadave's Avatar
 
Join Date: Jan 2008
Posts: 1,209
Default

Welcome back......good news
__________________
Music is the best
เพลง ที่ดีที่สุดคือ
zappadave is online now   Reply With Quote
Old 03-13-2017, 09:43 PM   #2267
Lokasenna
Human being with feelings
 
Lokasenna's Avatar
 
Join Date: Sep 2008
Location: The vast, frozen wasteland of western Canadia.
Posts: 4,239
Default

Welcome back. Hope your machete's sharp.
__________________
Currently working away from home; don't expect timely responses from me.
Default 5.0 Nitpicky Edition / GUI tutorial for Lua / GUI library for Lua scripts / Theory Helper / Radial Menu / Donate / ReaPack
Lokasenna is offline   Reply With Quote
Old 03-13-2017, 10:34 PM   #2268
tweed
Human being with feelings
 
Join Date: Dec 2006
Posts: 595
Default

With the new version out today - i got the most wonderful feeling - i started feeling - D O N A T E - today's a perfect 10 for me! GRRREAT thanks! - best wishes to everyone
tweed is offline   Reply With Quote
Old 03-14-2017, 12:57 AM   #2269
chumbo
Human being with feelings
 
Join Date: Apr 2015
Location: Brussels, Belgium
Posts: 413
Default

WOW, this is so awesome! Really glad this isn't defunct!
Does this mean continued support is back for good or will we have to wait another year or so for future updates?
chumbo is offline   Reply With Quote
Old 03-14-2017, 01:15 AM   #2270
siehorst
Human being with feelings
 
siehorst's Avatar
 
Join Date: Mar 2009
Posts: 302
Default

Quote:
Originally Posted by sws View Post
I hope everyone is well! -SWS
OK, you are well, and that is the best!
...
Thank's to your cat :-) .
siehorst is offline   Reply With Quote
Old 03-14-2017, 02:01 AM   #2271
vanhaze
Human being with feelings
 
vanhaze's Avatar
 
Join Date: Jul 2012
Location: Netherlands
Posts: 3,839
Default

Quote:
Originally Posted by sws View Post
Check check... testing 123... Is this thing on?

I figured before the lynch mob arrived at my front door I should post an updated build. So I did.
You just made my day, thanks a million !
vanhaze is offline   Reply With Quote
Old 03-14-2017, 02:08 AM   #2272
Fabian
Human being with feelings
 
Fabian's Avatar
 
Join Date: Sep 2008
Location: Sweden
Posts: 5,061
Default

Quote:
Originally Posted by sws View Post
Check check... testing 123... Is this thing on?

I figured before the lynch mob arrived at my front door I should post an updated build. So I did.
Thank you!
Thank you so much.

I just now tried to donate, but all I get is that "Some required information is missing or incomplete. Please correct your entries and try again." It all looks fine to me, and it doesn't tell me what or where... Sorry.
__________________
// MVHMF
I never always did the right thing, but all I did wasn't wrong...

Last edited by Fabian; 03-14-2017 at 02:14 AM.
Fabian is offline   Reply With Quote
Old 03-14-2017, 02:10 AM   #2273
stereolost
Human being with feelings
 
stereolost's Avatar
 
Join Date: Mar 2015
Location: Moscow, Russia
Posts: 205
Default

Happy to see it live and breath)
stereolost is offline   Reply With Quote
Old 03-14-2017, 03:28 AM   #2274
Lorbakounet
Human being with feelings
 
Lorbakounet's Avatar
 
Join Date: Mar 2015
Posts: 112
Default

Quote:
Originally Posted by sws View Post
Check check... testing 123... Is this thing on?

I figured before the lynch mob arrived at my front door I should post an updated build. So I did.
Wow ! I had burning ears from the sound of relief of at least billions of SWS raper users right now
Lorbakounet is online now   Reply With Quote
Old 03-14-2017, 03:37 AM   #2275
X-Raym
Human being with feelings
 
X-Raym's Avatar
 
Join Date: Apr 2013
Location: France
Posts: 4,309
Default

It's alive, IT'S ALIVE !




--
Let us know if you need help for whatever reason, kickstart campaign, bugs testing to help you close github issues which may not be needed anymore etc... :P
X-Raym is offline   Reply With Quote
Old 03-14-2017, 04:19 AM   #2276
Pet
Human being with feelings
 
Pet's Avatar
 
Join Date: Nov 2015
Location: Germany
Posts: 930
Default

Tim, you are my hero!!!!
THANK YOU!!!
__________________
If the v5 Default Theme is too bright for you take a gander at my mod of it: Default v5 Dark Theme
Pet is offline   Reply With Quote
Old 03-14-2017, 04:26 AM   #2277
citizenkeith
Human being with feelings
 
Join Date: Jun 2014
Location: Ohio
Posts: 535
Default

Many thanks!
citizenkeith is online now   Reply With Quote
Old 03-14-2017, 05:06 AM   #2278
Mercado_Negro
Moderator
 
Mercado_Negro's Avatar
 
Join Date: Aug 2007
Location: Caracas, Venezuela
Posts: 8,124
Default

Thanks, Tim!
__________________
Pressure is what turns coal into diamonds - Michael a.k.a. Runaway
Mercado_Negro is offline   Reply With Quote
Old 03-14-2017, 06:57 AM   #2279
nofish
Human being with feelings
 
nofish's Avatar
 
Join Date: Oct 2007
Location: home is where the heart is
Posts: 7,306
Default

nofish is offline   Reply With Quote
Old 03-14-2017, 07:30 AM   #2280
heda
Human being with feelings
 
heda's Avatar
 
Join Date: Jun 2012
Location: Spain
Posts: 4,451
Default

Excellent news!
__________________
HeDaScripts for REAPER | VIP Donations
heda is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 06:26 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.