Old 04-04-2018, 11:25 AM   #1
Triode
Human being with feelings
 
Triode's Avatar
 
Join Date: Jan 2012
Posts: 527
Default v5.79pre7 - April 4 2018

v5.79pre7 - April 4 2018
+ Localization: improve various localized string formats [p=1974919]
+ Localization: various fixes [p=1974917]
+ MIDI: never sort events based on anything but time position [t=205082]
__________________
Brush and Beater Drums Online: www.outoftheboxdrums.co.uk
Triode is offline   Reply With Quote
Old 04-04-2018, 11:45 AM   #2
juliansader
Human being with feelings
 
Join Date: Jul 2009
Posts: 2,692
Default

Quote:
Originally Posted by Triode View Post
+ MIDI: never sort events based on anything but time position [t=205082]
This update appears to fix the "adjacent note gets deleted when changing channel" bug!

The "adjacent note gets deleted when pasting" bug, which seems superficially similar, is still happening:

juliansader is offline   Reply With Quote
Old 04-05-2018, 01:03 AM   #3
ivansc
Human being with feelings
 
Join Date: Aug 2007
Location: Near Cambridge UK and Near Questembert, France
Posts: 18,889
Default

Quote:
Originally Posted by Triode View Post
+ MIDI: never sort events based on anything but time position [t=205082]

YAYYYYYY!!!!!
__________________
Brexit Schmexit. Lets have a violent revolution instead. Bagsy the first go with a nuke! (Here, Moggy Moggy...)
ivansc is offline   Reply With Quote
Old 04-05-2018, 06:15 AM   #4
Soli Deo Gloria
Human being with feelings
 
Soli Deo Gloria's Avatar
 
Join Date: Oct 2013
Location: Buenos Aires, Argentina
Posts: 895
Default

I am working with the Notation Editor right now and I find an annoying bug (I allow myself to post this here since I see you have been dealing in this pre with the notation editor) :

When you undo something while entering notes or other tasks, the voicing is completely messed (it has also just happened while changing the channel of some notes. Just try to enter notes in different channels and voice them (for example, channels 1 and 2 on the upper staff and 3 and 4 on the lower one). Undo, redo and undo again on repeated occassions and you´ll most probably see what I´m talking about.

Edit : I attach now a test project, in which I voiced channel 1 upwards and channel 2 downwards. When you open it, you´ll most probably see it messed up. When you set the voice again as I did and you duplicate the track, the voicing of the new track is also messed.Even when I get in and out of the editor the voicing is wrecked (!!!)

Edit 2 : I can confirm now this was introduced in pre 7. It just doesn´t happen in pre 6

(Sorry for this, but I can´t avoid commenting by the way that it would be mandatory for all of us who enter notes with a keyboard controller to have an action available to set the staff we have just clicked for inserting new events. It´s simply painful (to say the least)when you want to write things quicly here and there to have to jump continuously from the score to the track list in the editor to change the staff for entering notes)
Attached Files
File Type: rpp Notation Bug.RPP (5.2 KB, 28 views)

Last edited by Soli Deo Gloria; 04-05-2018 at 06:34 AM.
Soli Deo Gloria is offline   Reply With Quote
Old 04-05-2018, 07:39 AM   #5
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 12,389
Default

Quote:
Originally Posted by Soli Deo Gloria View Post
I am working with the Notation Editor right now and I find an annoying bug (I allow myself to post this here since I see you have been dealing in this pre with the notation editor) :

When you undo something while entering notes or other tasks, the voicing is completely messed (it has also just happened while changing the channel of some notes. Just try to enter notes in different channels and voice them (for example, channels 1 and 2 on the upper staff and 3 and 4 on the lower one). Undo, redo and undo again on repeated occassions and you´ll most probably see what I´m talking about.

Edit : I attach now a test project, in which I voiced channel 1 upwards and channel 2 downwards. When you open it, you´ll most probably see it messed up. When you set the voice again as I did and you duplicate the track, the voicing of the new track is also messed.Even when I get in and out of the editor the voicing is wrecked (!!!)

Edit 2 : I can confirm now this was introduced in pre 7. It just doesn´t happen in pre 6
Thanks, fixing!
Justin is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 04:38 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.