Old 02-26-2020, 08:13 PM   #1
gfd
Human being with feelings
 
Join Date: Feb 2020
Posts: 2
Default MIDI Channel Filter

Greetings,

I am new to Reaper. I have a controller with 2 keyboards (drawbar organ clone). I have it setup to transfer notes on channel 2 (upper) and channel 3 (lower). Control data is sent over channel 1.

I have two instrument tracks setup: Synthmaster One and SampleTank 4. SampleTank 4 is multi timbral and so I can set the Input:MIDI channel to OMNI and the channel that it receives notes on, in this case 3, internally.

Synth One is not multi timbral, so I have to filter the channel input externally. So I have Synth One receiving notes on channel 2 and SampleTank on 3. Looking at the MIDI in options in the track, I see either a single channel, or all.

If I go for one channel on Synth One, and I choose the channel to receive notes (2), the instrument plays the notes I press on the upper keyboard. Problem there is that channel 1 is filtered out and I can't send CC messages to the instruments.

If I choose OMNI, the instrument receives note and CC data, but then because Synth One cannot filter channels internally, it receives all the data from the controller. So it plays no matter which keyboard I'm pressing. I can't have it walking on SampleTank.

Being new, I'm not totally sure where to look for the solution. I installed the MIDI routing matrix JS plugin above Synth One in the effects rack, but it's not working. Synth One still plays no matter which keyboard I'm using. Not a knock on the plugin, I'm operating in ignorance here.

Is there a Reaper configuration option I've overlooked? Should MIDI routing matrix do the job? If so, how do you set it up and configure? I also tried PizMidi Channel Filter and Midi Polysher. Is there another plugin that can be added to the track to filter out MIDI channels I don't want transmitting to the instrument. If all else fails, how do I workaround this?

I would appreciate your help and I'll say thanks in advance,

Graham
gfd is offline   Reply With Quote
Old 02-26-2020, 11:31 PM   #2
gfd
Human being with feelings
 
Join Date: Feb 2020
Posts: 2
Default

I thought I'd bump my thread. I seem to have found a solution to the issue.

I set up a third track and set MIDI input to OMNI from the controller. I then inserted a MIDI channel filter and filtered out everything other than channel 1 (control) and channel 3 (notes).

I then setup a send from that track to the track containing Synthmaster One. Synthmaster One is now getting data through the control channel and the upper
keyboard only, and is no longer walking on the synth in the other track.

Thanks for reading and I look forward to taking advantage of your time and talent as I learn how to use this software.

Graham
gfd is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 08:41 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.