Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 03-02-2018, 09:29 AM   #1
zosoaudo007
Human being with feelings
 
Join Date: Jul 2017
Posts: 24
Default Bug: Editing script in external editor opens incorrectly

This is for Sublime Text 3. If the script name has spaces in it, then it fails to open properly in Sublime 3. It opens multiple blank tabs which are defined by how many spaces are in the filename. Very odd.

For example: "Script A" won't open properly and will open two blank tabs, but "Script_A" works well.

This also occurs if the script is in a subfolder.

Repro steps:
- Set up Reaper to use Sublime text as an external editor for LUA and EEL files
- Edit any of these scripts from the Action Menu
- Select Sublime Text
- Note that the script is not opened if it has spaces in it (or is in a subfolder).
zosoaudo007 is offline   Reply With Quote
Old 03-02-2018, 11:18 AM   #2
X-Raym
Human being with feelings
 
X-Raym's Avatar
 
Join Date: Apr 2013
Location: France
Posts: 6,031
Default

I confirm the issue, I have the same with Atom code editor as external editor, on Windows.

It is a old bug I cant even figure when it appears.
X-Raym is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 02:41 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.