Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 03-12-2014, 09:06 AM   #1
Reaktor:[Dave]
Human being with feelings
 
Reaktor:[Dave]'s Avatar
 
Join Date: Jun 2010
Location: Berlin
Posts: 458
Default Reapeaks causing GUI lags at certain zoom levels

Download this file. Optionally load factory settings.

Open the project "GUI lagging". Make sure that all tracks are at minimum height and reapeaks are displayed. Maximize Reaper, hide the docker.
  • Scroll up/down to get some scrambling on the TCP
  • Scrolling left/right (ALT+Left/Right) or by hand (CTRL+ALT+SHIFT+LeftDrag) lags extremely
  • Zoom in or out (horizontally) and the lag is gone.
-> Lag only occurs on certain horizontal zoom-levels and depends on the amount of items displayed. (so for you it may not lag because your screen is at 1280x720)

Open "GUI lagging less". It's basically the same project as the one before, just the media item is wav instead of flac.
  • Scrolling (esp. by hand) is much more responsive.
-> Lag decreases using wave files.

So there are two bugs:
  1. Certain horizontal zoom levels can heavily decrease GUI performance
  2. Reapeaks of wav-files seem to perform better than reapeaks of compressed audio

Can you reproduce this?

Last edited by Reaktor:[Dave]; 03-13-2014 at 03:14 AM.
Reaktor:[Dave] is offline   Reply With Quote
Old 03-18-2014, 05:11 AM   #2
Reaktor:[Dave]
Human being with feelings
 
Reaktor:[Dave]'s Avatar
 
Join Date: Jun 2010
Location: Berlin
Posts: 458
Default

Can someone verify?
Reaktor:[Dave] is offline   Reply With Quote
Old 03-26-2014, 03:08 AM   #3
Reaktor:[Dave]
Human being with feelings
 
Reaktor:[Dave]'s Avatar
 
Join Date: Jun 2010
Location: Berlin
Posts: 458
Default

push.
Reaktor:[Dave] is offline   Reply With Quote
Old 03-26-2014, 05:08 AM   #4
musicbynumbers
Human being with feelings
 
musicbynumbers's Avatar
 
Join Date: Jun 2009
Location: brighton, uk
Posts: 12,744
Default

Confirmed!

Need to check VLC against FFMPEG and see if it's the codecs in the version of VLC I use but if it happens on all of them then I'm hoping Christophe could have a look
__________________
subproject FRs click here
note: don't search for my pseudonym on the web. The "musicbynumbers" you find is not me or the name I use for my own music.
musicbynumbers is offline   Reply With Quote
Old 03-26-2014, 06:11 AM   #5
Tod
Human being with feelings
 
Tod's Avatar
 
Join Date: Jan 2010
Location: Just outside of Glacier National Park
Posts: 12,601
Default

I can't be sure but I think this problem might be related to a problem that Soli Deo Gloria and I were having in the Midi Editor.

http://forum.cockos.com/showthread.php?t=119410
__________________
Kontakt Vid Tutorials->Create Outputs / Create Templates -|- SMDrums Free drums -|- Elk Video Productions -|- Tod's Music
Tod is offline   Reply With Quote
Old 03-26-2014, 06:18 AM   #6
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 12,427
Default

It's not reapeaks that are the problem, the problem is that at a certain zoom level it switches to reading a copy of the underlying video file to get audio information, and that ends up slow (because it's coming from the video container). So maybe we can come up with a way of getting audio more quickly from video files, but I don't know.
Justin is offline   Reply With Quote
Old 03-26-2014, 06:36 AM   #7
Reaktor:[Dave]
Human being with feelings
 
Reaktor:[Dave]'s Avatar
 
Join Date: Jun 2010
Location: Berlin
Posts: 458
Default

Thank you for your replies and thank you Justin for your explanation!

This is also happening with audio files, not video only (check my project file in the first post). Wouldn't it make sense to keep some peak stuff in memory when hitting these zoom levels instead of re-reading the data from HDD all the time? This way, the lag would only occur when zooming in and not while editing.

What could improve the video situation: use wav as audio codec or completely remove audio from video and put it in as wav-file.
Reaktor:[Dave] is offline   Reply With Quote
Old 03-26-2014, 06:50 AM   #8
musicbynumbers
Human being with feelings
 
musicbynumbers's Avatar
 
Join Date: Jun 2009
Location: brighton, uk
Posts: 12,744
Default

Thanks Justin for the reply.

Reaktor Dave might be on to something there. Especially if other types of files are doing it too.

Ironically, I don't often need the audio from the video so for me, the first thing would be an option (maybe in source properties) to mute/hide audio from the video track. If I do need the video audio as reference, I could copy the the video to a new track and bounce it to be just audio and hide/mute audio on the actual video item (with a new source properties tick box) which would help a lot.
__________________
subproject FRs click here
note: don't search for my pseudonym on the web. The "musicbynumbers" you find is not me or the name I use for my own music.
musicbynumbers is offline   Reply With Quote
Old 03-27-2014, 05:13 AM   #9
airon
Human being with feelings
 
airon's Avatar
 
Join Date: Aug 2006
Location: Berlin
Posts: 10,375
Default

I can safely say that using video stripped of audio has given me no problems of this nature. An "Ignore audio" switch for video items might be a good thing. YOu can always copy the video item and glue the audio to get a copy of that for reference purposes, or use MPEG Steamclip to decode the audio track from MP4 or Quicktimes.

That this lag happens with all media that require peak displays however, if there's enough of it on screen, can be a problem though.

It may be prudent to think of a strategy to deal with this, as is done with the lazy GUI drawing priority already.

Perhaps the most detailed peak files should be drawn in instead of the actual waveform until that is updated with the underlying data.Nobody is likely to mind if the GUI stays responsive.
__________________
Dialogue/FX Editor & Re-Recording Mixer
(Video)Using Latch Preview
"My ego comes pre-shrunk" - Randy Thom

Last edited by airon; 03-27-2014 at 05:33 AM.
airon is offline   Reply With Quote
Old 03-08-2018, 11:31 AM   #10
preachers
Human being with feelings
 
preachers's Avatar
 
Join Date: Feb 2010
Location: Jilin
Posts: 179
Default

Solved by unchecking "Hi-res peaks" in Source Properties.
preachers is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 06:41 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.