Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 02-10-2020, 04:48 PM   #1
Scottsdale
Human being with feelings
 
Join Date: May 2010
Location: London, UK
Posts: 123
Default Windows accessibility: focus bug in "Device" category of Preferences dialog (FIXED)

Hi,

In Windows builds, focus gets stolen the first time you use the keyboard to navigate to "Device" in the category tree of the Preferences dialog.

Reproduction steps:

1. Open the Preferences window, select any category other than "Device" and hit OK to close the dialog (bear with me, this stage is just to set you up for success in next steps).

2. Reopen the Preferences dialog, then use either UpArrow or DownArrow to navigate through the categories until you reach "Device".

3. Notice how when you reach the Device category, focus gets automatically redirected to the "Audio system" combo box? That's the bug.

4. Keep Preferences open, move back to the category tree, and use your keyboard to move away from the "Device" category.

5. Use the keyboard to return to the "device" category. Notice how this time, focus doesn't jump anywhere? That's the expected behaviour I reckon, seeing as that's how all other categories behave.

Not a showstopper, but a UX oddity that I'd like to get squashed if poss.

Cheers,

Scott
Scottsdale is offline   Reply With Quote
Old 02-11-2020, 03:09 AM   #2
Overlord25
Human being with feelings
 
Join Date: Apr 2019
Posts: 5
Default Chris

Yes would definitely be good to squash this one, it's not a biggie now but for newbies it can cause confusion by inadvertently changing the default audio interface when tabbing and arrowing around the preferances dialogs
Overlord25 is offline   Reply With Quote
Old 02-11-2020, 08:27 AM   #3
Kara Louise
Human being with feelings
 
Kara Louise's Avatar
 
Join Date: Mar 2017
Posts: 4
Default

Yes, it’d be great to finally get this one squashed.
Kara Louise is offline   Reply With Quote
Old 02-12-2020, 11:24 AM   #4
Castle Starter
Human being with feelings
 
Join Date: Oct 2019
Posts: 21
Default

I'd like to see this fixed. It certainly happens and is inconvenient and can also mean you change the settings inadvertently which can be pretty crucial for this bit of the preferences.
Castle Starter is offline   Reply With Quote
Old 02-14-2020, 03:55 AM   #5
Straylight
Human being with feelings
 
Join Date: Feb 2020
Posts: 1
Default

Yep. For new users particularly, this can certainly throw you as you're adjusting settings. You think you're cursoring up and down in the tree view but will actually be changing your device settings.
Straylight is offline   Reply With Quote
Old 03-06-2020, 03:39 PM   #6
Scottsdale
Human being with feelings
 
Join Date: May 2010
Location: London, UK
Posts: 123
Default

Just re-tested - this is fixed in 6.05. Many thankyous!
Scottsdale is offline   Reply With Quote
Old 05-05-2020, 06:28 AM   #7
Scottsdale
Human being with feelings
 
Join Date: May 2010
Location: London, UK
Posts: 123
Default The second wave...

This bug is present again in 6.09. May have reappeared even sooner (I was lagging on 6.05 for a while longer than usual).
Scottsdale is offline   Reply With Quote
Old 05-06-2020, 12:24 PM   #8
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 12,970
Default

I don't think it was fixed in 6.05, was there a changelog line that mentions it?

Anyway taking a look now.
Justin is offline   Reply With Quote
Old 05-06-2020, 03:05 PM   #9
Scottsdale
Human being with feelings
 
Join Date: May 2010
Location: London, UK
Posts: 123
Default

Quote:
Originally Posted by Justin View Post
I don't think it was fixed in 6.05, was there a changelog line that mentions it?
I don't recall seeing it in the changelog no, but it started behaving properly in 6.04+dev0224, right around the same time as when Kenny fixed another bug I'd reported (t=231969), so I assumed he'd also fixed this.

Does that help narrow it down any?
Scottsdale is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 05:43 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.