Old 01-06-2017, 04:50 PM   #2041
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,190
Default

Quote:
Originally Posted by Reflected View Post
it works! :P

one "bug", when rendering mp3, the LBX XY automation in mp3 outcome sounds different than it sounds in the project/real time.
Ok - Have done quick test - and 1x render seems to work ok. You're never going to get a null between multiple renders of the same part because the script is not sample accurate - it just sends data to the plugins it's controlling as quickly as it can (whilst maintaining user input capabilities) - but can only do so when Reaper gives it processing time - so you will always have very small timing differences if you were to perform multiple renders of the same thing.

I could possibly improve accuracy a little by coding in a 'render' mode - where it switches off all unnecessary things like user input/ graphics updates etc. This would allow it to be more accurate when rendering (I guess - these are just ideas). However, I don't think it would ever be fast enough for an offline render.

I'll have a play when I get some free time. I think a completely stripped down run loop which solely monitors automation and nothing else (for rendering) - would be quite easy to include... But then - it would probably sound different to how you're hearing it during tracking - so whether that's what you want anyway is debatable -
but it would always be optional. Maybe call it an 'improved accuracy' mode

EDIT: I only tried rendering to WAV 24bit. Didn't test mp3 at 1x. What exact rendering options were you testing? Offline/Online/Realtime?

Another thought - if accuracy is really really important - I could do something like I did in Chaos Engine - which writes each controls automation to the tracks with the fx on - so basically printing the automation generated by the script to the fx plugins automation lanes. This could be done before rendering - and depending on the plugins involved - would more likely cope with an offline render. Obvious downside to this is that if you needed to change the automation in the scripts XY or Path - you would need to delete the printed automation and redo it. But might be an option in the future. Depends whether offline rendering is important to you, or whether you are happy to render online/realtime at 1x.

As I said earlier - I'll look into the different possibilities and provide some options - but I don't think there will be a perfect solution where you can rely on just the script to produce exact replicas each time the project is rendered, and offline.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal

Last edited by lb0; 01-06-2017 at 05:13 PM.
lb0 is offline   Reply With Quote
Old 01-06-2017, 06:10 PM   #2042
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,190
Default

And just released update with sensitivity settings for knob and slider controls - can set sensitivity 1-20 for normal/fine adjust/wheel/fine wheel.

I've gone for a 1-20 scale for each as it's easier to remember than 2, 0.1, 0.01, 0.003 which were the defaults.

Anyway - setting any to 0 - reverts to global settings - which currently are fixed but will make adjustable in another update soon.

Find the settings in CTL OPTIONS 2.

Cheers.

Also - a few fixes for cock-ups I've made recently. Main one I can remember was Display Value Offset - wasn't reading the value properly from the saved data. There was also another one where when the text editbox is on the screen - mouse clicks would 'click through' to the surface - so for things like editing control name - you would end up deselecting the control before it could update the data.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is offline   Reply With Quote
Old 01-06-2017, 09:04 PM   #2043
timbralzoom
Human being with feelings
 
timbralzoom's Avatar
 
Join Date: Apr 2010
Location: Turkey/Istanbul
Posts: 1,689
Default

Automation Basics

https://www.youtube.com/watch?v=zoct...ature=youtu.be
timbralzoom is offline   Reply With Quote
Old 01-07-2017, 01:36 AM   #2044
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,190
Default

Quote:
Originally Posted by timbralzoom View Post
- clear and concise - thanks!
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is offline   Reply With Quote
Old 01-07-2017, 02:41 AM   #2045
timbralzoom
Human being with feelings
 
timbralzoom's Avatar
 
Join Date: Apr 2010
Location: Turkey/Istanbul
Posts: 1,689
Default

Thanks i glad you like it
didn't tried mouse sensitivity yet but thanks for the update also!

...
just realized:

Quote:
Originally Posted by lb0 View Post
New update - includes Record Mode On/Off button within Metalite.

Setting Record Mode On - switches automation mode to Latch on __LBX_CTL track. Also prevents fader read automation for all parameters (currently - will improve to just recording params soon). Any movements in Metalite/Paths will be recorded to automation track.

Setting record mode off - switches auto mode to trim/read on __LBX_CTL track. Fader automation can now be read back from control track.

So if you want to record automation - just click the button on.

To stop recording and allow playback - switch off.

Hopefully this works ok - let me know.

Still needs a bit of refinement - but don't have time right now as lunchbreak nearly over!
it seems switching RECORD MODE ON
sets Global automation to "No Global override" ..is this is expected behavior?
timbralzoom is offline   Reply With Quote
Old 01-07-2017, 02:57 AM   #2046
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,190
Default

Quote:
Originally Posted by timbralzoom View Post
Thanks i glad you like it
didn't tried mouse sensitivity yet but thanks for the update also!

...
just realized:



it seems switching RECORD MODE ON
sets Global automation to "No Global override" ..is this is expected behavior?
That must be consequence when setting the control track's automation mode. Will see when I get some time if it can be done differently.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is offline   Reply With Quote
Old 01-07-2017, 03:02 AM   #2047
Reflected
Human being with feelings
 
Reflected's Avatar
 
Join Date: Jul 2009
Posts: 2,187
Default

Quote:
Originally Posted by lb0 View Post
Ok - Have done quick test - and 1x render seems to work ok. You're never going to get a null between multiple renders of the same part because the script is not sample accurate - it just sends data to the plugins it's controlling as quickly as it can (whilst maintaining user input capabilities) - but can only do so when Reaper gives it processing time - so you will always have very small timing differences if you were to perform multiple renders of the same thing.

I could possibly improve accuracy a little by coding in a 'render' mode - where it switches off all unnecessary things like user input/ graphics updates etc. This would allow it to be more accurate when rendering (I guess - these are just ideas). However, I don't think it would ever be fast enough for an offline render.

I'll have a play when I get some free time. I think a completely stripped down run loop which solely monitors automation and nothing else (for rendering) - would be quite easy to include... But then - it would probably sound different to how you're hearing it during tracking - so whether that's what you want anyway is debatable -
but it would always be optional. Maybe call it an 'improved accuracy' mode

EDIT: I only tried rendering to WAV 24bit. Didn't test mp3 at 1x. What exact rendering options were you testing? Offline/Online/Realtime?

Another thought - if accuracy is really really important - I could do something like I did in Chaos Engine - which writes each controls automation to the tracks with the fx on - so basically printing the automation generated by the script to the fx plugins automation lanes. This could be done before rendering - and depending on the plugins involved - would more likely cope with an offline render. Obvious downside to this is that if you needed to change the automation in the scripts XY or Path - you would need to delete the printed automation and redo it. But might be an option in the future. Depends whether offline rendering is important to you, or whether you are happy to render online/realtime at 1x.

As I said earlier - I'll look into the different possibilities and provide some options - but I don't think there will be a perfect solution where you can rely on just the script to produce exact replicas each time the project is rendered, and offline.

I created an mp3 by offline render.
if it's too much effort don't let it bothers u.
I will just record the vst parameters live and then render.
__________________
Thanks devs for adding the abillity to use single click to change a single velocity And single right click to remove a single note without dragging.
much appreciated.
Reflected is offline   Reply With Quote
Old 01-07-2017, 03:23 AM   #2048
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,190
Default

Quote:
Originally Posted by Reflected View Post
I created an mp3 by offline render.
if it's too much effort don't let it bothers u.
I will just record the vst parameters live and then render.
As long as that solution is ok for you. I would love to be able to provide proper offline support - but just don't think it is possible.

As said - I could add an option to step through the project and generate the automation for the vst parameters - but if you're happy recording them live then I won't worry just yet.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is offline   Reply With Quote
Old 01-07-2017, 03:34 AM   #2049
Reflected
Human being with feelings
 
Reflected's Avatar
 
Join Date: Jul 2009
Posts: 2,187
Default

Quote:
Originally Posted by lb0 View Post
As long as that solution is ok for you. I would love to be able to provide proper offline support - but just don't think it is possible.

As said - I could add an option to step through the project and generate the automation for the vst parameters - but if you're happy recording them live then I won't worry just yet.
don't worry about it then.
I'm very pleased already :P
__________________
Thanks devs for adding the abillity to use single click to change a single velocity And single right click to remove a single note without dragging.
much appreciated.
Reflected is offline   Reply With Quote
Old 01-07-2017, 04:10 AM   #2050
timbralzoom
Human being with feelings
 
timbralzoom's Avatar
 
Join Date: Apr 2010
Location: Turkey/Istanbul
Posts: 1,689
Default Controls & Graphics

all the "controls & graphics" collected,created so far

Update 2019-07-23

https://drive.google.com/open?id=17f...QP28nfQJ4FiDS1

enjoy!

Last edited by timbralzoom; 07-22-2019 at 03:05 PM. Reason: Update 2019-07-23
timbralzoom is offline   Reply With Quote
Old 01-07-2017, 06:24 AM   #2051
timbralzoom
Human being with feelings
 
timbralzoom's Avatar
 
Join Date: Apr 2010
Location: Turkey/Istanbul
Posts: 1,689
Default

ho ho ho full of snow here... meaning i have plenty of time
sooo
Testing hard!

project Ram usage about 116 K
in my first test after recording automation i left to play loop about 9 min, ram raised up 1.928 K and stopped there

in second test (this video) , it took about 30 min to get there but i also noticed slow graphic
and it goes away when i close the stripper window as you can see...

https://drive.google.com/open?id=0B9...ktJa003SXJWWnc



also
catch by chance

REAPER\Scripts\LBX\LBX Stripper.lua:6892: attempt to index a nil value (field '?')

message, while switching to the Page 2 on the fly ..in the video ( 02:56 min )...
no need to watch whole video btw...
just can jump from here to 28:30 to see the ram usage (1.917 K) and the slow graphic (meters & XY cursor)

in the third test it took 24 min to raise up to 1.921 K ram usage...

in the fourth test it took again about 25 min
i switched all 3th party fx offline except the MMBandDelay to test project before send to you
just in case it might help to test things...

https://drive.google.com/open?id=0B9...lNmRTlXSzlJbEE


personally i have no problem with the ram usage but the graphic part seemed important.

as a final note: project was old one so i just added FaderBox and automation if its make any sense.
timbralzoom is offline   Reply With Quote
Old 01-07-2017, 07:03 AM   #2052
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,190
Default

Quote:
Originally Posted by timbralzoom View Post
ho ho ho full of snow here... meaning i have plenty of time
sooo
Testing hard!

project Ram usage about 116 K
in my first test after recording automation i left to play loop about 9 min, ram raised up 1.928 K and stopped there

in second test (this video) , it took about 30 min to get there but i also noticed slow graphic
and it goes away when i close the stripper window as you can see...

https://drive.google.com/open?id=0B9...ktJa003SXJWWnc



also
catch by chance

REAPER\Scripts\LBX\LBX Stripper.lua:6892: attempt to index a nil value (field '?')

message, while switching to the Page 2 on the fly ..in the video ( 02:56 min )...
no need to watch whole video btw...
just can jump from here to 28:30 to see the ram usage (1.917 K) and the slow graphic (meters & XY cursor)

in the third test it took 24 min to raise up to 1.921 K ram usage...

in the fourth test it took again about 25 min
i switched all 3th party fx offline except the MMBandDelay to test project before send to you
just in case it might help to test things...

https://drive.google.com/open?id=0B9...lNmRTlXSzlJbEE


personally i have no problem with the ram usage but the graphic part seemed important.

as a final note: project was old one so i just added FaderBox and automation if its make any sense.
Ouch - not sure whats going on there - will look into. It certainly shouldn't be using up any extra RAM doing this at all.

Just a quick question - when you finished and saved the project file - how big was it?

If you reloaded - did it use same amount of RAM? If not - must be a memory leak on my part. If the project still used as much RAM - then it might be the way reaper was storing the automation - but it was in a loop - so should be overwriting old data. as I said - will see if I can spot the issue.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal

Last edited by lb0; 01-07-2017 at 07:09 AM.
lb0 is offline   Reply With Quote
Old 01-07-2017, 07:46 AM   #2053
timbralzoom
Human being with feelings
 
timbralzoom's Avatar
 
Join Date: Apr 2010
Location: Turkey/Istanbul
Posts: 1,689
Default

reload resets the ram :
- Reaper empty: 62 K
- with project while playing before Stripper window open: 103 K
- after opening the Stripper in a few second 300K and counting...
- if i close Stripper, ram raising also stops till i re open Stripper

didn't save the project after tests...
now i let the play loop again (the project i attached)

edit after 25 mins saved it didn't affect the project size (still 82kb)

uhmm.
just realized was't only the meter movements, it was affecting also plugin gui movements too

...

new one:
(tried in reaper reaper532pre8_x64 and reaper532pre9_x64)

-start empty project
-add track
-open stripper
-load strip ReEQ4b
-Save project

Scripts\LBX\LBX Stripper.lua:18858: attempt to index a number value (field 'knobsens')

same message also in this order
-save empty project
-add track
-add same strip
-press to save

Last edited by timbralzoom; 01-07-2017 at 08:45 AM.
timbralzoom is offline   Reply With Quote
Old 01-07-2017, 08:46 AM   #2054
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,190
Default

Quote:
Originally Posted by timbralzoom View Post
reload resets the ram :
- Reaper empty: 62 K
- with project while playing before Stripper window open: 103 K
- after opening the Stripper in a few second 300K and counting...
- if i close Stripper, ram raising also stops till i re open Stripper

didn't save the project after tests...
now i let the play loop again (the project i attached)

edit after 25 mins saved it didn't affect the project size (still 82kb)

uhmm.
just realized was't only the meter movements, it was affecting also plugin gui movements too

...

new one:
-start empty project
-add track
-open stripper
-load strip ReEQ4b
-Save project

Scripts\LBX\LBX Stripper.lua:18858: attempt to index a number value (field 'knobsens')

same message also in this order
-save empty project
-add track
-add same strip
-press to save
Hmmm - more research needed. I've left mine playing all day (indeed have often left running all day when gone to work recently) - only controlling a single or 2 instances of ReaEQ - but memory usage has been completely stable - doesn't move during playback at all. Yes project uses about 70Mb RAM - but it just sits there...

What am I doing different to you? I have Metalite automation recorded XY and Path - and just leaving running in a loop with a single track audio.

What plugs are you automating?

EDIT: is it just going up during playback with automation- or using Stripper generally?

EDIT2 - thanks will look into the error - that's to do with the knob sensitivity...
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is offline   Reply With Quote
Old 01-07-2017, 08:48 AM   #2055
timbralzoom
Human being with feelings
 
timbralzoom's Avatar
 
Join Date: Apr 2010
Location: Turkey/Istanbul
Posts: 1,689
Default

hmmm.
i was about to try from scratch with your rea eq strip but had that message.

EDIT:
i open the original/old project so no faderbox no xy automation

-4x track sends
-Rea EQ (Hi pass Lo pass)
-Rea Delay "DRY" (just for volume automation)
and messed with the parameters randomly about 5 min
if i am not mistaken seems switching snapshots doesn't affect after some point,
but tweaking the parameters and creating the different parameter combinations continue the add extra ram (?)... not that much like in Automation video



here is the result
https://drive.google.com/open?id=0B9...Vg2cUd6bkl5TXc

Last edited by timbralzoom; 01-07-2017 at 09:20 AM.
timbralzoom is offline   Reply With Quote
Old 01-07-2017, 09:00 AM   #2056
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,190
Default

Quote:
Originally Posted by timbralzoom View Post
hmmm.
i was about to try from scratch with your rea eq strip but had that message.
ok think I've fixed that error. Simple mistake - doh!

update with fix available.

Still not sure what's going on re RAM...
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is offline   Reply With Quote
Old 01-07-2017, 09:24 AM   #2057
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,190
Default

Quote:
Originally Posted by timbralzoom View Post
hmmm.
i was about to try from scratch with your rea eq strip but had that message.

EDIT:
i open the original/old project so no faderbox no xy automation

-4x track sends
-Rea EQ (Hi pass Lo pass)
-Rea Delay "DRY" (just for volume automation)
and messed with the parameters randomly about 5 min
if i am not mistaken seems switching snapshots doesn't affect after some point,
but tweaking the parameters and creating the different parameter combinations continue the add extra ram (?)... not that much like in Automation video



here is the result
https://drive.google.com/open?id=0B9...Vg2cUd6bkl5TXc
Ok - thanks - will look into tonight if I get the chance
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is offline   Reply With Quote
Old 01-07-2017, 09:41 AM   #2058
timbralzoom
Human being with feelings
 
timbralzoom's Avatar
 
Join Date: Apr 2010
Location: Turkey/Istanbul
Posts: 1,689
Default

Quote:
Originally Posted by lb0 View Post
Ok - thanks - will look into tonight if I get the chance
Thank you,
absolutely nothing to hurry!

thanks also for the fix
you are right, created from scratch
-one instance uTONIC
-your eq strip (4 snapshots with crazy tweaks)
-XY automation recorded
and still playing in loop...
no ram madness, nailed to 145K (which is normal) and doesn't move even a bit.


weird indeed
ill try to recreate that old project from scratch when i get time.

EDIT:
i hope i found it
i just added one track Send to Melda delay ram start to raise again
removed the melda just Send and still counting ..i think we nailed it!

EDIT2 send also automated!
final: after removing send parameter from the grid ram raise stopped instantly!

Last edited by timbralzoom; 01-07-2017 at 09:58 AM.
timbralzoom is offline   Reply With Quote
Old 01-07-2017, 10:30 AM   #2059
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,190
Default

Quote:
Originally Posted by timbralzoom View Post
Thank you,
absolutely nothing to hurry!

thanks also for the fix
you are right, created from scratch
-one instance uTONIC
-your eq strip (4 snapshots with crazy tweaks)
-XY automation recorded
and still playing in loop...
no ram madness, nailed to 145K (which is normal) and doesn't move even a bit.


weird indeed
ill try to recreate that old project from scratch when i get time.

EDIT:
i hope i found it
i just added one track Send to Melda delay ram start to raise again
removed the melda just Send and still counting ..i think we nailed it!

EDIT2 send also automated!
final: after removing send parameter from the grid ram raise stopped instantly!
awesome - thanks - will look into

ok - still need to perform a few more tests to be sure - but i think the memory leak may be inside the reaper api call - SetTrackSendUIVol. still need to confirm i'm not doing anything silly - but initial tests suggest this. if i do think it is - will raise a bug report.

Confirmed (as far as I'm concerned) - created a simple script that just called that API call - and it completely eats all my RAM on my laptop.

So I have filed a bug report. - But sadly - this is not something I can fix myself so we have to hope that the Reaper Gods are listening!
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal

Last edited by lb0; 01-07-2017 at 12:48 PM.
lb0 is offline   Reply With Quote
Old 01-07-2017, 02:45 PM   #2060
Arthur McArthur
Human being with feelings
 
Join Date: Sep 2016
Location: Toronto
Posts: 482
Default

Hey Leon, I'm getting a "LBX Stripper.lua:1983: attempt to index a nil value (field '?')" error on opening the stripper. Just started popping up every time... I have the newest version (new stuff looks really cool btw)
Arthur McArthur is offline   Reply With Quote
Old 01-07-2017, 03:12 PM   #2061
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,190
Default

Quote:
Originally Posted by Arthur McArthur View Post
Hey Leon, I'm getting a "LBX Stripper.lua:1983: attempt to index a nil value (field '?')" error on opening the stripper. Just started popping up every time... I have the newest version (new stuff looks really cool btw)
Hmmm... Have you changed anything in the controls folder - added any new controls, changed any around - edited any .knb files?
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is offline   Reply With Quote
Old 01-07-2017, 03:17 PM   #2062
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,190
Default

I need to apologise to the Reaper Gods... There is no memory leak!! It seems I was doing it wrong

I was calling the API with a flag setting that was causing it to create an undo point each and every time the knob moved and sent a new value - oops!!

So have released an update which should not do this
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is offline   Reply With Quote
Old 01-07-2017, 04:01 PM   #2063
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,190
Default

Quote:
Originally Posted by Arthur McArthur View Post
Hey Leon, I'm getting a "LBX Stripper.lua:1983: attempt to index a nil value (field '?')" error on opening the stripper. Just started popping up every time... I have the newest version (new stuff looks really cool btw)
Hi Arthur,

I've released an update which might help you to pinpoint what's going on in your control file folder.

Let me know how you get on - whether it helps. It should display a debug message if it finds a problem with a .knb file.

Thanks,
Leon.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is offline   Reply With Quote
Old 01-07-2017, 04:41 PM   #2064
Arthur McArthur
Human being with feelings
 
Join Date: Sep 2016
Location: Toronto
Posts: 482
Default

Quote:
Originally Posted by lb0 View Post
Hi Arthur,

I've released an update which might help you to pinpoint what's going on in your control file folder.

Let me know how you get on - whether it helps. It should display a debug message if it finds a problem with a .knb file.

Thanks,
Leon.
Fixed! Thanks!

It was a new knob that I had put in the controls folder. I had renamed a .knob file to .knb to try to get it to recognize it. I'm obviously doing something wrong, how can I get stripper to recognize the .knob file?
Arthur McArthur is offline   Reply With Quote
Old 01-07-2017, 04:51 PM   #2065
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,190
Default

Quote:
Originally Posted by Arthur McArthur View Post
Fixed! Thanks!

It was a new knob that I had put in the controls folder. I had renamed a .knob file to .knb to try to get it to recognize it. I'm obviously doing something wrong, how can I get stripper to recognize the .knob file?
the .knob file is Knobman file. This needs to be exported as a vertically stitched png file.

Then - copy that png file into Controls folder.

Then duplicate any of the .knb files from within the controls folder. Open it in notepad or similar. Edit it so it has the correct values for the knob you created. cellh = height of a single frame.

Other items should be obvious. Ctltype leave on 0 if you're not sure - you can change this within stripper when sorting into folders from the control chooser.

Do not change any of the key values (on the left). Only change the values themselves (after the =) - so it should retain exact format. Keep any quotation marks.

Save the knb file so it has same filename (except for the extension) as the png file.

Example knb file:

{{
["fn"]="__default.png",
["ctltype"]=0,
["frames"]=100,
["cellh"]=64,
},
}

A Stripper .knb file - is NOT the same as a .knob file. Sorry for any confusion.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is offline   Reply With Quote
Old 01-08-2017, 01:22 AM   #2066
timbralzoom
Human being with feelings
 
timbralzoom's Avatar
 
Join Date: Apr 2010
Location: Turkey/Istanbul
Posts: 1,689
Default

same project, playing loop about 40 mins, ram zombie was dead!
thanks!

if you switch pages while reading XY automation
\LBX Stripper.lua:6865: attempt to index a nil value (field '?')

seems closing and re opening the stripper window works, without restarting the Reaper.
timbralzoom is offline   Reply With Quote
Old 01-08-2017, 01:54 AM   #2067
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,190
Default

Quote:
Originally Posted by timbralzoom View Post
same project, playing loop about 40 mins, ram zombie was dead!
thanks!

if you switch pages while reading XY automation
\LBX Stripper.lua:6865: attempt to index a nil value (field '?')

seems closing and re opening the stripper window works, without restarting the Reaper.
- thanks.

Is that latest version - had a quick look last night and made a few fixes around midnight that *might* have addressed the issue.

The only time an error should require project reload - is if the error occurs during saving (ie. when hitting save/closing the script/saving project). At this point the saved data will be corrupted.

EDIT: Ok - yes latest version... will look into
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is offline   Reply With Quote
Old 01-08-2017, 02:10 AM   #2068
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,190
Default

Quote:
Originally Posted by timbralzoom View Post
same project, playing loop about 40 mins, ram zombie was dead!
thanks!

if you switch pages while reading XY automation
\LBX Stripper.lua:6865: attempt to index a nil value (field '?')

seems closing and re opening the stripper window works, without restarting the Reaper.
Hopefully fixed
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is offline   Reply With Quote
Old 01-08-2017, 02:40 AM   #2069
timbralzoom
Human being with feelings
 
timbralzoom's Avatar
 
Join Date: Apr 2010
Location: Turkey/Istanbul
Posts: 1,689
Default

confirmed! Thank you!

one more off topic Q.
out of curiosity,
what would you suggest for the controls frame count?
performance vs visual smoothness is there is a maximal frame?
timbralzoom is offline   Reply With Quote
Old 01-08-2017, 02:49 AM   #2070
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,190
Default

Quote:
Originally Posted by timbralzoom View Post
confirmed! Thank you!

one more off topic Q.
out of curiosity,
what would you suggest for the controls frame count?
performance vs visual smoothness is there is a maximal frame?
technically - shouldn't matter performance wise - but the more frames = more RAM. The more frames = better smoothness.

I've not really done any research myself - just stuck to 100 and 128 frame controls in general.

I would just create a few controls with say 100, 150, 200 etc frames - place them side by side in a strip and see how they perform, and which you prefer. Make sure you assign them to a control with decent range of values (so a continuous control - like a eq frequency). And report your findings here

I guess smaller controls won't benefit as much from v high frame count as there will be less difference between the frames.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is offline   Reply With Quote
Old 01-08-2017, 03:10 AM   #2071
timbralzoom
Human being with feelings
 
timbralzoom's Avatar
 
Join Date: Apr 2010
Location: Turkey/Istanbul
Posts: 1,689
Default


ok i will test soon,

(edit. actually i prefer 129 frames currently ..but will try 200 and more)


new one
how to use clip indicators? do we need special graphic for them?
currently it doesn't stay clipped as in the mixer, am i expecting something wrong?

timbralzoom is offline   Reply With Quote
Old 01-08-2017, 03:20 AM   #2072
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,190
Default

Quote:
Originally Posted by timbralzoom View Post

ok i will test soon,

(edit. actually i prefer 129 frames currently ..but will try 200 and more)


new one
how to use clip indicators? do we need special graphic for them?
currently it doesn't stay clipped as in the mixer, am i expecting something wrong?

The clip indicators work more like those on a hardware mixer (at least the cheaper one's I get to use :P ). So they don't latch to on when the audio clips.

I could probably provide a version that does latch on, would need to work out the logic but sure it would be quite easy.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is offline   Reply With Quote
Old 01-08-2017, 03:26 AM   #2073
timbralzoom
Human being with feelings
 
timbralzoom's Avatar
 
Join Date: Apr 2010
Location: Turkey/Istanbul
Posts: 1,689
Default

ah! ok not that important, it was just out of curiosity.

EDIT:
trying factory EQ strip
and it seems 129 vs 200 frames doesn't make any differences at all ...love it!




EDIT:
one more nerdy Q.
is there is a way to delete Subsets via editing/deleting the files in the folder that project Stripper files saved into?

EDIT2
i think i found
via editing the "psnap001_ss1.psnap" file .. removed subsets and lines from it
and replaced the first line "[p1_sstype_count]5 to [p1_sstype_count]1"
...
am i doing right?

Last edited by timbralzoom; 01-08-2017 at 05:17 AM.
timbralzoom is offline   Reply With Quote
Old 01-08-2017, 10:07 AM   #2074
Vincent Sermonne
Human being with feelings
 
Vincent Sermonne's Avatar
 
Join Date: Feb 2009
Location: Marseille France
Posts: 6,004
Default something strange with graphics edit

__________________
Vincent
ReaperDrummer
http://www.tchackpoum.fr
Vincent Sermonne is online now   Reply With Quote
Old 01-08-2017, 11:03 AM   #2075
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,190
Default

Whoops - will fix

Should now be fixed - sorry about that - had to shift some code about in runloop - and it had a few consequences that needed sorting out - I think I've got most of them now.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal

Last edited by lb0; 01-08-2017 at 12:45 PM.
lb0 is offline   Reply With Quote
Old 01-08-2017, 12:55 PM   #2076
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,190
Default

Quote:
Originally Posted by timbralzoom View Post
ah! ok not that important, it was just out of curiosity.

EDIT:
trying factory EQ strip
and it seems 129 vs 200 frames doesn't make any differences at all ...love it!




EDIT:
one more nerdy Q.
is there is a way to delete Subsets via editing/deleting the files in the folder that project Stripper files saved into?

EDIT2
i think i found
via editing the "psnap001_ss1.psnap" file .. removed subsets and lines from it
and replaced the first line "[p1_sstype_count]5 to [p1_sstype_count]1"
...
am i doing right?
I would say regarding deleting data from the save data file - that you're risking breaking the project the data is tied to. I would strongly advise against this.

Several reasons. When the data is loaded - it gets sorted into table structures - some of which will reference others. If one of those that is referenced by another is missing - you may get nil value errors when running the code.

Another reason is that you may end up with data getting misaligned - in that a snapshot may end up tied to an incorrect path or fader or something else.

Basically - the reason why I've not yet added simple delete functions is that I would need to sort and reorder and relink many other bits of data simply to just delete something without things becoming messed up internally - data wise.

Now - what you've done - may have no consequence (I've not checked) - but it could also be catastrophic for the project under certain conditions.

So I advise against it - and to wait for me to implement proper functions to do this. But if you think it works in this case - and seems to have no consequence - then feel free to try it - but I have warned you!!

But definitely don't go messing in the pstrip files!! :P


On the other note: I'm puzzled as to how a 200 frame bitmap can be the same size (memory wise) as a 129 frame bitmap of similar frame dimensions... Not sure why - but I would say this is incorrect - unless the image is stored in a compressed state (no idea - but would doubt it).
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is offline   Reply With Quote
Old 01-08-2017, 12:58 PM   #2077
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,190
Default

Quote:
Originally Posted by TonE View Post
Thanks, looks cool. Is snapshot a single fx snapshot or are multip fx snapshots possible, too? Like in sws snapshots, but without any morphing.

If your Reaper car racing.lua could use sws snapshots, that would be like traveling to Mars.
Reaper car racing.lua??? eh what?? sounds like fun! are you referring to the paths?

snapshots works across multi fx/tracks whatever - however you set it up.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is offline   Reply With Quote
Old 01-08-2017, 01:21 PM   #2078
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,190
Default

Quote:
Originally Posted by TonE View Post
Oh, we are already in Mars, thanks.
I should say - they effectively work across tracks. You would need to import all the parameters from all the fx on different tracks into the same strip page - as snapshots are limited to a single strip page - but as you can import params from anywhere into a single strip - you can therefore create snapshots of all the params you want.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is offline   Reply With Quote
Old 01-08-2017, 01:23 PM   #2079
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,190
Default

Quote:
Originally Posted by TonE View Post
Can the moving point be an image or .svg? Snapshots looking like planets, a spaceship flying around. Or some presidents head.
haha lol. Technically - yes of course. At the moment - I just draw a X using two lines. No reason why it can't be a bitmap if you'd prefer. Not too much work...
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is offline   Reply With Quote
Old 01-08-2017, 02:01 PM   #2080
timbralzoom
Human being with feelings
 
timbralzoom's Avatar
 
Join Date: Apr 2010
Location: Turkey/Istanbul
Posts: 1,689
Default

Thanks!
immediately-instantly-in no time-absolutely replaced with the backup !


Quote:
Originally Posted by TonE View Post
Thanks, looks cool. Is snapshot a single fx snapshot or are multip fx snapshots possible, too? Like in sws snapshots, but without any morphing.

If your Reaper car racing.lua could use sws snapshots, that would be like traveling to Mars.
i think you meant something like this


Last edited by timbralzoom; 01-08-2017 at 02:08 PM.
timbralzoom is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 07:23 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.