Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER for Linux

Reply
 
Thread Tools Display Modes
Old 05-21-2019, 02:07 AM   #1
bulevardi
Human being with feelings
 
Join Date: Feb 2017
Location: Brussels
Posts: 55
Default (solved) There was an error opening the audio hardware

Until yesterday I worked with Linux Mint Cinnamon (18 ?)
With a Focusrite Solo, Reaper worked directly out of the box.


Since today, I switched to another OS (Linux Mint XFCE 19), and installed Reaper again.

However, Reaper doesn't seem to recognize the hardware (see screenshot).

In the Volume Control, the Scralett Solo is already set by default and it's working as I can play music via VLC Player or Youtube or whatever.

Already switched to other USB port, rebooted, re´nstalled Reaper,...

Any other things I could try?

(I want to work directly via ALSA, not Jack)



Thanks in advance!
__________________
More adventure on: http://users.telenet.be/bulevardi

Last edited by bulevardi; 05-22-2019 at 11:33 AM. Reason: solved
bulevardi is offline   Reply With Quote
Old 05-21-2019, 12:44 PM   #2
bulevardi
Human being with feelings
 
Join Date: Feb 2017
Location: Brussels
Posts: 55
Default

Re´nstalled Cinnamon, this went quite quick, as my working files are on a separate disk.
Opened Reaper, error message, went to Reaper Preference menu, ALSA input/output field was blank too, clicked on it, did nothing...
but when fiddling in the blank field, I clicked on the dropdown arrow and the HW: usb audio Scarlett appeared !!

Did a recording, worked perfect.

I'm now wondering that I clicked on the arrow or not when I was testing in Xfce... Grrrr
The Volume Control of Cinnamon is slightly different as UI in comparison with the Pavucontrol in Xfce, but I'm really wondering if that really changed anything...

Should I re´nstall Xfce again to test it out... tempting... :s
__________________
More adventure on: http://users.telenet.be/bulevardi
bulevardi is offline   Reply With Quote
Old 05-21-2019, 02:44 PM   #3
Glennbo
Human being with feelings
 
Glennbo's Avatar
 
Join Date: Mar 2008
Location: Planet Earth
Posts: 4,055
Default

I've used xfce since initially installing Xubuntu 18.04 and ALSA works fine on my DAW with one of my two M-Audio 2496 cards.

That said, I use JACK so I can make both cards available to REAPER using QjackCtl's patch bay. Performance wise, they are pretty equal.
__________________
Glennbo
Hear My Music - Click Me!!!
--
Glennbo is offline   Reply With Quote
Old 05-22-2019, 11:32 AM   #4
bulevardi
Human being with feelings
 
Join Date: Feb 2017
Location: Brussels
Posts: 55
Default

Re´nstalled Xfce from scratch. Pavucontrol as volume mixer.

For some reason it is now directly working out of the box...
The input/output fields of the ALSA settings were already filled in with Scarlett in Reaper.
And no latency at all when recording. :shock:


Don't know what went wrong in the first place. It's all working, so far so good.
__________________
More adventure on: http://users.telenet.be/bulevardi
bulevardi is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 03:09 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.