Old 07-02-2019, 08:22 AM   #1
framus2
Human being with feelings
 
Join Date: Dec 2014
Posts: 112
Default Video nach Rendern zu groß ?

Hallo liebes Forum.
Ich hab ejetzt das erste mal ein Viedeo bearbeitet. Das heist vertont und ein paar Videoeffekte eingebaut.
Die größe des Original Videos vor der bearbeitung war 18 MB groß.
Nach dem Rendern mit folgenen Einstellungen sind es plötzlich 286 MB.

Wie ist das möglich? Ist es nicht möglich das Viedeo kleiner zu bekommen?
Vieleicht hat jemand Erfahrung damit.....
Liebe Grüße

Franz-Willi
Attached Images
File Type: jpg Bild_2019_07_02_17_05_31_267.jpg (53.9 KB, 48 views)

Last edited by framus2; 07-02-2019 at 11:39 AM.
framus2 is offline   Reply With Quote
Old 07-02-2019, 09:09 AM   #2
solger
Human being with feelings
 
solger's Avatar
 
Join Date: Mar 2013
Posts: 3,800
Default

Quote:
Die größe des Original Videos vor der bearbeitung war 18 MB groß.
Nach dem Rendern mit folgenen Einstellungen sind es plötzlich 286 MB.

Wie ist das möglich?
Hallo,

welches Video- und Audio-Codec Format hat denn das (importierte) Original Video selbst?
Müsste man z.B. mittels Rechts-Klick auf das Item > Source Properties angezeigt bekommen.

Quote:
Ist es nicht möglich das Viedeo kleiner zu bekommen?
Ist generell abhängig vom den verwendeten Video und Audio-Codecs bzw. dessen Qualitäts-Einstellungen.
__________________
ReaLauncher
solger is offline   Reply With Quote
Old 07-02-2019, 11:31 AM   #3
framus2
Human being with feelings
 
Join Date: Dec 2014
Posts: 112
Default

Hallo Solger.
Erst einmal vielen Dank für Deine schnelle Antwort.
Hier die Daten des Original Videos:
Length: 1:12.563
Video: 1280x720@30.00fps, Aspect=1.00, Decoding format=I420/YV12
Audio: 44100Hz 2ch 32bps

Using VLC decoder (v3.0.x)
Video: 1280x720, h264, 30.00fps
Audio: 44100hz, 32bps, 2ch, mp4a

Loaded from: C:\Program Files\VideoLAN\VLC
Hat im Original 17.7 MB
Nach dem rendern mit meiner Musik kommt es auf 286 MB

Da ich das Video über das Internet teilen möchte, darf es auch nicht viel gößer werden.
wie sollte den da die render Eistellung sein?



Liebe Grüße
FRanz-Willi
framus2 is offline   Reply With Quote
Old 07-02-2019, 11:58 AM   #4
solger
Human being with feelings
 
solger's Avatar
 
Join Date: Mar 2013
Posts: 3,800
Default

OK. Danke für die Infos.

Probier generell ein Rendern mit Formaten, die nicht lossless/verlustfrei sind, wie z.B:


Format: QT/MOV/MP4 - 1280 x 720, 30.00fps <-- Gleiche Auflösung und Framerate wie im Originalvideo passt (wie bereits in deinem Screenshot zu sehen)
Video codec: H. 264 - 95%
Audio codec: AAC - 320 kbps

Man kann noch mit geringerem %-Wert beim Video Codec und/oder geringerer Bitrate beim Audio Codec herumprobieren (und schauen, ob man dadurch einen besseren Kompromiss zwischen Dateigröße und Qualität findet).
Wie z.B in diesem Screenshot zu sehen (mit H.264 - 33%): https://forum.cockos.com/showpost.ph...41&postcount=9
__________________
ReaLauncher

Last edited by solger; 07-02-2019 at 12:16 PM.
solger is offline   Reply With Quote
Old 07-02-2019, 12:25 PM   #5
framus2
Human being with feelings
 
Join Date: Dec 2014
Posts: 112
Default

Hallo Solger.
Bei mir kann ich den H.264 gar nicht auswählen. Ebenso kann ich auch nicht den AAC auswählen.
Nur MJPEG und16 und 24 Bit PCM


Da liegt wahrscheinlich der Fehler.
framus2 is offline   Reply With Quote
Old 07-02-2019, 12:38 PM   #6
solger
Human being with feelings
 
solger's Avatar
 
Join Date: Mar 2013
Posts: 3,800
Default

Quote:
Originally Posted by framus2 View Post
Bei mir kann ich den H.264 gar nicht auswählen. Ebenso kann ich auch nicht den AAC auswählen.
Nur MJPEG und16 und 24 Bit PCM
Da liegt wahrscheinlich der Fehler.
Hast du VLC in der passenden Bit-Version zu Reaper installiert (damit Reaper auf die Codecs zugreifen kann)?
  • Reaper 64-bit -> VLC 64-bit
  • Reaper 32-bit -> VLC 32-bit


Unter Preferences > Media > Video/REX/Misc gibt's rechts oben auch einen [Show availbable decoder information] Knopf zur Überprüfung, welche Video Decoder gefunden wurden.
__________________
ReaLauncher
solger is offline   Reply With Quote
Old 07-02-2019, 12:43 PM   #7
framus2
Human being with feelings
 
Join Date: Dec 2014
Posts: 112
Default

Das müste der richtige sein.
vailable decoder information:

========== VLC ==========
VLC v3.0.x
Loaded from: C:\Program Files\VideoLAN\VLC

========== ffmpeg/libav ==========
ffmpeg/libav DLL decoder v54.92.100

Loaded from: C:\Program Files\REAPER (x64)\Plugins\FFmpeg.dll
ffmpeg/libav configuration:
--arch=x86_64
--extra-cflags=' -I../libvpx -I../libvorbis-1.3.1/include -I../libogg-1.2.0/include'
--extra-ldflags=' -L../libvpx -L../libvorbis-1.3.1/lib/.libs -L../libogg-1.2.0/src/.libs'
--enable-shared
--disable-static
--enable-memalign-hack
--disable-debug
--disable-avdevice
--disable-avfilter
--disable-network
--disable-everything
--disable-swscale-alpha
--disable-dct
--disable-fft
--disable-mdct
--disable-rdft
--disable-vaapi
--disable-vdpau
--disable-dxva2
--disable-zlib
--disable-bzlib
--enable-muxer=avi
--enable-muxer=matroska
--enable-demuxer=avi
--enable-demuxer=matroska
--enable-muxer=dv
--enable-demuxer=dv
--enable-muxer=webm
--enable-muxer=mov
--enable-demuxer=mov
--enable-encoder=qtrle
--enable-decoder=qtrle
--enable-encoder=ffv1
--enable-decoder=ffv1
--enable-encoder=huffyuv
--enable-decoder=huffyuv
--enable-encoder=dvvideo
--enable-decoder=dvvideo
--enable-libvpx
--enable-encoder=libvpx_vp8
--enable-decoder=libvpx_vp8
--enable-libvorbis
--enable-encoder=libvorbis
--enable-decoder=libvorbis
--enable-encoder=mjpeg
--enable-decoder=mjpeg
--enable-encoder=pcm_s16le
--enable-decoder=pcm_s16le
--enable-encoder=pcm_s24le
--enable-decoder=pcm_s24le
--enable-encoder=pcm_f32le
--enable-decoder=pcm_f32le
--enable-protocol=file
--disable-iconv
--disable-version3
--disable-gpl
--cc=x86_64-w64-mingw32-gcc
--ld=
--cxx=x86_64-w64-mingw32-g++
--nm=x86_64-w64-mingw32-nm
--ar=x86_64-w64-mingw32-ar

ffmpeg/libav search path:
%PATH%
C:\Program Files\REAPER (x64)
C:\Users\framus2\AppData\Roaming\REAPER\UserPlugin s\64
C:\Users\framus2\AppData\Roaming\REAPER\UserPlugin s
C:\Program Files\REAPER (x64)\Plugins

========== DirectShow ==========
DirectShow available
framus2 is offline   Reply With Quote
Old 07-02-2019, 12:45 PM   #8
solger
Human being with feelings
 
solger's Avatar
 
Join Date: Mar 2013
Posts: 3,800
Default

Quote:
Das müste der richtige sein.
vailable decoder information:
VLC schaut soweit gut aus. Beim FFMPEG habe ich hier eine neuere Version: ffmpeg/libav DLL decoder v57.107.100



FFMPEG Library Links gibt's hier: https://wiki.cockos.com/wiki/index.php/Video_Support

Für Reaper 64-bit wäre das die ffmpeg-3.4.1-win64-shared.zip. Von dieser .zip Datei dann nur aus dem "bin"-Ordner alle .dll Dateien (keine der .exe Dateien!) in den "Plugins" Unterordner vom Reaper Resourcen-Ordner (Options > Show Reaper resource pathr ... ) kopieren. Danach Reaper zur Sicherheit einmal neu starten.
__________________
ReaLauncher
solger is offline   Reply With Quote
Old 07-02-2019, 12:53 PM   #9
solger
Human being with feelings
 
solger's Avatar
 
Join Date: Mar 2013
Posts: 3,800
Default

Hab jetzt nochmal kurz bei einen frischen Reaper Installation nachgeschaut. Nach Kopieren der .dll Dateien vom ffmpeg-3.4.1-win64-shared.zip sollten die zusätzlichen Codec-Optionen verfügbar sein
__________________
ReaLauncher
solger is offline   Reply With Quote
Old 07-02-2019, 01:10 PM   #10
framus2
Human being with feelings
 
Join Date: Dec 2014
Posts: 112
Default

Hallo Solger.
Hat funktioniert....!!!!
Vielen, vielen Dank für Deine Hilfe.


Liebe Grüße aus Flensburg


Franz-Willi
framus2 is offline   Reply With Quote
Old 09-01-2019, 08:25 AM   #11
mawi
Human being with feelings
 
Join Date: Apr 2011
Posts: 681
Default

Ich habe gerade ein H.264 Video Codec Test gemacht. Einmal mit 100% und 1% Einstellung. Audio beides AAC 320 kBit/s. Format ist mov.

100% = 131MB
1% = 75,7MB

Videos sehen beide gleich gut aus, konnte keinen Qualitätsunterschied feststellen. Ist schon erstaunlich, wie viel man ein Video verkleinern kann.
mawi is offline   Reply With Quote
Old 09-03-2019, 12:22 PM   #12
framus2
Human being with feelings
 
Join Date: Dec 2014
Posts: 112
Default

Hallo Mawi.
Entschuldige bitte , dass ich mich jetzt erst melde. Danke für Deine Info, ich werde das auch einmal ausprobieren.
Gruß
Franz-Willi
framus2 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 06:42 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.