Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER for Linux

Reply
 
Thread Tools Display Modes
Old 06-15-2019, 10:41 AM   #1
lilith93
Human being with feelings
 
lilith93's Avatar
 
Join Date: Apr 2018
Location: Karlsruhe
Posts: 245
Default All faders down and height maximized

Sometimes when opening a project Reaper comes up with all faders down and with maximized track heights in the mixer view. This really drives me crazy as I have to adjust all the faders again. Is anyone else experiencing this from time to time?
__________________
https://soundcloud.com/lilith_93

Debian - Stretch / XFCE
lilith93 is offline   Reply With Quote
Old 06-15-2019, 11:43 AM   #2
JamesPeters
Human being with feelings
 
JamesPeters's Avatar
 
Join Date: Aug 2011
Location: Near a big lake
Posts: 2,723
Default

No.

Your system is broken.

I vaguely recall reading about someone having this problem a while ago, but I don't remember when and who it was (and if the problem was something on their system or not). Search the forum...
__________________
http://petersamplification.com
Using REAPER for Linux
JamesPeters is offline   Reply With Quote
Old 06-15-2019, 12:17 PM   #3
lilith93
Human being with feelings
 
lilith93's Avatar
 
Join Date: Apr 2018
Location: Karlsruhe
Posts: 245
Default

Quote:
Originally Posted by JamesPeters View Post
No.

Your system is broken.

I vaguely recall reading about someone having this problem a while ago, but I don't remember when and who it was (and if the problem was something on their system or not). Search the forum...
Yes, I asked that question a while ago and somebody mentioned having the same problem from time to time. I don´t have any problems with my system, undo/redo is working in other programs as it should. Maybe justin can comment if a system problem can cause such behavior. I wanted to avoid making a new install, but if nothing helps I have to. I also checked the journal entries and there are no errors. So I guess the system is fine.
__________________
https://soundcloud.com/lilith_93

Debian - Stretch / XFCE
lilith93 is offline   Reply With Quote
Old 06-15-2019, 05:26 PM   #4
JamesPeters
Human being with feelings
 
JamesPeters's Avatar
 
Join Date: Aug 2011
Location: Near a big lake
Posts: 2,723
Default

I mention your system, partially as a joke, because it seems you're having a few issues that no one else has reported or can duplicate.

(edit) I see on another thread that you're also testing a "live" MX Linux setup. Does this issue happen on MX Linux for you too?
__________________
http://petersamplification.com
Using REAPER for Linux

Last edited by JamesPeters; 06-15-2019 at 06:25 PM.
JamesPeters is offline   Reply With Quote
Old 06-16-2019, 12:19 AM   #5
lilith93
Human being with feelings
 
lilith93's Avatar
 
Join Date: Apr 2018
Location: Karlsruhe
Posts: 245
Default

That is happening more rarely, so I need to test it for a longer time. I would not be surprised if this bug is also due to the u-he plugins.
__________________
https://soundcloud.com/lilith_93

Debian - Stretch / XFCE
lilith93 is offline   Reply With Quote
Old 06-16-2019, 01:20 AM   #6
biopsin
Human being with feelings
 
Join Date: Sep 2010
Location: oslo
Posts: 38
Default

Yeah, had this issue on versions pre 5.9.6.5, this used to happen on both new/fresh and old projects, so I don't think it's a spesific plugin issue.
__________________
Voidlinux_glibc / gcc_9.2 / libSwell_GDK2 / Reaper_5.9.8.4 / RME_Hammerfall
biopsin is offline   Reply With Quote
Old 06-16-2019, 03:11 AM   #7
Westrabua
Human being with feelings
 
Join Date: Aug 2008
Location: Germany
Posts: 56
Default

So I've had the issue of faders resetting to zero as well two or so weeks ago for a couple days. For me it was in conjunction with performing 'undo'.

Anyway, I haven't experienced it for over a week now (same latest reaper version), by doing the following:

1) Close Reaper.
2) Backup the '.config/REAPER/' folder.
3) Within your REAPER config folder, open the 'reaper.ini' file and search for any 'comma' character (that are part of a number's delimiter) and replace it with a 'period' character.
4) Furthermore go to your system's 'locale settings' (not sure where this is on MxLinux as I'm on Manjaro) and look at the 'locale settings' for 'numbers'.



For me this was set to german initially.
I changed it to english.


My current hypothesis on this whole thing:
I did a system reinstall not too long ago.
I copied over the '.config/REAPER' folder of my old machine.
Maybe my locale settings were different on my old install.
Maybe something got messed up by having german style number delimiters ('comma') in the reaper.ini file despite REAPER expecting english style delimiters ('period').
By applying the above mentioned steps I haven't yet seen any new 'comma' delimiters in numbers in reaper.ini (I have put the whole 'REAPER' folder into git for detecting changes).
Westrabua is offline   Reply With Quote
Old 06-16-2019, 03:53 AM   #8
lilith93
Human being with feelings
 
lilith93's Avatar
 
Join Date: Apr 2018
Location: Karlsruhe
Posts: 245
Default

Great! I'll check this later. As I was playing with undo yesterday that makes sense.
__________________
https://soundcloud.com/lilith_93

Debian - Stretch / XFCE
lilith93 is offline   Reply With Quote
Old 06-16-2019, 06:25 AM   #9
lilith93
Human being with feelings
 
lilith93's Avatar
 
Join Date: Apr 2018
Location: Karlsruhe
Posts: 245
Default

Quote:
Originally Posted by Westrabua View Post
So I've had the issue of faders resetting to zero as well two or so weeks ago for a couple days. For me it was in conjunction with performing 'undo'.

Anyway, I haven't experienced it for over a week now (same latest reaper version), by doing the following:

1) Close Reaper.
2) Backup the '.config/REAPER/' folder.
3) Within your REAPER config folder, open the 'reaper.ini' file and search for any 'comma' character (that are part of a number's delimiter) and replace it with a 'period' character.
4) Furthermore go to your system's 'locale settings' (not sure where this is on MxLinux as I'm on Manjaro) and look at the 'locale settings' for 'numbers'.



For me this was set to german initially.
I changed it to english.


My current hypothesis on this whole thing:
I did a system reinstall not too long ago.
I copied over the '.config/REAPER' folder of my old machine.
Maybe my locale settings were different on my old install.
Maybe something got messed up by having german style number delimiters ('comma') in the reaper.ini file despite REAPER expecting english style delimiters ('period').
By applying the above mentioned steps I haven't yet seen any new 'comma' delimiters in numbers in reaper.ini (I have put the whole 'REAPER' folder into git for detecting changes).
Thanks so much, there was also something wrong on my system as I had some commas in the ini file.
Luckily this change also solved my other issue that is described here:

https://forum.cockos.com/showthread.php?t=222043

Is set everything to en_US.utf8 now, including the language.

__________________
https://soundcloud.com/lilith_93

Debian - Stretch / XFCE
lilith93 is offline   Reply With Quote
Old 06-16-2019, 08:59 AM   #10
Jack Winter
Human being with feelings
 
Jack Winter's Avatar
 
Join Date: Aug 2007
Location: Luxembourg/Spain
Posts: 1,800
Default

Quote:
Originally Posted by Westrabua View Post
delimiters in numbers in reaper.ini (I have put the whole 'REAPER' folder into git for detecting changes).
A sure sign of attaining penguinhood
__________________
Reaper for Linux Documentation (WIP). Software: Archlinux/KDE, Fabfilter FX, Komplete 8, Nebula, Schwa/Stillwell, T-racks Max/Amplitube/SVX, etc. Gear: i7-2600k/4700HQ/16GB, RME Multiface/Babyface, Behringer X32, Genelec 8040, etc. :)
Jack Winter is online now   Reply With Quote
Old 06-16-2019, 09:39 AM   #11
Westrabua
Human being with feelings
 
Join Date: Aug 2008
Location: Germany
Posts: 56
Default

Quote:
Originally Posted by lilith93 View Post
Thanks so much, there was also something wrong on my system as I had some commas in the ini file.
Luckily this change also solved my other issue that is described here:

https://forum.cockos.com/showthread.php?t=222043

Is set everything to en_US.utf8 now, including the language.

Glad it seemingly (for now) helped in your case as well.
As we are probably not the only two Linux Reaper users with german locale settings by default, it would sure make sense to saveguard against this regarding the ini-file.

I keep on observing on my end some more, but as I've mentioned I've not seen the previous fader problem in over week since applying that fix.

Quote:
Originally Posted by Jack Winter View Post
A sure sign of attaining penguinhood
Ha, guess some things one learns simply creep into other areas.
Westrabua is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 01:01 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.