COCKOS
CONFEDERATED FORUMS
Cockos : REAPER : NINJAM : Forums
Forum Home : Register : FAQ : Members List : Search :
Old 12-04-2017, 11:28 PM   #1
Bobflip
Human being with feelings
 
Join Date: Nov 2016
Posts: 316
Default Rez failed with exit code 2

So Iím having trouble with a Rez error preventing AU compilation.

Everything had been compiling fine on VST2 VST3, APP and AU. But over the past few hours this has started coming up.

Iíd suspect the .plist files as Iíve updated those recently, but it doesnít seem to be anything Iíve changed as I can duplicate a working project and have this error when I try to compile the copy.

Iíve tried cleaning the project and deleting the Derived Data folder

These are the errors Iím getting:

Code:
/Volumes/Data/Programming/IPlug-Youlean-master/WDL/IPlug/IPlugAU.r:102: ### /Applications/Xcode.app/Contents/Developer/usr/bin/Rez - Expected string, but got identifier (PLUG_MFR)
/Volumes/Data/Programming/IPlug-Youlean-master/WDL/IPlug/IPlugAU.r:106: ### /Applications/Xcode.app/Contents/Developer/usr/bin/Rez - Expected string, but got identifier (PLUG_NAME)
/Volumes/Data/Programming/IPlug-Youlean-master/WDL/IPlug/IPlugAU.r:110: ### /Applications/Xcode.app/Contents/Developer/usr/bin/Rez - Expected string, but got identifier (PLUG_ENTRY_STR)
/Volumes/Data/Programming/IPlug-Youlean-master/WDL/IPlug/IPlugAU.r:113: ### /Applications/Xcode.app/Contents/Developer/usr/bin/Rez - Expected 'SYSHEAP', 'APPHEAP', 'PURGEABLE', 'NONPURGEABLE', 'LOCKED', 'UNLOCKED',
 'PRELOAD', 'NONPRELOAD', 'PROTECTED', or 'UNPROTECTED', but got identifier (PLUG_MFR)
/Volumes/Data/Programming/IPlug-Youlean-master/WDL/IPlug/IPlugAU.r:114: ### /Applications/Xcode.app/Contents/Developer/usr/bin/Rez - Undefined variable (PLUG_IS_INST) not allowed in expression.
/Volumes/Data/Programming/IPlug-Youlean-master/WDL/IPlug/IPlugAU.r:114: ### /Applications/Xcode.app/Contents/Developer/usr/bin/Rez - Badly formed expression.
/Volumes/Data/Programming/IPlug-Youlean-master/WDL/IPlug/IPlugAU.r:116: ### /Applications/Xcode.app/Contents/Developer/usr/bin/Rez - Undefined variable (AU_MIDI_FX) not allowed in expression.
/Volumes/Data/Programming/IPlug-Youlean-master/WDL/IPlug/IPlugAU.r:116: ### /Applications/Xcode.app/Contents/Developer/usr/bin/Rez - Badly formed expression.
/Volumes/Data/Programming/IPlug-Youlean-master/WDL/IPlug/IPlugAU.r:118: ### /Applications/Xcode.app/Contents/Developer/usr/bin/Rez - Undefined variable (PLUG_DOES_MIDI) not allowed in expression.
/Volumes/Data/Programming/IPlug-Youlean-master/WDL/IPlug/IPlugAU.r:118: ### /Applications/Xcode.app/Contents/Developer/usr/bin/Rez - Badly formed expression.
/Volumes/Data/Programming/IPlug-Youlean-master/WDL/IPlug/IPlugAU.r:161: ### /Applications/Xcode.app/Contents/Developer/usr/bin/Rez - Expected string, but got identifier (PLUG_MFR)
/Volumes/Data/Programming/IPlug-Youlean-master/WDL/IPlug/IPlugAU.r:165: ### /Applications/Xcode.app/Contents/Developer/usr/bin/Rez - Expected string, but got identifier (PLUG_NAME)
/Volumes/Data/Programming/IPlug-Youlean-master/WDL/IPlug/IPlugAU.r:169: ### /Applications/Xcode.app/Contents/Developer/usr/bin/Rez - Expected string, but got identifier (PLUG_VIEW_ENTRY_STR)
I even tried duplicating IPlugEffect afresh, and adding everything back to that, which solved it as first but it just came back after a while.

Totally stumped on this one! Any thoughts?
Bobflip is offline   Reply With Quote
Old 12-05-2017, 03:37 AM   #2
Youlean
Human being with feelings
 
Youlean's Avatar
 
Join Date: May 2015
Location: Serbia
Posts: 649
Default

You need to add #define AU_MIDI_FX 1 to the resources.h
__________________
Website | Facebook Page | IPlug-Youlean
Youlean is offline   Reply With Quote
Old 12-05-2017, 04:01 AM   #3
Bobflip
Human being with feelings
 
Join Date: Nov 2016
Posts: 316
Default

Hmmm, that didn't work. It was set to 0, so changed it to 1 and deleted build-mac and Derived Data before compiling, but still got the same errors.
Bobflip is offline   Reply With Quote
Old 12-05-2017, 04:33 AM   #4
Youlean
Human being with feelings
 
Youlean's Avatar
 
Join Date: May 2015
Location: Serbia
Posts: 649
Default

Quote:
Originally Posted by Bobflip View Post
Hmmm, that didn't work. It was set to 0, so changed it to 1 and deleted build-mac and Derived Data before compiling, but still got the same errors.
Oh no, it should be 0. Then check other macros too...
__________________
Website | Facebook Page | IPlug-Youlean
Youlean is offline   Reply With Quote
Old 12-05-2017, 05:48 AM   #5
Bobflip
Human being with feelings
 
Join Date: Nov 2016
Posts: 316
Default

Thanks for the tip. Itís a weird one though, as the resources.h file would be the same in the duplicated copy as the original copy, so shouldnít be down to something like that. It ends up affecting other backup folders of the project, and then new compiles of those donít show up in any hosts or even the list given by ďauval -aĒ.

Itís like something hugely important has got corrupted but I canít think what it could be. Was meant to have this plug released weeks ago and thought Iíd finally get there yesterdayÖ

Iíve cleaned things again managed to put together another project folder that builds and scans alright, and am working from that for now. Still not really sure whatís caused it, but fingers crossed it wonít happen again!
Bobflip is offline   Reply With Quote
Old 12-05-2017, 04:01 PM   #6
Bobflip
Human being with feelings
 
Join Date: Nov 2016
Posts: 316
Default

Ok, so it came up again, but I've solved it now, I think. I finally narrowed it down to the Cryptopp library. I had built the library and dragged it to Frameworks and Libraries, and had dragged 7 files to Other Sources (whrlpool.h, cryptlib.h, hex.h, filters.h, des.h, modes.h, secblock.h, aes.h). Iíd also added the headers to my main projectís .h file, and added the cryptopp-master directory to the paths for the required targets.

Turns out that I needed to *uncheck* the AU target from the 7 .h files Iíd dragged into Other Sources, which went against what I thought is how it worked, but there you go.
Bobflip is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 04:59 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.