COCKOS
CONFEDERATED FORUMS
Cockos : REAPER : NINJAM : Forums
Forum Home : Register : FAQ : Members List : Search :
Old 03-30-2007, 07:27 AM   #1
derJörg
Human being with feelings
 
Join Date: Mar 2007
Posts: 3
Question Error when trying to start Debris

Hello,

I came across Debris Visual Art when I searched for Reaper.

I downloaded and installed it, but I can neither access any screen saver options, nor does the program run.

When I try to start it via start menu or screen saver panel, I get the following error message:

--------------------------
"Assertion failed"
--------------------------
Expression: !r
File: P:\projects\rsxe\sql.cpp
Line: 26

[OK] [Cancel]
--------------------------

I'm running Windows XP SP2 (updated to the latest patch).

Regards,
derJörg
derJörg is offline  
Old 04-01-2007, 07:04 AM   #2
derJörg
Human being with feelings
 
Join Date: Mar 2007
Posts: 3
Default Addendum

I tried several previous versions of Debris now, and the last version that works is #43.

...by the way: Debris is a very interesting program. Thank you for releasing it to the public.

Regards,
derJörg

Last edited by derJörg; 04-02-2007 at 03:36 AM.
derJörg is offline  
Old 06-14-2007, 03:10 PM   #3
Brennan
hey man
 
Brennan's Avatar
 
Join Date: Jun 2005
Posts: 331
Default

Quote:
Originally Posted by derJörg View Post
I tried several previous versions of Debris now, and the last version that works is #43.

...by the way: Debris is a very interesting program. Thank you for releasing it to the public.

Regards,
derJörg
You're welcome. I will try to make that assert into a better error message soon. That particular error message means that the sqlite db that holds the images' source urls could not be opened. That could happen for a number of reasons. (Out of disk space, can't write to user data dir, etc.) It's hard to say for now without any more information. I improved the error message a tiny bit for next version. Glad you got #43 to work for you. If you're interested in trying out a new version to determine exactly what the problem is post here and let me know and we can try that.
Brennan is offline  
Old 06-19-2007, 05:10 PM   #4
derJörg
Human being with feelings
 
Join Date: Mar 2007
Posts: 3
Default

Thank you, I'm glad if I can help you. The error still remains, but the error message is a little more descriptive:

--------------------------
"Assertion failed"
--------------------------
"can't open dbfile 'C:\Dokumente und Einstellungen\Jörg\Anwendungsdaten\Debris Visual Art\debrisurl.db', error code 1244944"
Expression: !r
File: P:\projects\rsxe\sql.cpp
Line: 27

[OK] [Cancel]
--------------------------

The folder doesn't exist (I removed it when I uninstalled #43 and versions after #43 don't create it).

Version #43 creates the folder and fills it with two files ("debrisurl.db" and "wasabi.xmlconfig") and a folder ("checkpoint" with files like this: debris_obj_????????.ppma).

Maybe the "ö" character in the path name is causing trouble? I'm a developer myself and special characters like the german umlauts (ä, ö, ü) have often caused trouble in source code I had to work with - just a shot in the dark...

I'm interested in helping you, so don't hesitate to give me something for testing.

Regards,
derJörg
derJörg is offline  
Old 06-28-2007, 02:30 PM   #5
Brennan
hey man
 
Brennan's Avatar
 
Join Date: Jun 2005
Posts: 331
Default

You know what, I agree. That seems really suspicious, especially if older versions worked. I'm gonna have to experiment a bit and dig through my source control system to see what changed. Thanks for the feedback! I'll post here when I get something worth trying.


Brennan
Brennan is offline  
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 11:13 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.