Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER for Live Use

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 03-15-2019, 12:09 AM   #1
Caroozo
Human being with feelings
 
Join Date: Dec 2018
Posts: 14
Talking Changing Reaper presets on different channels (live)

Hi,

I'd like to use KeyLab 61 to control several plugins (live). All of them are on different tracks and different channels. Some of them (Roland Cloud) HAVE to be controlled through Reaper presets, others (like Omnisphere) are fine, but Reaper presets are so useful that I want to use them for my entire setup. I did make preset list from different plugins, imported them to ReaControl MIDI, but I have the big problem I couldn't solve 'till now.

KeyLab (mk1) is configured so it send messages on Ch16, and change presets through pads (PC on Ch16 from 0 to 15 - already preconfigured). It works fine, to the moment when after changing patch I need to reroute MIDI to play just one VSTi. I saw that there were options in ReaControl MIDI under MIDI button, but somehow I can't get it to work.

1. Is it possible to do this that way? Or is there another simple solution?

2. If not, maybe there are some macros, triggered through CC? I can program KeyLab as I want, so no problem to make pads send CC or any other messages.

3. I still didn't used SWS plugins on purpose - I'd like to find solution in vanilla Reaper, unless it's impossible. If so, I'll be grateful if someone could help poor soul and send me simple solution .

I'm musician, not a programmer, I know a thing or two about computers (since Atari 65XE and DOS era ), but it's a little too much for me. I play mainly live in jazz band, and want to use several plugins for live gigs. For now, I use my RD700GX and change presets through different MIDI Channels, but want to do it on KeyLab for solos/pads/brasses. I know I'm missing something...

P.S. One more thing - I found a solution to send SysEx messages on KeyLab screen:
https://forum.arturia.com/index.php?topic=90496.0
But when I tried it, the screen flickered with the text sended by Reaper and parameters shown by KeyLab. Maybe something to do with the way Reaper sends messages? It works on AnalogLab just fine, it's plain SysEx so I dunno what's wrong. It should be nice to implement it in Reaper (as ReaControl MIDI has this function), but it's optional. Maybe someone have some experience and could give me a hint?

MANY thanks for any response! I'm kinda desperate to make things work
Caroozo is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 08:43 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.