Old 07-13-2018, 03:51 PM   #1
Patriots2007
Human being with feelings
 
Join Date: Apr 2018
Posts: 29
Default Timing issue

I have a wav file of a song I did in BIAB. Unfortunately I no longer have the original file of the tune from BIAB due to a major computer issue a while ago. I am now trying to record vocal tracks but they do not line up with the wave file. I think it is because I never set the tempo in Reaper before importing the wav. Is there any way to fix this problem? Thanks in advance,
Rich
Patriots2007 is offline   Reply With Quote
Old 07-13-2018, 05:03 PM   #2
serr
Human being with feelings
 
Join Date: Sep 2010
Posts: 7,110
Default

If you mean that when you record your overdubs (and hear everything correctly in the headphones while tracking) but then when you play back, the overdub is now offset from the rest.

There's an alignment step in setup of a DAW. The system will have a certain latency depending on your interface's baseline latency and your block size. SOP is to leave the DAW latency high-ish and monitor overdubs with your interface's cuemix mixer. This leads to overdubs being offset by that system latency.

Go to Preferences/Recording to set the correction for this offset. You can read up on "loopback tests" for more info. The correction factor will automatically nudge every recording back by the system latency so they line up with previously recorded audio.

Or...

Tempo is a 'coarse' interval. Samples is the ultimate root interval for recorded audio. You can't just set a tempo on one machine and record something and then set a tempo on a 2nd machine and record to that, and then expect those two recordings to be in sync with each other. (Not sure that anyone would try to do something clumsy like that but just an example to illustrate it.) Once you record the first thing - weather that first thing is live audio with time keeping or that first thing is a grid laid down to a tempo - everything else must be recorded to the first thing.
serr is offline   Reply With Quote
Old 07-13-2018, 05:39 PM   #3
Patriots2007
Human being with feelings
 
Join Date: Apr 2018
Posts: 29
Default

I am going to need time to digest that. I am a bit confused by some of the terminology. Thanks for the info. But to be sure I explained myself clearly. The BIAB file I imported to Reaper was actually converted to a stereo wav file before I imported it. Should'nt I be able to then add other audio tracks via reaper? Not sure if that sounds redundant.
Patriots2007 is offline   Reply With Quote
Old 07-14-2018, 08:49 AM   #4
serr
Human being with feelings
 
Join Date: Sep 2010
Posts: 7,110
Default

Quote:
Originally Posted by Patriots2007 View Post
I am going to need time to digest that. I am a bit confused by some of the terminology. Thanks for the info. But to be sure I explained myself clearly. The BIAB file I imported to Reaper was actually converted to a stereo wav file before I imported it. Should'nt I be able to then add other audio tracks via reaper? Not sure if that sounds redundant.
Yep, it's as simple as that. But you DO need to set the correction factor to "calibrate" your DAW on day 1. This is a thing you have to do in the world of recording with computers. Again, the controls are in Reaper Preferences/Recording on the bottom of the page.

The "Use driver reported latency" part is sometimes close by itself (obviously it's not on your system). You can use that + an offset or completely your own offset value.

Now, a not very good workaround might be to set the block size low for low latency operation. This is what you do for running live sound or doing live performance where there can be no perceptible latency in the live sound. This makes the computer scream and you need an above average machine to do such things. This is why it is still SOP to leave the computer latency high and monitor overdubs with your audio interface's built in cuemix mixer. And then set the 'calibration' in the DAW to line up newly recorded audio with previously recorded audio.

Tip: Choose a larger block size like 1024 or 512 samples and stay with that (so this isn't a moving target). Set the correction in Preferences/Recording.

Google "loopback testing DAW" and you will find more information and videos.
serr is offline   Reply With Quote
Old 07-14-2018, 03:07 PM   #5
Patriots2007
Human being with feelings
 
Join Date: Apr 2018
Posts: 29
Default

Thanks, I found a video on line which walked me through it. Simple indeed. I had to adjust playback latency from 0 to 300. Thanks again,
Rich
Patriots2007 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 11:10 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.