Old 08-09-2020, 06:54 AM   #1
ilpelle
Human being with feelings
 
ilpelle's Avatar
 
Join Date: Jul 2019
Location: Medi.Ar.Phi.
Posts: 74
Default Missing metadata on .wav

Hi all
when I render a song, if I set some field (title, artist etc) in Project Render Metadata for scheme ID3 (MP3) I can find them on the resulting .MP3, but if I set the same data on INFO (WAV) scheme these data are not written (see attach): where I'm wrong?

Many thanks in advance

Ciao
ilpelle
Attached Images
File Type: jpg Metadata.jpg (57.4 KB, 208 views)
ilpelle is offline   Reply With Quote
Old 08-09-2020, 06:58 AM   #2
schwa
Administrator
 
schwa's Avatar
 
Join Date: Mar 2007
Location: NY
Posts: 14,802
Default

Can you attach or link to the actual rendered .wav file? I think it's likely that the metadata is embedded, but whatever application that is a screenshot of (windows explorer?) does not recognize/support INFO metadata.
schwa is offline   Reply With Quote
Old 08-09-2020, 07:17 AM   #3
ilpelle
Human being with feelings
 
ilpelle's Avatar
 
Join Date: Jul 2019
Location: Medi.Ar.Phi.
Posts: 74
Default

the WAV is about 100MB so I don't know how attach it...

here the properties of the two files, the WAV's one is empty
Attached Images
File Type: jpg MP3 ProprietÓ.jpg (37.7 KB, 189 views)
File Type: jpg WAV ProprietÓ.jpg (38.1 KB, 196 views)
ilpelle is offline   Reply With Quote
Old 08-09-2020, 07:38 AM   #4
Meo-Ada Mespotine
Human being with feelings
 
Meo-Ada Mespotine's Avatar
 
Join Date: May 2017
Location: Leipzig
Posts: 6,297
Default

Quote:
Originally Posted by ilpelle View Post
the WAV is about 100MB so I don't know how attach it...

here the properties of the two files, the WAV's one is empty
Create a short wav-file(1 second or so) with the embed-metadata-checkbox enabled. After that, put the resulting file into a zip-archive, as zip is accepted by the forum.

This short file should be enough to show the problem.
__________________
Use you/she/her.Ultraschall-Api Lua Api4Reaper
Bugreports&Docs notes please do here:https://github.com/Ultraschall/ultra...-reaper/issues - Donate, if you wish
Meo-Ada Mespotine is online now   Reply With Quote
Old 08-09-2020, 08:12 AM   #5
schwa
Administrator
 
schwa's Avatar
 
Join Date: Mar 2007
Location: NY
Posts: 14,802
Default

Actually, no need. I can confirm that Windows explorer file properties don't display INFO, or in fact any kind of .wav metadata as far as I can tell.

So I don't think this is a REAPER issue, I think it's just something that Windows doesn't support.
schwa is offline   Reply With Quote
Old 08-09-2020, 08:22 AM   #6
schwa
Administrator
 
schwa's Avatar
 
Join Date: Mar 2007
Location: NY
Posts: 14,802
Default

Accctually, windows explorer can recognize INFO metadata, but only if it is the last chunk of data in the file. Generally metadata is placed at the start of a file so that programs that scan for it don't have to read the entire file. We'll think about whether we should make an exception for INFO metadata.
schwa is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 11:19 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2023, vBulletin Solutions Inc.