Old 08-12-2018, 11:19 AM   #1
Steviebone
Human being with feelings
 
Join Date: Jul 2018
Posts: 37
Default External MIDI devices and latch preview mode

Reaper does not echo external MIDI control signals in latch preview mode. When in latch preview mode although the control surfaces execute normally at the track level in reaper the corresponding links to external MIDI gear are not transmitted. So if I have external gear that is being controlled by MIDI volume messaging and I going to latch preview mode although the levels within reaper are reflected I never hear any change in the external gear because the corresponding MIDI control signals are not being sent to the external gear.

Is there a setting I am overlooking somewhere? Or is this something that a gifted scripter could craft a workaround for?

My setup is unique in that I have many external boxes that I use to generate sound and that audio output is routed to external digital mixers that sum the various outputs rather than going back into the Daw. This has how I have worked for some time using brute force to overcome processing power limitations.

At some point I may check out reamote, but re-configuring my whole set up at this point just isn't in the cards. For now, I have to carefully enter write mode in the loop and remember to toggle between full on global read and track level automation write. Even with macros it's a bit clumsy.

In-the-box adjustments seem to work, I can grab an envelope with the mouse and make audible adjustments but nothing is echoed from the control surfaces (mackie or novation). But this also defeats the whole purpose of latch preview (as well as external control surfaces).

Any suggestions are welcome. Thank you.

PS: This question may be better suited for the script forum if there is no native way to solve this problem...

Last edited by Steviebone; 08-12-2018 at 11:26 AM.
Steviebone is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 10:39 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.