Old 05-19-2018, 05:08 PM   #1
Thonex
Human being with feelings
 
Join Date: May 2018
Location: Los Angeles
Posts: 742
Default Stop Reaper from looping audio or extending audio range

Hi guys,

Ok, so I figured out how to stop Reaper from looping audio items when I don't want it to. However, I would like to also stop if from extending the item's length beyond the actual recording. Is that possible?


Here is what I mean, the actual audio ends but I am able to drag the tail of the item to the right and create a longer region but there is actually no audio behind it. Is there a setting is Reaper to limit an items/regions length the its underlying content?



Thanks for any help.

Cheers,

Andrew K
Thonex is offline   Reply With Quote
Old 05-20-2018, 12:00 AM   #2
solger
Human being with feelings
 
solger's Avatar
 
Join Date: Mar 2013
Posts: 3,748
Default

Quote:
Is there a setting is Reaper to limit an items/regions length the its underlying content?
Not sure if it's possible to limit the Dragging Action itself to stop at the item content length (since you can't assign any Custom Actions to the [Media Item Edge] [left drag] Mouse Modifier).

But maybe this Action might be useful in some cases: Item: Set items length to source media lengths
solger is online now   Reply With Quote
Old 05-20-2018, 01:09 AM   #3
EvilDragon
Human being with feelings
 
EvilDragon's Avatar
 
Join Date: Jun 2009
Location: Croatia
Posts: 23,311
Default

Disable all Loop source options in Preferences->Project->Media Item Defaults.
EvilDragon is online now   Reply With Quote
Old 05-20-2018, 04:03 PM   #4
Thonex
Human being with feelings
 
Join Date: May 2018
Location: Los Angeles
Posts: 742
Default

Quote:
Originally Posted by EvilDragon View Post
Disable all Loop source options in Preferences->Project->Media Item Defaults.
Thanks guys,

ED, while that Prefs page did seem like the logical place (ad I found other goodies on that page -- thanks), it's not prohibiting me from making a region longer than it's underlying audio -- even after disabling all the loop prefs there.

Could it be somewhere else?

I'm still learning where things are "hidden" in Reaper.

Thanks.

Cheers,

Andrew K
Thonex is offline   Reply With Quote
Old 05-20-2018, 04:22 PM   #5
Tod
Human being with feelings
 
Tod's Avatar
 
Join Date: Jan 2010
Location: Just outside of Glacier National Park
Posts: 12,601
Default

Quote:
Originally Posted by Thonex View Post
Thanks guys,

ED, while that Prefs page did seem like the logical place (ad I found other goodies on that page -- thanks), it's not prohibiting me from making a region longer than it's underlying audio -- even after disabling all the loop prefs there.

Could it be somewhere else?

I'm still learning where things are "hidden" in Reaper.
How are you making your regions? When I want to create regions based on the items I use the SWS action: "SWS: Create regions from selected items (name by active take)".

I use that a lot, especially when editing samples.
__________________
Kontakt Vid Tutorials->Create Outputs / Create Templates -|- SMDrums Free drums -|- Elk Video Productions -|- Tod's Music
Tod is offline   Reply With Quote
Old 05-20-2018, 05:10 PM   #6
Thonex
Human being with feelings
 
Join Date: May 2018
Location: Los Angeles
Posts: 742
Default

Quote:
Originally Posted by Tod View Post
How are you making your regions? When I want to create regions based on the items I use the SWS action: "SWS: Create regions from selected items (name by active take)".

I use that a lot, especially when editing samples.
Hi Todd,

Thanks for answering. Much appreciated. Even if I simply drag/drop an audio file into Reaper, I can extend it beyond it's audio. As if the Item boundaries are not constrained by the underlying audio. So, when resizing stuff, it can be very misleading visually.

There is probably an Item, Take, Region hierarchy that I'm not yet familiar with. I'm coming from Nuendo.

Regarding your script, that's a nice script, but it doesn't stop Items from being able to be lengthened beyond their length.

Cheers,

Andrew K
Thonex is offline   Reply With Quote
Old 05-20-2018, 05:25 PM   #7
Tod
Human being with feelings
 
Tod's Avatar
 
Join Date: Jan 2010
Location: Just outside of Glacier National Park
Posts: 12,601
Default

Quote:
Originally Posted by Thonex View Post
Even if I simply drag/drop an audio file into Reaper, I can extend it beyond it's audio. As if the Item boundaries are not constrained by the underlying audio. So, when resizing stuff, it can be very misleading visually.
Hi Andrew, This has got me confused, you say you drag and drop an audio item, and then you say you can extend it beyond it's actual size. So you are manually readjusting the size of the items after you drag them in? May I ask why you're resizing these items?

Incidentally, that action I showed you is not a script, it's part of the many SWS actions that are available. If you haven't downloaded the SWS actions yet you'll want to do that.

And welcome on board Andrew.
__________________
Kontakt Vid Tutorials->Create Outputs / Create Templates -|- SMDrums Free drums -|- Elk Video Productions -|- Tod's Music
Tod is offline   Reply With Quote
Old 05-20-2018, 11:12 PM   #8
EvilDragon
Human being with feelings
 
EvilDragon's Avatar
 
Join Date: Jun 2009
Location: Croatia
Posts: 23,311
Default

So the options I mentioned will prevent looping the source media, but, in Reaper, you can always resize the item beyond its source length (in order to i.e. add silence when you glue the item.

You can try locking the item edges. Right click the padlock button in top left of Reaper GUI.
EvilDragon is online now   Reply With Quote
Old 06-22-2019, 04:23 PM   #9
Simon Kessler
Human being with feelings
 
Join Date: Jun 2018
Posts: 1
Default Solution in current project

So I searched google for this and the solution is to

1.) Right click the item and go to Item Properties
2.) Un-check Loop source


Found it on another forum and I did it all at once by Ctrl+A for all of the items.
Simon Kessler is offline   Reply With Quote
Old 07-30-2019, 01:31 AM   #10
Scoox
Human being with feelings
 
Scoox's Avatar
 
Join Date: Jun 2009
Location: Wuxi, China
Posts: 253
Default

This is one of those things that should be disabled by default. Until that happens, Reaper will continue to suck out of the box, sadly.
Scoox is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 11:30 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.