Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Color Themes and Icon Sets

Reply
 
Thread Tools Display Modes
Old 12-27-2018, 12:10 PM   #161
sightlessness
Human being with feelings
 
sightlessness's Avatar
 
Join Date: Mar 2010
Posts: 911
Default

I know you're busy I don't expect an solution right away, I hope in the long
run (mabye next year :P, no sarcasm) I can get it fixed because I love this theme I hope I can keep on using Reaper with this theme. Cheers.

EDIT:

TL;DR Track FX insert zone and Sends zone
are above VU meters, instead of below... weird...

TL;DR 2 In other words now theme works perfect, no artifacts or anything weird, BUT I can't insert FX or drag sends from one track to another using MPC, because
they are hidden above the VU meters. TCP works perefect.

Ok, I noticed after messing around with it a little bit more, and I think I am doing everything right:

For some reason, the cursor THAT/WHEN changes to a handle appears in the middle of nowhere (MPC track), very down below the track, and
I have to squint to see where it is, then drag it all the way up so the VU meters with the word GAIN above it appears as your screentshots,
leaving a space where the 3 zones (I think it's 2 in your theme moestly: Track FX inserts and Track Sends) should go.
And when I do that (Gain word at the top, VU meters at the top) I get no artifcats, so all good now.

The ONLY issue, weird I know, is that the FX inserts zone and the Send one are missing (hidden) now, because they were all the time above the VU meters,
but since I dragged (moved) all the way up the VU meters, well, now there is an empty space... too redundant, I know: Track FX insert zone and Sends zone
are above VU meters, instead of below... weird...

almost there by Charlie Brown, on Flickr
__________________
I want to live PEACEFULLY PLEASE WORLD "LEADERS" GET THIS DONE/LET IT BE FOR GOOD AND MAKE HISTORYYYYYYY! Thanks.

Last edited by sightlessness; 12-27-2018 at 12:48 PM.
sightlessness is offline   Reply With Quote
Old 12-27-2018, 01:48 PM   #162
sightlessness
Human being with feelings
 
sightlessness's Avatar
 
Join Date: Mar 2010
Posts: 911
Default

Downloaded last version of Reaper, and even tried the first version you released (WIP) and it all behaves the same.
__________________
I want to live PEACEFULLY PLEASE WORLD "LEADERS" GET THIS DONE/LET IT BE FOR GOOD AND MAKE HISTORYYYYYYY! Thanks.
sightlessness is offline   Reply With Quote
Old 12-27-2018, 03:40 PM   #163
talustalus
Human being with feelings
 
Join Date: Dec 2018
Posts: 383
Default

Quote:
Originally Posted by jrengmusic View Post
You can drag child track to its target parent.

I personally never use folder button on track. I wrote a custom script to folderize selected tracks.
Thank you. Can I download this script?
(I am new and have not got any scripts yet, just browsed like 100 themes until I saw yours and was like "yeah!")
talustalus is offline   Reply With Quote
Old 12-27-2018, 05:42 PM   #164
jrengmusic
Human being with feelings
 
jrengmusic's Avatar
 
Join Date: Jun 2015
Posts: 553
Default

Quote:
Originally Posted by sightlessness View Post
Downloaded last version of Reaper, and even tried the first version you released (WIP) and it all behaves the same.
The thing is, your problem is something that i can’t reproduce. I don’t have a Windows machine with native 4K resolution. How could i create a solution to a problem that i don’t encounter?

The smallest monitor which works best with this theme is my 2015 15.4” Retina MacBookPro with 2880 x 1800 px native resolution. Technically smaller than native 4K screen, and there isn’t any a single problem.

Perhaps try this
windows-scaling-issues-for-high-dpi-devices

I don’t want to sound like a douche, but furthermore I don’t know how to help you.
__________________
JRENG! | M E T R I C
jrengmusic is offline   Reply With Quote
Old 12-27-2018, 05:45 PM   #165
jrengmusic
Human being with feelings
 
jrengmusic's Avatar
 
Join Date: Jun 2015
Posts: 553
Default

Quote:
Originally Posted by talustalus View Post
Thank you. Can I download this script?
(I am new and have not got any scripts yet, just browsed like 100 themes until I saw yours and was like "yeah!")
Download and install the latest SWS Extension. You might find appropriate actions to do such things.
__________________
JRENG! | M E T R I C
jrengmusic is offline   Reply With Quote
Old 12-27-2018, 09:35 PM   #166
talustalus
Human being with feelings
 
Join Date: Dec 2018
Posts: 383
Default

Quote:
Originally Posted by jrengmusic View Post
Download and install the latest SWS Extension. You might find appropriate actions to do such things.
I do have SWS extension already. But I'm not sure how to find your specific script that you mentioned. No idea in fact. But once I do know, I will be good to go.
talustalus is offline   Reply With Quote
Old 12-27-2018, 10:45 PM   #167
jrengmusic
Human being with feelings
 
jrengmusic's Avatar
 
Join Date: Jun 2015
Posts: 553
Default

Quote:
Originally Posted by talustalus View Post
I do have SWS extension already. But I'm not sure how to find your specific script that you mentioned. No idea in fact. But once I do know, I will be good to go.
Find this on Action list
Code:
SWS: Make folder from selected tracks
__________________
JRENG! | M E T R I C
jrengmusic is offline   Reply With Quote
Old 12-27-2018, 10:46 PM   #168
sightlessness
Human being with feelings
 
sightlessness's Avatar
 
Join Date: Mar 2010
Posts: 911
Default

TL;DR Maybe I just need a line of code to FORCE those areas I mention
below the VU meters? I know you got inspiriation from the Imperial theme
and that one works as intended (3 zones I mention below VU meters which
are forced below the VU meters).

I totally understand, believe me I used to code stuff in Flash,
do design in Photoshop, and I know what happens behind the curtains.

If you found the time, I think I'd just need suggestions
for the rtconfig and include/change a line of code where the zones:
Track FX inserts, Track sends, Track FX parameters are FORCED below
the VU meters, because that's the way the Imperial theme behaves,
it has the VU at the top by default (I think forced because when you
resize the MPC those VU meters are dead set at the top), whereas the 3
zones I mention are below always no matter what, and if you go beyond
a certain point resizing down the MPC (mixer) these 3 areas invade certain
areas below to a degree. And the Imperial that way works perfect (but no 4k
version, yet).
__________________
I want to live PEACEFULLY PLEASE WORLD "LEADERS" GET THIS DONE/LET IT BE FOR GOOD AND MAKE HISTORYYYYYYY! Thanks.
sightlessness is offline   Reply With Quote
Old 12-28-2018, 04:53 AM   #169
White Tie
Pixel Pusher
 
White Tie's Avatar
 
Join Date: Mar 2007
Location: Blighty
Posts: 2,565
Default

I believe I could be of assistance here, if the OP has any questions I would be more than happy to provide whatever answers I have.
__________________
The House of White Tie
White Tie is offline   Reply With Quote
Old 12-28-2018, 06:04 AM   #170
jrengmusic
Human being with feelings
 
jrengmusic's Avatar
 
Join Date: Jun 2015
Posts: 553
Default

Quote:
Originally Posted by White Tie View Post
I believe I could be of assistance here, if the OP has any questions I would be more than happy to provide whatever answers I have.
My main problem is, I don't have a Windows machine to test. So i couldn't debug the problem in macOS.

What might cause the layouts behave differently on Windows display vs macOS? In this case the track label, and the extmixer layout. Maybe the logic i wrote in WALTER doesn't work on Windows display monitor?

Would you mind have a look at METRIC rtconfig? Perhaps there are line of codes that i could optimize to work on both OS.

Thanks WT.
__________________
JRENG! | M E T R I C
jrengmusic is offline   Reply With Quote
Old 12-28-2018, 06:26 AM   #171
sightlessness
Human being with feelings
 
sightlessness's Avatar
 
Join Date: Mar 2010
Posts: 911
Default

Please, I totally understand your position, and don't make this issue
yours. I just hope you could find the time trying to help me fix this issue.
I know it's not an issue to you, you have a life, you gave this to us as a gift AS IS. I couldn't ever take you for a douche when you gave this away to us.

If you don't find time to give me the hour of the day, it's just fine.
Honest.

Is not your problem.

Anyway, I am changing bits of code to see what it does (not choosing randomly) trying to find what could be the cause.

And reading your last reply I am/will check those parameters too.

EDIT: Couldn't find the key element that's messing this up :P

EDIT2: At 100% Windows overall Display settings same behaviour.

EDIT3: If I change the rtconfig global scaling to 1.5 or 1.0 (windows at 100% or 150% or 200% scenarios) my issue fixes itself but still some images display in the wrong areas still.

EDIT4: The Triangles image (master, aux, receive) always stays in the same place, instead of always being below the vu meters. Bybass images should be below (kinda) this Triangles image.

EDIT5: If there is a macro for TCP and works great (remember in the MCP track names won't display in most layouts, whereas in the TCP they display just fine?) and TCP works perfectly,
this leads me to believe there is something at least "missing" or "misleading" in the MCP that makes it not work as it should.

EDIT6: I totally get it: If it works just fine for you in a Mac, why it shouldn't in Windows if themes are OS-nostic. Computers...
__________________
I want to live PEACEFULLY PLEASE WORLD "LEADERS" GET THIS DONE/LET IT BE FOR GOOD AND MAKE HISTORYYYYYYY! Thanks.

Last edited by sightlessness; 12-28-2018 at 07:12 AM.
sightlessness is offline   Reply With Quote
Old 12-28-2018, 08:50 AM   #172
talustalus
Human being with feelings
 
Join Date: Dec 2018
Posts: 383
Default

Quote:
Originally Posted by jrengmusic View Post
Find this on Action list
Code:
SWS: Make folder from selected tracks
Thank you
And I can see why this is far more useful then the 'make track a folder' button.

This theme is all-round something special.

Last edited by talustalus; 12-28-2018 at 09:17 PM.
talustalus is offline   Reply With Quote
Old 12-29-2018, 04:48 AM   #173
sightlessness
Human being with feelings
 
sightlessness's Avatar
 
Join Date: Mar 2010
Posts: 911
Default

Ok, so I took Imperial 24 theme, and changed the rtconfig: added the lines
"version 5
global_scale 2.0"
at the top, and guess what? It does the same thing,
places the VU meters below 3 main Track zones (mcp) :P

Also as with JRENG, from the mid to the top area of the track images (icons)
are misplaced.

I do have Display settings in Windows 10 "Change the size of tet, apps, and other itmes" to 200%, always had.

Thanks.

EDIT: Also made an experiment placing the JRENGS theme's images into Imperial's folder (overwriting what it could find) and adding the lines
"version 5
global_scale 2.0"
doing the same thing.
If I remove those lines, and then set in the Advanced UI/system settings "Scale UI elements...." by: 1.90, VU meters still appear at the top and
3 Track zones I mention all the time below as they should. And even buttons/icons appear where they should, I think, but deformed, yet they all work great.
TCP always looks great no matter what (or 9% there sometimeS)
__________________
I want to live PEACEFULLY PLEASE WORLD "LEADERS" GET THIS DONE/LET IT BE FOR GOOD AND MAKE HISTORYYYYYYY! Thanks.

Last edited by sightlessness; 12-29-2018 at 04:57 AM.
sightlessness is offline   Reply With Quote
Old 12-29-2018, 05:21 AM   #174
jrengmusic
Human being with feelings
 
jrengmusic's Avatar
 
Join Date: Jun 2015
Posts: 553
Default

METRIC MCP may look similar to Imperial, and there are macros which taken from Imperial v5 WIP (with a slight modification IIRC), but everything else was coded from scratch. Because it is a different design, by element also by behavior. So the logic was different, thus replacing images with different WALTER might not end up as you expected.
__________________
JRENG! | M E T R I C
jrengmusic is offline   Reply With Quote
Old 12-29-2018, 05:25 AM   #175
sightlessness
Human being with feelings
 
sightlessness's Avatar
 
Join Date: Mar 2010
Posts: 911
Default

After silly things I did, I found a MOTHERFKCING SOLUTION!
I was desperate, that much I liked this... lol.
So, I just changed the value of the line "global_scale 2.0" from 2.0 to 1.9 (which worked) then 1.99,
which also worked. Oh lord.
Made this Reaper project just to show all the track layouts TCP and MCP. I knew it was JUST A DETAIL that had to be messed around with.
What I don't get is why this is happening, lol.

EDIT: I posted my solution ASAP just in case you were at least thinking about a solution, so we could all rest in peace. Computers... lol

yes by Charlie Brown, on Flickr
__________________
I want to live PEACEFULLY PLEASE WORLD "LEADERS" GET THIS DONE/LET IT BE FOR GOOD AND MAKE HISTORYYYYYYY! Thanks.

Last edited by sightlessness; 12-29-2018 at 05:32 AM.
sightlessness is offline   Reply With Quote
Old 12-29-2018, 05:35 AM   #176
sightlessness
Human being with feelings
 
sightlessness's Avatar
 
Join Date: Mar 2010
Posts: 911
Default

Yeah, I was just desperate trying to find a solution.
THANKS SO MUCH for sharing this theme from the first time
I saw it I knew it was "my" theme to go.
When I started using it, I knew design wise to the eyes was very good,
some could say it was cluttered or needed some contrast, whatever, worked
great for me.

AWESOME :P

Quote:
Originally Posted by jrengmusic View Post
METRIC MCP may look similar to Imperial, and there are macros which taken from Imperial v5 WIP (with a slight modification IIRC), but everything else was coded from scratch. Because it is a different design, by element also by behavior. So the logic was different, thus replacing images with different WALTER might not end up as you expected.
__________________
I want to live PEACEFULLY PLEASE WORLD "LEADERS" GET THIS DONE/LET IT BE FOR GOOD AND MAKE HISTORYYYYYYY! Thanks.
sightlessness is offline   Reply With Quote
Old 12-29-2018, 05:59 AM   #177
jrengmusic
Human being with feelings
 
jrengmusic's Avatar
 
Join Date: Jun 2015
Posts: 553
Default

Great!

Maybe it’s REAPER rounding issue with Windows?

Anyway, i’m glad you find solution which might help other user whom having the same problem.

Is the blank MCP label still occurring after the 1.99 scaling?

Edit: Oh you may want to install the METRIC font for the transport.
__________________
JRENG! | M E T R I C
jrengmusic is offline   Reply With Quote
Old 12-29-2018, 07:02 AM   #178
sightlessness
Human being with feelings
 
sightlessness's Avatar
 
Join Date: Mar 2010
Posts: 911
Default

Yes, still blank MCP label on all layouts but Auxiliary.

Yes, I was comparing how it looks on mine and yours (at your site)
lol, I was like ok, I know I installed the Exo 2 font, and that one
at the transport isn't it, went down to the FAQ, yeah, I forgot about that.

Just stumbled your music site, and I went to Youtube, watched the last 2
videos, loved them. Love images with loads of contrast so that's why I loved them, and your editing was spot on. Ofc songs are very nice :P I like how bass is not hidden as in loads of songs on Youtube. Subbed!

So, so far, I have tested a little bit the theme, and can't find anything
unusual except yeah, the blank MCP issue.

Thanks so much again, you don't know how happy I am, I wish you could see me
smiling, lol. Cheers!
__________________
I want to live PEACEFULLY PLEASE WORLD "LEADERS" GET THIS DONE/LET IT BE FOR GOOD AND MAKE HISTORYYYYYYY! Thanks.
sightlessness is offline   Reply With Quote
Old 12-29-2018, 07:43 AM   #179
xpander
Human being with feelings
 
xpander's Avatar
 
Join Date: Jun 2007
Location: Terra incognita
Posts: 4,850
Default

Quote:
Originally Posted by sightlessness View Post
So, I just changed the value of the line "global_scale 2.0" from 2.0 to 1.9 (which worked) then 1.99,
which also worked.
Thanks for posting this, global_scale 2.0 was a good search keyword and found many similar posts about the scale issue. According to many posters it seems 1.9x is a good scale for Windows while 2.0 if fine for Macs?

There was also a mention about scaling to 200% making pink lines 2 pixels wide, which would mess up images relying on pink lines. But I think that was meant when themers are editing already existing images to make the bigger themes. At any rate, a good point top keep in mind.
xpander is online now   Reply With Quote
Old 12-29-2018, 08:22 AM   #180
White Tie
Pixel Pusher
 
White Tie's Avatar
 
Join Date: Mar 2007
Location: Blighty
Posts: 2,565
Default

Quote:
Originally Posted by jrengmusic View Post
My main problem is, I don't have a Windows machine to test. So i couldn't debug the problem in macOS.

What might cause the layouts behave differently on Windows display vs macOS? In this case the track label, and the extmixer layout. Maybe the logic i wrote in WALTER doesn't work on Windows display monitor?

Would you mind have a look at METRIC rtconfig? Perhaps there are line of codes that i could optimize to work on both OS.

Thanks WT.
First things first : ignore the OS thing. The only real OS difference is a slight text baseline difference, but that's a detail thing and I can talk you through fixing it once the text is actually visible I can't guarantee there isn't something weird going on with Windows because it allows all kinds of different scaling factors while OSX is just a simple 1x/2x, and then of course there's the simple matter that Reaper's HiDPI functionality is extremely experimental and could well be a little bit horribly broken ...we're exploring in new territory here. But at first glance it doesn't smell like that.

Here's what I can say for sure: because your mixer design isn't fully responsive, if it opens in a mixer window with the extended mixer set really big (which it does in a vanilla reaper install!) then the design is all scrunched up, and difficult to un-scrunch because the extmixer handle is hidden behind the routing section.

Obviously its not ideal to expect users to understand the fine details of all of this, but we now have the 'toosmall' indicator to solve this. Set it to the minimum height that your design makes sense, and if the user doesn't give it enough space then it'll just scoot off the bottom of the screen. They won't be able to actually use it, but they'll at least understand why and that they need to do some resizing If you want to be a bit more fancypants, add a few more hide commands as the mixer gets really small so it degrades in an attractive (though perhaps not necessarily that useful) way.

Edit : nope, you had it right. There's a Reaper bug, useful data for the experimental mode, thanks!

I don't know what's going on with the mixer label, I can't see it here, and if my guess of the cause is correct then I don't have a clue why it wouldn't be broken for you as well. Very weird. Anyway, my guess is this: you've done something odd with the marginshift macro...

Code:
set base_element        count{0}>0 . + [element element element element element] * * 2{2} [0 0 mcp.size{0}] - totalframes 1
...that multiply by 2 thing ...I don't know why you've done that. mcp.size is your mcp.size, as you set it, irrespective of the screen resolution. The imageshift moves panels by the width of the mcp to mask to different frames, and the marginshift then pushes the text back into view. The way you've used it on the mixer label is correct, your image is set up correctly, so all it needs to do is shove things left or right by a multiple of of the panel width, which is (confusing walter moment alert!) the first value of mcp.size, not the third. I think there's one or more cockups in there that you'll have very little difficulty in fixing If not, then ...er... yeah, maybe you've found a HiDPI bug, and if so then congratulations, that's a very useful thing.





--------------------------------------------------

Quote:
Originally Posted by jrengmusic View Post
METRIC MCP may look similar to Imperial, and there are macros which taken from Imperial v5 WIP (with a slight modification IIRC), but everything else was coded from scratch.
I am far from a credit whore ...but c'mon man. What you have made here is a miraculous achievement and I'd go so far as to say its the finest first-time theme we've ever seen. You've been upfront about your sources; you've taken an existing design and an existing theme and melded them into something new and magnificent, and you've been a stand-up guy by being clear about that. Don't start walking it back now, it gains you nothing.

Looking through your walter, I'm seriously impressed and have 100% confidence that you could do all of this from scratch. And I hope you stick with Reaper theming and do exactly that, you're already easily better at walter than the majority of themers. But it isn't without problems. There's loads of remnants of ImperialV5WIP code in there, mostly (at first glance) looking like its not even doing anything. I always say that modding a theme is harder than making one from scratch, for you I'd say that is doubly true because you're clearly capable of doing this yourself, and doing it well.
__________________
The House of White Tie

Last edited by White Tie; 12-29-2018 at 01:20 PM. Reason: editing for reason
White Tie is offline   Reply With Quote
Old 12-29-2018, 08:25 AM   #181
White Tie
Pixel Pusher
 
White Tie's Avatar
 
Join Date: Mar 2007
Location: Blighty
Posts: 2,565
Default

Quote:
Originally Posted by xpander View Post
According to many posters it seems 1.9x is a good scale for Windows while 2.0 if fine for Macs?
My windows 10 HiDPI test platform is a Surface Pro 4, 2736x1824 at 200% scaling. Works fine.
__________________
The House of White Tie
White Tie is offline   Reply With Quote
Old 12-29-2018, 12:32 PM   #182
sightlessness
Human being with feelings
 
sightlessness's Avatar
 
Join Date: Mar 2010
Posts: 911
Default

All I know is in my system it was giving me this messy "error" (my
screenshots are "proof") and well, at the end of the day little did I know
all I had to do was unzip theme, change value to 1.99, rezip and voilá,
best theme ever in use now (close 2nd Imperial? wink wink :P )

This would help anyone if they (big IF maybe) had my issue now they know.
__________________
I want to live PEACEFULLY PLEASE WORLD "LEADERS" GET THIS DONE/LET IT BE FOR GOOD AND MAKE HISTORYYYYYYY! Thanks.
sightlessness is offline   Reply With Quote
Old 12-29-2018, 01:16 PM   #183
White Tie
Pixel Pusher
 
White Tie's Avatar
 
Join Date: Mar 2007
Location: Blighty
Posts: 2,565
Default

Yeah, you're onto something. There's a Reaper bug here whereby a type[1] extmixer is being forced into being a type[0] at 2x scaling.

Reported. Thanks for the find!
__________________
The House of White Tie

Last edited by White Tie; 12-29-2018 at 01:25 PM.
White Tie is offline   Reply With Quote
Old 12-30-2018, 05:38 AM   #184
jrengmusic
Human being with feelings
 
jrengmusic's Avatar
 
Join Date: Jun 2015
Posts: 553
Default MCP Label

I have couple of minutes before recording next instruments. So, here we go...

White Tie,

Thank you for chiming in and help us sorting up these problems. I really appreciate your thorough inspection on my brutal WALTER coding. Indeed–as you can see on those remnant of codes–Imperial has tremendously influence this theme in a great manner. In fact, without Imperial and your ingenious WALTER coding there wouldn't be METRIC in the first place. So, hats off to you Sir!

----------------------------------------------------------

It's been more than a year past since the last time i touch those codes. I don't remember exactly what were i doing with it back then.

But IIRC, marginshift macro straight from your Imperial v5 WIP does not work as it expected on @2x scaling–at least on my macOS.

The following are comparison between the two on my 2015 15" Retina MacBookPro.

Imperial v5 WIP
Code:
macro marginshift element variable frame totalframes
def count        element##_cnt
def base_element element##_base
set base_element count{0}>0 . + [element element element element element] * [0 0 mcp.size{0}] - totalframes 1
set frameshift   * mcp.size{0} - frame 1
set element      ?variable{0} + base_element * [1 0 -1] frameshift count{0}>0 . base_element
set count        + count [1]
endmacro


Thus, i kinda hack a workaround with those 2 times multiplier, which proven to be working for Retina screen, but it seems cause problem on Windows.

M E T R I C
Code:
macro marginshift element variable frame totalframes
	def count               element##_cnt
	def base_element 	 element##_base
	set base_element        count{0}>0 . + [element element element element element] * * 2{2} [0 0 mcp.size{0}] - totalframes 1
	set frameshift          * * 2 mcp.size{0} - frame 1
	set element             ?variable{0} + base_element * [1 0 -1] frameshift count{0}>0 . base_element
	set count               + count [1]
endmacro


Perhaps, have we found another bug on REAPER's experimental HiDPI/Retina functionality?

OK, GTG. Now i have to back to record some music...
__________________
JRENG! | M E T R I C
jrengmusic is offline   Reply With Quote
Old 12-30-2018, 08:50 AM   #185
White Tie
Pixel Pusher
 
White Tie's Avatar
 
Join Date: Mar 2007
Location: Blighty
Posts: 2,565
Default

Quote:
Originally Posted by jrengmusic View Post
Perhaps, have we found another bug on REAPER's experimental HiDPI/Retina functionality?
Indeed! On windows if I remove your doubling multipliers from base_element and frameshift, the track name appears. So my guess is that your adjustments were needed because its misreporting mcp.size on OSX, though I can't confirm that because my mac isn't retina. I'll report as much as we know and hopefully that'll be enough.
__________________
The House of White Tie
White Tie is offline   Reply With Quote
Old 12-30-2018, 03:39 PM   #186
sightlessness
Human being with feelings
 
sightlessness's Avatar
 
Join Date: Mar 2010
Posts: 911
Default

Awesome you fixed the names now, still I got to use 1.99 for "exact" replica
in your website screenshots.

But if I change the value back to 2.0 the theme works great either way, elements
work all great and no surprises, but VU meters are now not on top, which is something some would prefer, and get more real estate for FX inserts and stuff.

But since I found out with the mouse wheel you can browse that real estate, I
am using 1.99 anyway (not because i like or dont like VU meters at the top)
but because overall for me is more aesthetic that way.
__________________
I want to live PEACEFULLY PLEASE WORLD "LEADERS" GET THIS DONE/LET IT BE FOR GOOD AND MAKE HISTORYYYYYYY! Thanks.

Last edited by sightlessness; 12-30-2018 at 05:04 PM.
sightlessness is offline   Reply With Quote
Old 01-01-2019, 12:56 PM   #187
SBK
Human being with feelings
 
Join Date: May 2016
Posts: 243
Default

Dude..

This is crazy, does it goes for normal resolution too?
SBK is offline   Reply With Quote
Old 01-01-2019, 05:42 PM   #188
sightlessness
Human being with feelings
 
sightlessness's Avatar
 
Join Date: Mar 2010
Posts: 911
Default

Nay /5char
__________________
I want to live PEACEFULLY PLEASE WORLD "LEADERS" GET THIS DONE/LET IT BE FOR GOOD AND MAKE HISTORYYYYYYY! Thanks.
sightlessness is offline   Reply With Quote
Old 01-04-2019, 10:29 AM   #189
White Tie
Pixel Pusher
 
White Tie's Avatar
 
Join Date: Mar 2007
Location: Blighty
Posts: 2,565
Default

Update:

bug 1 (mode1 extmixer shifting to mode0 at global scale >2) has been fixed in the latest pre-release version, so please stand by for that to be in the next full release.

bug 2 : If I make the following changes to revert changes to the marginshift macro, it fixes all problems on Windows and doesn't cause problems on non-retina OSX.

Code:
set base_element    count{0}>0 . + [element element element element element] * * 2{2} [0 0 mcp.size{0}] - totalframes 1
set frameshift      * * 2 mcp.size{0} - frame 1
to
Code:
set base_element    count{0}>0 . + [element element element element element] * [0 0 mcp.size{0}] - totalframes 1
set frameshift      * mcp.size{0} - frame 1

so the next test would be for someone with a retina mac to make those changes and see if they break the mixer name field.
__________________
The House of White Tie
White Tie is offline   Reply With Quote
Old 01-04-2019, 02:07 PM   #190
jrengmusic
Human being with feelings
 
jrengmusic's Avatar
 
Join Date: Jun 2015
Posts: 553
Default

Quote:
Originally Posted by White Tie View Post
Update:

bug 2 : If I make the following changes to revert changes to the marginshift macro, it fixes all problems on Windows and doesn't cause problems on non-retina OSX.
Code:
set base_element    count{0}>0 . + [element element element element element] * [0 0 mcp.size{0}] - totalframes 1
set frameshift      * mcp.size{0} - frame 1
so the next test would be for someone with a retina mac to make those changes and see if they break the mixer name field.
Thanks for the heads up.

Tested on latest pre v5.965+dev1231 / reaper5965+dev1231-icc18_x86_64. Without doubling multipliers, the mixer label still broken on retina screen.
__________________
JRENG! | M E T R I C
jrengmusic is offline   Reply With Quote
Old 01-12-2019, 11:50 AM   #191
woogish
Human being with feelings
 
Join Date: Feb 2011
Posts: 596
Default

This theme is way too glaring for me, but MAN! A LOT of real good ideas here! Such as:
more detail in slider markings (mcp_volbg) on select..... my favorite theme would be one that shows most tcp/mcp controls/knobs only on hover or select, excepting volume, pan, mute and solo. "Show on demand" would include i/o routing, fx stuff, etc.
I PREFER LESS CLUTTER!!! This theme has that feature.
Good thinking on much of this theme.

2 HOURS LATER-
The more I look at this, the more I like it... especially the "lit up" look of the rec, solo, and mute buttons.......

Last edited by woogish; 01-12-2019 at 12:14 PM.
woogish is offline   Reply With Quote
Old 01-12-2019, 09:39 PM   #192
sightlessness
Human being with feelings
 
sightlessness's Avatar
 
Join Date: Mar 2010
Posts: 911
Default

What line of code do I need to change to nudge the faders on the mcp
a little up. Even at 2 global scale (rememeber we have it at 1.99 on Windows)
at zero (unity gain, whatever you wanna call it) faders don't line up with the
lines drawn there.

Thanks! (reading Walter guide now I guess)
__________________
I want to live PEACEFULLY PLEASE WORLD "LEADERS" GET THIS DONE/LET IT BE FOR GOOD AND MAKE HISTORYYYYYYY! Thanks.
sightlessness is offline   Reply With Quote
Old 01-12-2019, 11:43 PM   #193
jrengmusic
Human being with feelings
 
jrengmusic's Avatar
 
Join Date: Jun 2015
Posts: 553
Default

The faders line up at unity for volume fader range +18dB Default shape.
__________________
JRENG! | M E T R I C
jrengmusic is offline   Reply With Quote
Old 01-13-2019, 11:27 AM   #194
sightlessness
Human being with feelings
 
sightlessness's Avatar
 
Join Date: Mar 2010
Posts: 911
Default

The highest my faders go is 12+ db :P

So I can't move faders? For future themes I'd like to know. Thanks.
__________________
I want to live PEACEFULLY PLEASE WORLD "LEADERS" GET THIS DONE/LET IT BE FOR GOOD AND MAKE HISTORYYYYYYY! Thanks.
sightlessness is offline   Reply With Quote
Old 01-13-2019, 04:00 PM   #195
lucas_LCS
Human being with feelings
 
Join Date: Dec 2015
Posts: 693
Default

Quote:
Originally Posted by sightlessness View Post
The highest my faders go is 12+ db :P

So I can't move faders? For future themes I'd like to know. Thanks.
Do you have the volume fader range set to +18 in the preferences?
This section is at the bottom of the Track Control Panels page.
It's labeled as: /Volume/Pan Faders
lucas_LCS is offline   Reply With Quote
Old 01-13-2019, 04:12 PM   #196
sightlessness
Human being with feelings
 
sightlessness's Avatar
 
Join Date: Mar 2010
Posts: 911
Default

Awesome Lucas, thank you very much. I was looking for that
but there's so much to read within Reaper, lol.

Now my faders line up perfectly.

Do we need faders going that high? Is it useful because
maybe our recorded audio is very quiet so we just use the fader
instead of normalizing stuff?

Just wondering as I don't know what is the standard way to work with DAWS.

Thanks again so much
__________________
I want to live PEACEFULLY PLEASE WORLD "LEADERS" GET THIS DONE/LET IT BE FOR GOOD AND MAKE HISTORYYYYYYY! Thanks.
sightlessness is offline   Reply With Quote
Old 01-14-2019, 12:32 AM   #197
jrengmusic
Human being with feelings
 
jrengmusic's Avatar
 
Join Date: Jun 2015
Posts: 553
Default

Quote:
Originally Posted by sightlessness View Post
Do we need faders going that high? Is it useful because
maybe our recorded audio is very quiet so we just use the fader
instead of normalizing stuff?
Normalizing item means you change the gain pre-insert-FX on track, whereas fader is post-FX. Depending on what FX you put on the track fx insert slot, the result are two different stories.
__________________
JRENG! | M E T R I C
jrengmusic is offline   Reply With Quote
Old 01-14-2019, 04:27 AM   #198
sightlessness
Human being with feelings
 
sightlessness's Avatar
 
Join Date: Mar 2010
Posts: 911
Default

You're so right thanks for reminding me of that.
Some plugins do react depending of the input volume
they get.

Cheers.
__________________
I want to live PEACEFULLY PLEASE WORLD "LEADERS" GET THIS DONE/LET IT BE FOR GOOD AND MAKE HISTORYYYYYYY! Thanks.
sightlessness is offline   Reply With Quote
Old 01-14-2019, 05:43 AM   #199
blackiyto
Human being with feelings
 
Join Date: Jan 2019
Posts: 4
Default

Wow. Great theme! Keep it up!
Bluestacks Kodi Lucky Patcher

Last edited by blackiyto; 01-24-2019 at 02:24 PM.
blackiyto is offline   Reply With Quote
Old 01-14-2019, 09:06 AM   #200
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 12,438
Default

Quote:
Originally Posted by jrengmusic View Post
Thanks for the heads up.

Tested on latest pre v5.965+dev1231 / reaper5965+dev1231-icc18_x86_64. Without doubling multipliers, the mixer label still broken on retina screen.
Hmm can you make me a minimal test/demo? Thanks
Justin is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 12:30 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.