Old 01-05-2020, 09:05 AM   #1
Pinknoise
Human being with feelings
 
Pinknoise's Avatar
 
Join Date: Aug 2012
Location: Around Montréal
Posts: 946
Default Manjaro-RT Cinnamon

I was happy to try this distro as it has both RT and cinnamon wich I like a lot.

To my surprise it runs very smoothly at average 0,7% cpu use on idle.

But... when trying to run reaper even at 5,6 ms latency (256 samples) Reaper freezes. It seems to happen mostly with Kontakt but I did'nt do extensive testing yet.

I run windows plugins through Linvst and use cadence to set things up.

All installs come from the AUR repositories mostly.

I see 2 things in HTOP that seems to be the culprit:
-PulseAudio blablabla Deamon is acting up 12-20% cpu use (maybe this is normal using RT)
-Cinnamon --replace is acting the worst 20%+ cpu use.

I did some of the tweaks suggested in another thread like turning off windows tiling and disable compositing.

I was wondering if you guys had any tips as where to tweak I tried to change PulseAudio for Alsa but I can't make it happen, do you guys know why when I choose my usb interface via alsamixer in terminal, it always reverts back to PulseAudio ?
Some pointers to change to alsa might be a good solution to try. Do you guys use cadence to set things up ?

I have more luck with Xubuntu so far.
Pinknoise is offline   Reply With Quote
Old 01-05-2020, 12:41 PM   #2
Glennbo
Human being with feelings
 
Glennbo's Avatar
 
Join Date: Mar 2008
Location: Planet Earth
Posts: 4,319
Default

I'm running Xubuntu and have Pulse Audio set to use my motherboard audio so there's no conflict for REAPER to use my 8 input USB audio hardware. In REAPER I only had to choose ALSA and then select my UMC1820 from the list.

I did do the tweaks elevating my user profile for unlimited memory and RT priority privileges, plus set the RT priority of my USB sound device to 98% and installed the linux-lowlatency kernel. I run my sound device at 64 samples latency and 4 periods with no artifacts in the audio or sluggishness in response.
__________________
Glennbo
Hear My Music - Click Me!!!
--
Glennbo is offline   Reply With Quote
Old 01-05-2020, 12:49 PM   #3
Pinknoise
Human being with feelings
 
Pinknoise's Avatar
 
Join Date: Aug 2012
Location: Around Montréal
Posts: 946
Default

ALSA: error setting input device format bit
Pinknoise is offline   Reply With Quote
Old 01-05-2020, 01:09 PM   #4
Glennbo
Human being with feelings
 
Glennbo's Avatar
 
Join Date: Mar 2008
Location: Planet Earth
Posts: 4,319
Default

If you go into the Pulse Audio mixer and hit the Configuration tab, what audio device is selected? It should NOT be the audio device you want to use with REAPER or it will likely interfere with REAPER being able to latch onto it.

It's also possible that Cadence has JACK locked onto your audio hardware, which could make the ALSA layer unavailable. I used to use JACK but when I bought my UMC1820 I did a clean install of Xubuntu and didn't touch anything dealing with JACK and ALSA worked without a hitch in REAPER.
__________________
Glennbo
Hear My Music - Click Me!!!
--
Glennbo is offline   Reply With Quote
Old 01-05-2020, 03:36 PM   #5
Peevy
Human being with feelings
 
Peevy's Avatar
 
Join Date: May 2008
Location: Ireland
Posts: 519
Default

I wouldn't bother with jack & just use alsa in reaper. Been doing it that way in Manjaro for over a year now without a problem. I think the only real reason to use jack is if you're connecting to other outside applications, if
everything is containded within Reaper just use alsa.

What soundcard are you using & have you cheked it's fully compatible with Linux?
__________________
System: Mobo-Asus Prime Z370P II, CPU-i7 8700K, RAM-32gb DDR4 3000mhz, GPU AMD RX580 OS: Manjaro Linux
Soundcard:
Komplete Audio 6 Monitors: Adam A5X
Peevy is offline   Reply With Quote
Old 01-05-2020, 05:28 PM   #6
Pinknoise
Human being with feelings
 
Pinknoise's Avatar
 
Join Date: Aug 2012
Location: Around Montréal
Posts: 946
Default

The interface is NI Session. A small 2 inputs usb unit.
It worked in every distro I tried it's ALSA that I have trouble with but I installed KXStudio in almost every distro so I did'nt really try hard without jack.

I thought that was the easiest way but now something else to try.

EDIT: vanilla install of Manjaro, turn off NI Session in PulseAudio config still the same:
ALSA: error setting input device format bits

Last edited by Pinknoise; 01-05-2020 at 06:24 PM.
Pinknoise is offline   Reply With Quote
Old 01-05-2020, 08:52 PM   #7
Pinknoise
Human being with feelings
 
Pinknoise's Avatar
 
Join Date: Aug 2012
Location: Around Montréal
Posts: 946
Default

Is it possible that by interface is recognized by PulseAudio and not by ALSA ?

Actually ALSA sees it because I can select it in Reaper.

I can find nothing on the interwebs on this particular subject.
Pinknoise is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 05:44 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.