Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 08-08-2016, 04:11 AM   #1
Sexan
Human being with feelings
 
Sexan's Avatar
 
Join Date: Jun 2009
Location: Croatia
Posts: 2,010
Default Playback extremly choppy and distorted when midi editor is opened

I'm experiencing this problem and cannot work when midi editor is opened.When closed everything is ok.I'm on latest Reaper x64 (tried other versions its the same).
Windows 10 x64
RME 800
Reaper 5.22 x64 (and any other version)

here is the loopback record of whats going on.it starts when midi editor is opened and then I close it after:
https://stash.reaper.fm/28215/midieditor.mp3

I don't know when this problem started because I don't work much with midi,but the newest thing I've got In my setup is RME 800

Last edited by Sexan; 08-08-2016 at 04:17 AM.
Sexan is offline   Reply With Quote
Old 08-09-2016, 12:55 AM   #2
Sexan
Human being with feelings
 
Sexan's Avatar
 
Join Date: Jun 2009
Location: Croatia
Posts: 2,010
Default

Can anyone help please it is literally unworkable
Sexan is offline   Reply With Quote
Old 08-09-2016, 01:23 AM   #3
EvilDragon
Human being with feelings
 
EvilDragon's Avatar
 
Join Date: Jun 2009
Location: Croatia
Posts: 22,030
Default

Tweak the media buffering and/or anticipative processing options for MIDI editor in Preferences->Audio->Buffering.
EvilDragon is online now   Reply With Quote
Old 08-09-2016, 01:31 AM   #4
Sexan
Human being with feelings
 
Sexan's Avatar
 
Join Date: Jun 2009
Location: Croatia
Posts: 2,010
Default

omg thank you!
I've checked "Allow on tracks with open MIDI editor..." and now it works fine
Sexan is offline   Reply With Quote
Old 08-09-2016, 01:32 AM   #5
EvilDragon
Human being with feelings
 
EvilDragon's Avatar
 
Join Date: Jun 2009
Location: Croatia
Posts: 22,030
Default

It increases editing preview latency but manages CPU much better...
EvilDragon is online now   Reply With Quote
Old 08-09-2016, 01:34 AM   #6
Sexan
Human being with feelings
 
Sexan's Avatar
 
Join Date: Jun 2009
Location: Croatia
Posts: 2,010
Default

yeah I am aware but its not a problem I'm not doing anything live or playing.But I still dont understand why is this happening when midi editor is opened ?
Sexan is offline   Reply With Quote
Old 08-09-2016, 01:59 AM   #7
EvilDragon
Human being with feelings
 
EvilDragon's Avatar
 
Join Date: Jun 2009
Location: Croatia
Posts: 22,030
Default

Because if that option is disabled, it disables anticipative processing for the tracks that are open in MIDI editor, and then all plugins on those tracks go into realtime thread (which is only on a single core)...

Last edited by EvilDragon; 08-09-2016 at 02:06 AM.
EvilDragon is online now   Reply With Quote
Old 08-09-2016, 02:34 AM   #8
vanhaze
Human being with feelings
 
vanhaze's Avatar
 
Join Date: Jul 2012
Location: Netherlands
Posts: 4,588
Default

Wow, this is very useful and understanding info, many thanks !
vanhaze is offline   Reply With Quote
Old 08-26-2017, 09:16 AM   #9
wjmwpg
Human being with feelings
 
wjmwpg's Avatar
 
Join Date: Feb 2017
Location: Winnipeg, Manitoba, Canada
Posts: 128
Default

Thanks. I was having this issue and found this answer very quickly. So great to have this community.
__________________
Switched to Reaper on 19FEB17 after a decade+ on Logic Pro.
wjmwpg is offline   Reply With Quote
Old 07-17-2018, 04:22 AM   #10
MrNocturne
Human being with feelings
 
MrNocturne's Avatar
 
Join Date: Nov 2011
Posts: 15
Default

Can't thank you enough EvilDragon! Saved me from a quite severe tantrum.
MrNocturne is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 04:29 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.