Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 10-27-2021, 12:43 AM   #1
Corpu5
Human being with feelings
 
Join Date: Jun 2021
Posts: 1
Default Saving the Reaper 6.38 settings configuration fails (FIXED)

Saving the Reaper 6.38 settings configuration fails. Determined that it is these 2 scripts that prevent the configuration from being saved. The archive with the configuration settings file is not created at all due to these errors.
Please correct this.
Windows 10. The latest updates were installed at the time the error occurred.

Corpu5 is offline   Reply With Quote
Old 11-11-2021, 10:37 AM   #2
PashaKarpov
Human being with feelings
 
Join Date: Nov 2017
Posts: 2
Default

This is due to the very long file names. I made them shorter and everything was recorded.
PashaKarpov is offline   Reply With Quote
Old 11-11-2021, 03:51 PM   #3
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 13,703
Default

Making it so that the config export still succeeds in these cases (minus the files that failed)
Justin is offline   Reply With Quote
Old 11-11-2021, 04:26 PM   #4
akademie
Human being with feelings
 
Join Date: Mar 2007
Posts: 2,527
Default

Quote:
Originally Posted by Justin View Post
Making it so that the config export still succeeds in these cases (minus the files that failed)
... and giving a report which files failed during export, Justin, please?
akademie is offline   Reply With Quote
Old 11-11-2021, 05:47 PM   #5
akademie
Human being with feelings
 
Join Date: Mar 2007
Posts: 2,527
Default

BTW, accented characters (like ěščřž etc. and also that "" long dash sign which is used in Win7 when duplicating file in Explorer, so it ends like this "filename – kopie.lua", are encoded wrong. In zip it then looks like this:
"ěščřž-file – kopie.lua" > "Ť+Ź++ż+Ż++ş-file kopie.lua"

Windows 7 Professionial (Czech) 32-bit + Reaper v6.41 (32-bit)

Last edited by akademie; 11-11-2021 at 06:03 PM.
akademie is offline   Reply With Quote
Old 11-11-2021, 07:40 PM   #6
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 13,703
Default

Quote:
Originally Posted by akademie View Post
... and giving a report which files failed during export, Justin, please?
If you look at the listview it will show the status of each file, yeah.
Justin is offline   Reply With Quote
Old 11-11-2021, 07:41 PM   #7
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 13,703
Default

Quote:
Originally Posted by akademie View Post
BTW, accented characters (like ěščřž etc. and also that "" long dash sign which is used in Win7 when duplicating file in Explorer, so it ends like this "filename – kopie.lua", are encoded wrong. In zip it then looks like this:
"ěščřž-file – kopie.lua" > "Ť+Ź++ż+Ż++ş-file kopie.lua"

Windows 7 Professionial (Czech) 32-bit + Reaper v6.41 (32-bit)
It is using UTF-8 for the filenames, but oops it's not setting that hint bit in the .zip file. REAPER reads it anyway :/

Last edited by Justin; 11-11-2021 at 08:01 PM.
Justin is offline   Reply With Quote
Old 11-11-2021, 07:41 PM   #8
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 13,703
Default

also: the latest +dev builds should support extra-long-pathnames natively
Justin is offline   Reply With Quote
Old 11-11-2021, 08:10 PM   #9
akademie
Human being with feelings
 
Join Date: Mar 2007
Posts: 2,527
Default

great, thanks
akademie is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 03:20 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.