Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 02-13-2021, 07:48 AM   #1
szoroskobold
Human being with feelings
 
Join Date: Feb 2021
Posts: 5
Default Convolution effects: increased dB level with increased samplerate (FIXED)

tl,dr: goto RESULT

Hello,
Maybe it has already been reported there but I have not found in Bug Reports, so decided to tell.
While using an evaluation version I did an "only stock plugins challenge"; to spare up CPU power, I worked on my mix @48kHz samplerate, then rendered @192kHz in order to have enough frequency headroom for saturation effects (thus to reduce aliasing to non-audible range). The mix sounded just perfect to me. Then I listened to the exported version: the electric guitars became WAY louder, the reverbs sounded exaggerated.
After a long line of experiments of switching plugins one by one, switching samplerate and watching max peak meter for a loop,
:RESULT
I got that
- JS effect 'Convolution Amp/Cab Modeler" made a ~+6dB increase in output by doubling samplerate (48k->96k)
- ReaVerb around ~+3.5 dB (somehow I could not measure the exact value but it was quite audible)
- JS Distortion ~1dB, it was not really audible and even could have been only because of the better waveform reproduction, almost lack of aliasing etc.
:END( of RESULT)

I made measurements with ReaGate, ReaEQ and ReaComp, JS Major Tom Compressor, JS Non-Linear Processor, JS Volume Adjustment, JS Saturation, JS RBJ 4-Band Semi-Parametric EQ as well - none of them had a noticeable effect as listed above.

As this side effect could ruin a whole mix and is uncontrollable (if we do not perfectly know what dB increase to count with each effects, and we may NOT know), I consider this a bug.
I really like to only use the stock plugins for mixing, most of them sound GREAT, they do what they were made for - and not being distracted by shiny fake "knobs", it really makes me increase my creativity. Considering that, I would really appreciate if they worked under any common conditions such as the one I mentioned.
Thank you for understatement.
szoroskobold is offline   Reply With Quote
Old 02-14-2021, 07:22 AM   #2
Tale
Human being with feelings
 
Tale's Avatar
 
Join Date: Jul 2008
Location: The Netherlands
Posts: 3,204
Default

I think you're right about ReaVerb (I haven't tested the others), and I think I know how to fix it: I think ReaVerb does the same as the JSFX convolution code I posted a few years ago, which is scale by sample rate ratio. However, it would seem that this isn't correct; I guess you should scale by IR sum instead.
Tale is offline   Reply With Quote
Old 02-14-2021, 10:37 AM   #3
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 13,340
Default

Hi,

What impulses are you noticing this with? Could you share one or two of the most obvious ones that we can test against? Thanks!
Justin is online now   Reply With Quote
Old 02-14-2021, 01:22 PM   #4
szoroskobold
Human being with feelings
 
Join Date: Feb 2021
Posts: 5
Default

Sure!
In Convolution Amp/Cab Modeler I was using that Dumble Overdrive Special and Fender Bassman - Fender Bassman ones that come with Reaper; in ReaVerb that one:
https://drive.google.com/file/d/154v...ew?usp=sharing
szoroskobold is offline   Reply With Quote
Old 02-14-2021, 03:33 PM   #5
szoroskobold
Human being with feelings
 
Join Date: Feb 2021
Posts: 5
Default

One more thought I came to today.
Until now, I changed the whole project samplerate _before_ rendering. That made that side effect I wrote before.
Now, I tried doing like that: I unchecked the one for resampling (I choose then 512pt) just in the rendering window and rendered the project. After that, neither the guitars did sound louder, nor reverb became exagerated - maybe it sounded a little smoother, probably because of the lack of those unwanted artifacts (I really do not have golden ears, so do not know...). Thus, the problem only occurs while changing the whole project samplerate. That may be needed in some rare cases - of course, better avoid it.
szoroskobold is offline   Reply With Quote
Old 02-14-2021, 03:44 PM   #6
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 13,340
Default

Quote:
I worked on my mix @48kHz samplerate, then rendered @192kHz in order to have enough frequency headroom for saturation effects (thus to reduce aliasing to non-audible range). The mix sounded just perfect to me
If it sounded perfect then you should render at 48k!

Anyway, thanks! Latest +dev build has fixes for this (though you'll need to manually adjust the modes of any pre-existing respective plug-ins in order to get the new behavior).
Justin is online now   Reply With Quote
Old 02-14-2021, 03:53 PM   #7
szoroskobold
Human being with feelings
 
Join Date: Feb 2021
Posts: 5
Default

Quote:
Originally Posted by Justin View Post
If it sounded perfect then you should render at 48k!

Anyway, thanks! Latest +dev build has fixes for this (though you'll need to manually adjust the modes of any pre-existing respective plug-ins in order to get the new behavior).
Well, when I did today with 512pt Sinc resample, it sounded (adjective as ungramatically as possible) even more perfecteeer to me (-: Maybe was just placebo because I do not really have well-trained ears as I mentioned above, but I ams sure it certainly did not became worse.

Anyway, thank you for your answers and work!
szoroskobold is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 07:12 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.