Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 06-09-2020, 07:35 PM   #1
JamesPeters
Human being with feelings
 
Join Date: Aug 2011
Location: Near a big lake
Posts: 3,576
Default "Send all keyboard input to plug-in" not working correctly in REAPER for Linux

At first I noticed this in a particular way, that playback start/stop won't respond when JUCE-based plugin is in focus. I had the option "Send all keyboard input to plug-in" off by default, and I tested with it enabled as well, but I didn't realize a connection until now. The original bug report info (which is just a symptom) is in the second "quote" below.

The new information which points to the actual problem is in the first "quote" just below:
Quote:
1. "Send all keyboard input to plug-in" not working correctly in REAPER for Linux

How to reproduce (one example):
  • Open ReaComp in REAPER for Linux. Ensure "Send all keyboard input to plug-in" is enabled.
  • Place the cursor in a text field. Hit the space bar.
  • Playback will start (or stop, if it's already playing) instead of using the keyboard to enter a space in the field of the plugin. There's no difference to having "Send all keyboard input to plug-in" turned off.
By contrast in REAPER for Windows, the spacebar would send a space character into the field instead of starting/stopping playback (I tested this on a computer that has Windows).

In itself, as per that example, it's not a problem for me. However the behavior lends itself to something annoying: if a plugin wants to capture keyboard input automatically from REAPER, you can't disable that by unchecking "Send all keyboard input to plug-in". So with some plugin windows in focus after you click on a parameter (apparently with JUCE-based plugins, since they want to grab all keyboard input), you can't start or stop playback until you click away to another window or close the plugin window. That problem is what I first noticed, and it's explained below.

Quote:
2. Playback start/stop won't respond when JUCE-based plugin is in focus, in REAPER for Linux

This is an annoying symptom of the problem described above.

How to reproduce:
  • Open a Linux VST (a list of problematic plugins I noticed is below).
  • Adjust a parameter.
  • Without closing the fx window or clicking away (on the arrange view or somewhere else), hit spacebar. Playback won't start (if playback is stopped) or stop (if playback is active).
Changing the playback start/stop shortcut to any other key doesn't help either. Even if you unfocus the plugin itself by clicking on the window title bar or the fx chain list on the left side, playback won't start/stop.

"Send all keyboard input to plug-in" option is already disabled. I tried it both ways, and the same behavior exists.

Changing the playback start/stop shortcut to "global" or "global + text fields" also doesn't help with this.

It seems to be Linux VST made with JUCE which exhibit this behavior. Here is the list of all the Linux VST that I've noticed have this behavior in Reaper for Linux (these are all free plugins except the Audio Assault ones):This behavior has existed ever since I started using Reaper for Linux, with those plugins. I've changed Linux distros several times and updated Reaper many times since then. So it hasn't started as of a recent Reaper version or Linux distro (etc.)

Someone else running Ubuntu 19.10 noticed this as well. That's when I started testing other plugins, and on different distros. This happens with Gnome, XFCE, and KDE Plasma and Cinnamon.

I tested this with several versions of Reaper (Linux and Windows) from 6.13 and as far back as version 5.984.

This doesn't happen in Reaper for Windows 64-bit. I tested this on an older computer I have which still has Windows 7 64-bit, using the Windows VST3 plugin of Odin by Wave Warden (which has a brief "Made with JUCE" logo that appears at the bottom right corner when the plugin opens whether it's the Linux or Windows version, so it's a dead giveaway). It works fine. So this seems to be something that affects Reaper for Linux only.
Quote:
Also:

This is probably a different issue but I just recalled it while testing: double-clicking in the fx browser window in REAPER for Linux doesn't bring up the "add fx" dialog in any distro that I've tried so far.
__________________
Using REAPER for Linux on Manjaro 21.0.4

Last edited by JamesPeters; 10-03-2020 at 12:50 PM.
JamesPeters is offline   Reply With Quote
Old 06-09-2020, 07:39 PM   #2
Meo-Ada Mespotine
Human being with feelings
 
Meo-Ada Mespotine's Avatar
 
Join Date: Apr 2020
Location: Leipzig
Posts: 2,380
Default

Have you tested, if they work on other Linux-DAWs who accept VST?

Dunno if Ardour supports VST...
__________________
Use you/she/her, when contacting me, please. Thanks :) Not mentoring via PMs, sorry.
Ultraschall-API - 1385 ReaScript functions for Reaper - Reaper Internals - Developerdocs4Reaper - Donate, if you wish
Meo-Ada Mespotine is offline   Reply With Quote
Old 06-10-2020, 03:54 AM   #3
Meo-Ada Mespotine
Human being with feelings
 
Meo-Ada Mespotine's Avatar
 
Join Date: Apr 2020
Location: Leipzig
Posts: 2,380
Default

The reason I asked was, that we can know this way, if only Reaper shows the problem or if it's a problem with Juce on Linux in general. Narrowing it down to that can be a worthy hint for the devs.
__________________
Use you/she/her, when contacting me, please. Thanks :) Not mentoring via PMs, sorry.
Ultraschall-API - 1385 ReaScript functions for Reaper - Reaper Internals - Developerdocs4Reaper - Donate, if you wish
Meo-Ada Mespotine is offline   Reply With Quote
Old 07-30-2020, 04:34 PM   #4
JamesPeters
Human being with feelings
 
Join Date: Aug 2011
Location: Near a big lake
Posts: 3,576
Default

[edit] It seems JUCE itself (at least how people use it to make Linux VST and Linux LV2) is to blame for some of this, at least.

However it still seems that "Send all keyboard input to plug-in" doesn't work correctly in Reaper for Linux (and therefore can't be disabled properly).
__________________
Using REAPER for Linux on Manjaro 21.0.4

Last edited by JamesPeters; 02-14-2021 at 12:42 PM.
JamesPeters is offline   Reply With Quote
Old 11-16-2020, 12:14 AM   #5
PMan
Human being with feelings
 
Join Date: Aug 2019
Posts: 168
Default

Yeah, this happens to me too.

I'm running the latest Reaper on Ubuntu 19.10
PMan is offline   Reply With Quote
Old 11-16-2020, 12:39 AM   #6
Concrete
Human being with feelings
 
Concrete's Avatar
 
Join Date: Oct 2013
Location: Leftside In Mono Right?
Posts: 77
Default

I am also having this issue - Mint 20 with Reaper 6.15.
__________________
__________________
Signed by the Said?
Concrete is offline   Reply With Quote
Old 02-14-2021, 11:28 AM   #7
Shane Dunne
Human being with feelings
 
Join Date: Oct 2017
Posts: 1
Default Keystroke handling in JUCE is tricky

Hi folks. I'm the author of the JUCE port of the Dragonfly plug-ins. This was done with permission of Michael Willis, for use in another context entirely. Michael expressed interest in bringing the JUCE-based code into the main GitHub repo, so I sent a Pull Request, which appears to remain open.

Here's what I wrote in response to James's comment on the open PR:

> Keystroke handling is a real bugaboo in JUCE. Most GUI widgets seem to grab input focus by default, and you have to add code to every single one, to tell it not to. I struggle with this all the time in my JUCE based projects. I'll add a note to my to-do list to look into this for the Dragonfly reverbs, but it's a very long list, so I can't say when I'll be able to get to it.

If any JUCE experts care to advise on how best to resolve this, I'm all ears!
Shane Dunne is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 08:24 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.