COCKOS
CONFEDERATED FORUMS
Cockos : REAPER : NINJAM : Forums
Forum Home : Register : FAQ : Members List : Search :

Go Back   Cockos Incorporated Forums > Other Software Discussion > WDL users forum

Reply
 
Thread Tools Display Modes
Old 03-25-2020, 11:36 PM   #1
Nonlinear
Human being with feelings
 
Join Date: Apr 2018
Posts: 293
Default VST3 Parameter loading problem in Samplitude

Anyone here experienced issues with VST3 parameters loading incorrectly in Samplitude when re-opening a saved project?

Debugger shows that Samplitude is loading all of my VST3 plugin parameters properly but then goes back and overwrites some of them with the DEFAULT values as specified in the plugin's constructor.

I cannot figure out WHY it is doing that - any ideas? It is not doing this with the VST2 version or in any other DAW.

Last edited by Nonlinear; 03-26-2020 at 09:20 AM.
Nonlinear is offline   Reply With Quote
Old 03-26-2020, 09:50 AM   #2
Nonlinear
Human being with feelings
 
Join Date: Apr 2018
Posts: 293
Default

I have narrowed this down to the "Default" preset (MakeDefaultPreset("Default", 1)). If the plugin is loaded with it's initial Default preset and then the user changes those parameters Samplitude does not restore those parameters properly upon project re-load. It initially loads the correct values but then takes a few more steps and overwrites the last parameters touched with their default settings. No idea why as degugging shows nothing in the plugin is triggering this as far as I can tell.

HOWEVER, if any of the built-in ("MakePreset") presets are selected and then edited, Samplitude DOES restore all of those settings properly on project re-open.

Not sure what this means. Bug in my plugin - or in Samplitude? (Customer has reported problems with other developer's VST3 plugins in Samplitude too, so...)

Last edited by Nonlinear; 03-27-2020 at 04:49 PM.
Nonlinear is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 11:36 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.