Old 03-15-2016, 04:08 AM   #1
fredrikd
Human being with feelings
 
Join Date: Jan 2012
Posts: 6
Default First MIDI notes louder after playback start

Hi!

First of all, I'm not sure if this is a Reaper bug or if it's caused by some other issue, so I'm sorry if this has no place here. I haven't got any other suitable DAW to crosscheck.

What happens is that after I hit "play" the first appearing notes on every midi track are played back louder and then gradually stabilizes on the volume I've set, as if I'd given every note it's own velocity setting, gradually declining from around correct volume + 6db to correct volume.

This happens within a timeframe of about 0,5 - 1 second, so the amount of notes that are played back louder depends on how many notes are played within that timeframe. This happens to the first notes on every MIDI track, so if one of the MIDI tracks doesn't play notes at the exact point I choose to start the playback, the first notes on that MIDI track will be louder later, when the track starts playing notes.

It's not an issue of note-doubling, as it occurs whenever and wherever I decide to start the playback from. Deleting notes doesn't help.

It's not a NI Kontakt issue, as it happens to other plugins as well.

My current workaround is to automate the volume of each midi track the first 0,5 - 1 second when the track plays its first notes (to avoid volume increase on the track export/bounce), but as I'm sure you can understand it's no lasting solution

I appreciate any and all help, and hope this has an easy solution that I've simply overlooked.
fredrikd is offline   Reply With Quote
Old 03-22-2016, 12:48 PM   #2
Dstruct
Human being with feelings
 
Dstruct's Avatar
 
Join Date: Jul 2006
Location: Dresden, Germany
Posts: 12,112
Default

Mmh, maybe try with disabled "Tiny fade in on playback start" (Preferences/Audio).

Not sure if that's the culprit (because you're getting higher volume).
Dstruct is offline   Reply With Quote
Old 03-22-2016, 01:38 PM   #3
MikComposer
Human being with feelings
 
MikComposer's Avatar
 
Join Date: May 2012
Location: Brighton
Posts: 1,779
Default

Same problem here, since v4. I've made a post a while back about it and with example, but can't find it now. Don't know if tuning off small fade in fixed it.
__________________
My Royalty Free Music library
MikComposer is offline   Reply With Quote
Old 03-22-2016, 01:55 PM   #4
Pet
Human being with feelings
 
Pet's Avatar
 
Join Date: Nov 2015
Location: Germany
Posts: 918
Default

Hi,
have you made shure that there are no "hidden" controller events like expression or volume? And if, are they at the right place (before the note on event)?
__________________
If the v5 Default Theme is too bright for you take a gander at my mod of it: Default v5 Dark Theme
Pet is offline   Reply With Quote
Old 11-15-2017, 01:11 AM   #5
ericzang
Human being with feelings
 
ericzang's Avatar
 
Join Date: Mar 2014
Location: Phoenix, AZ
Posts: 288
Default

REAPER 5.62 x64
Win7 x64

I have the exact same problem. Using Kontakt 5.6.8. It appears not to be a midi issue. I have used midi monitors before, after, and inside of Kontakt to look for unintended messages. I have tried changing every relevant or slight related setting I could recognize within Reaper and Kontakt. It is not due to velocity or CC.

It is related to audio, and I also found it to be time dependent, just as described above. If I trigger a sound (whether by midi, or with Kontakt's internal keyboard) before my first recorded midi note is played, then the recorded note will be the intended volume (as long as it is .5-1 second before). If I trigger an empty key in kontakt in the same way, the recorded note is about 6db louder than it should.

Thanks for any help!
ericzang is offline   Reply With Quote
Old 11-15-2017, 01:50 AM   #6
ericzang
Human being with feelings
 
ericzang's Avatar
 
Join Date: Mar 2014
Location: Phoenix, AZ
Posts: 288
Default

I can get proper volume behavior when a sounding note is placed prior to the intended first note, and yet have the track's volume envelope set to silence during this prior note.
ericzang is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 08:51 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.