Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER General Discussion Forum

Reply
 
Thread Tools Display Modes
Old 10-15-2019, 06:43 AM   #1
Colox
Human being with feelings
 
Join Date: Feb 2012
Location: The land of meatballs and blondes
Posts: 973
Default Help. Reaper keeps selecting other tracks, can't make it stop

My Reaper keeps changing the active channel, to another channel than I want.

It constantly jumps three tracks below the one I'm currently got selected. It just will not stop, I can't even record because the track focus will jump three tracks down and continue record my keystrokes there. And I can't play my piano keyboard for the same reason. Have to change back to the formerly selected one, all the time.

I don't know what makes it do this and I could use some help in trouble solving it. It has just started happening, I don't remember it happening in Reaper before and I have not connected any new hardware to my workstation recently.

The track focus jumps three tracks down mostly when I'm playing my MIDI keyboard (and using the sustain pedal along with it). But it also jumps when I'm not playing my keyboard, when I'm not touching anything. I am not touching any other controls than my piano keyboard. I've spent a while making sure there are no stuck keys anywhere, or weights weighing down some key or whatever.

I got no macros or shortcuts designed to react off of piano keys, I've just checked all 127 of them including the sustain pedal.

It never jumps upwards, in the opposite direction like three tracks up, it's always three tracks down, no matter what plugin configuration I got loaded on it.

Further, I got this feeling that it may be connected to certain keys on the keyboard, because it mostly seems to flip tracks when I play a certain passage in the song on the keyboard. I'm not talking about 'a passage' as in 'a timeline position on the ruler'. Instead, I'm talking about having Reaper stopped and playing a chord progression passage on my piano keyboard. But it doesn't always flip when I play that passage. It's weird.

Also I don't think it's a Reaper bug, because if so then lots of people would've reacted to this already. But I am on Win10 pro r1903 x64, Reaper 5.984 x64

Could use some help in speculating how to stop this from happening.
Thanks in advance
__________________
There are only two kinds of people in the world: those who entertain, and those who are absurd.
- Britney Spears

Last edited by Colox; 10-15-2019 at 06:48 AM.
Colox is offline   Reply With Quote
Old 10-15-2019, 06:52 AM   #2
WolfJames
Human being with feelings
 
WolfJames's Avatar
 
Join Date: Feb 2009
Location: Nashville, TN
Posts: 196
Default

Desktop or laptop? First off, rule out any mouse problem. Change the USB slot it's plugged into. Wireless? Check the battery. Any other device interfering with the USB receiver? Try another mouse if you have one.

Try changing the mouse settings, like how many lines to scroll at a time. Is it a gaming mouse? Latest driver?

Do you happen to have a touch screen display?

Does the computer have Bluetooth? Turn it off and test.

Also, try a different keyboard, if you have one.

Last edited by WolfJames; 10-15-2019 at 06:53 AM. Reason: Added info
WolfJames is offline   Reply With Quote
Old 10-15-2019, 07:17 AM   #3
Colox
Human being with feelings
 
Join Date: Feb 2012
Location: The land of meatballs and blondes
Posts: 973
Default

Quote:
Originally Posted by WolfJames View Post
Desktop or laptop? First off, rule out any mouse problem. Change the USB slot it's plugged into. Wireless? Check the battery. Any other device interfering with the USB receiver? Try another mouse if you have one.

Try changing the mouse settings, like how many lines to scroll at a time. Is it a gaming mouse? Latest driver?

Do you happen to have a touch screen display?

Does the computer have Bluetooth? Turn it off and test.

Also, try a different keyboard, if you have one.
Thanks for helping.

The mouse huh? I've had this expensive wireless gaming mouse for some time. Never caused problems before, as far as I've noticed.

I'm on a desktop system, no touch screen, no bluetooth. I got the latest mouse driver and its own USB receiver located 5-7 inches right in front of it and the battery is at 80% good (according to own software). I changed how many lines it scrolls from 3 to 2, switched the USB port and rebooted the system.

Then tried Reaper again and it switched tracks just like before within 3 seconds. Damn. :/

I really don't want do use a different mouse, because I am literally mad picky about mice and this is by far the best I've ever used all categories.

By keyboard, do you mean piano type keyboard, or the regular keyboard with letters on it? If you meant the first, then I have none available - not today anyway.
__________________
There are only two kinds of people in the world: those who entertain, and those who are absurd.
- Britney Spears

Last edited by Colox; 10-15-2019 at 07:23 AM.
Colox is offline   Reply With Quote
Old 10-15-2019, 07:32 AM   #4
Colox
Human being with feelings
 
Join Date: Feb 2012
Location: The land of meatballs and blondes
Posts: 973
Default

Hm hold on here. Reaper did switch tracks first thing when I started Reaper up again. But now I've played the keyboard for a few minutes, even recorded some, and ... it hasn't switched tracks again ... so far ...

EDIT: oh, but now it's picking up again. Christ. This is starting to feel like the reasons I left Cubase :P
__________________
There are only two kinds of people in the world: those who entertain, and those who are absurd.
- Britney Spears

Last edited by Colox; 10-15-2019 at 07:39 AM.
Colox is offline   Reply With Quote
Old 10-15-2019, 09:06 AM   #5
cyrano
Human being with feelings
 
cyrano's Avatar
 
Join Date: Jun 2011
Location: Belgium
Posts: 4,610
Default

Sounds like a hardware problem. Try another keyboard and another mouse?
__________________
“It has become appallingly obvious that our technology has exceeded our humanity” Albert Einstein
cyrano is offline   Reply With Quote
Old 10-15-2019, 09:11 AM   #6
serr
Human being with feelings
 
Join Date: Sep 2010
Posts: 8,376
Default

Think it's possible that all the thousands of other Reaper users just put up with this going on all the time for them? Probably not, right?

You either have a failing mouse. Bouncy clicks like that are the most common mouse failure. Or you have some prankster app installed on your machine that's sending mouse moves/clicks.

Unplug the stupid thing and plug in a different one and test it. Just do it!
serr is offline   Reply With Quote
Old 10-15-2019, 09:51 PM   #7
technogremlin
Human being with feelings
 
technogremlin's Avatar
 
Join Date: Mar 2008
Location: Netherlands
Posts: 2,606
Default

Also put your computer keyboard upside down, give it a few gentle pads and see what falls out.
technogremlin is offline   Reply With Quote
Old 10-17-2019, 02:13 PM   #8
WolfJames
Human being with feelings
 
WolfJames's Avatar
 
Join Date: Feb 2009
Location: Nashville, TN
Posts: 196
Default

Yeah, you've got to switch the mouse out just test and rule it out. Then the keyboard if that doesn't work. The computer keyboard that you type on, not the piano keyboard. :-)

You said that you use a gaming mouse (I do too), is it possible Windows updated or changed the driver or settings during a Windows update?
WolfJames is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 01:19 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.