Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER for macOS X

Thread Tools Display Modes
Old 07-11-2018, 10:28 AM   #1
Human being with feelings
Join Date: Jul 2018
Posts: 3
Default Audio output issues - Reaper 4.78 32bit, OS X 10.6, Behringer UMC404HD

I just fall in love with the Repaer when I saw one of my friend using it.
I decided to quit Ableton permanently and start using reaper with its features and user friendly interface. I want to use it only for simple home recording.
As recording music doesn't require much of CPU, RAM and anything else that 4K, UHD and all video stuff needs now, I took my old macbook pro A1151 (Intel Core Duo 2,16Ghz, 2GB RAM). System is 10.6. I cleaned the system and the only program that I have installed right now is the Reaper v4.78 32-bit, and google chrome (old version).
Audio interface that I use is Behringer U-Phoria UMC404HD, and this may be the biggest problem.

So here's the problem:
When I start project everything works fine but after very short period of time (few minutes, or few "play" clicks), audio start to click, distort, freezes and just sounds awful. This happens without any effects. Adding effects makes problem appear instantly (much faster than without effects). When I open old projects with let's say 20 tracks it becomes unlistenable. It goes slow motion and there is more gaps than sounds.
For example I open new project and record first 2 tracks (vocal and guitar) and then I try to record next tracks (trying not to think about clicks), track are way out of sync.
Wav file rendered offline sounds the same.

What I tried already and did not work:
I tried switching disk to faster one (I even tried fast CF card),
I tried changing block size (requesting either big and small),
I tried requesting sample rate (from 192000 to 44100),
I tried changing project sample rate (to 44100),
I tried changing Playback resample mode (to Low),
I tried to change render resample mode,
I tried changing bit depth in project from 24 to 16 bit,
I tried changing from WAV to AIFF,
I tried changing track mixing bit depth (from 32 bit float to 16 bit integer),
I tried changing output sample rate in system midi audio settings from native 192000 to 44100.

So far the best solution is unplugging audio interface and using just build in audio. It's not perfect though, there are still some clicks and drops but I can listen to 20 tracks old project.

Do you guys know what is causing the problem?
I think there are some issues with drivers and audio interface but there are no alternative drivers, just Mac's CoreAudio. Maybe there's a way to put CoreAudio drivers from newer system? I bet they must have changed something since OS X 10.6

As attachment I give you the simple one track recording which is exported as offline but it still sounds the same in project.

I've been trying to find the answer on the forum but there are so many threads that I just don't where to look for it.
fanatic606 is offline   Reply With Quote
Old 07-11-2018, 11:41 AM   #2
Human being with feelings
Join Date: Jul 2018
Posts: 3

I did 2 more things.
1. I installed Ableton and the same problem occurs. The difference is that Ableton works perfectly on buit-in output. No dropouts and sound is pretty good.

2. I found this video on youtube but it proves that problem is with behringher not with Reaper
The only problem left is that the UMC404HD doesn't have this option which that guy found out to be working (switching internal clock to some "usb-sof")
fanatic606 is offline   Reply With Quote
Old 07-11-2018, 03:29 PM   #3
Human being with feelings
cyrano's Avatar
Join Date: Jun 2011
Location: Belgium
Posts: 3,409

I'd start with a clean install of Snow Leopard...

You said you" cleaned" it. I hope you didn't refer to MacKeeper or such. Many Mac users consider that on the edge of malware.
“It has become appallingly obvious that our technology has exceeded our humanity” Albert Einstein
cyrano is online now   Reply With Quote
Old 07-12-2018, 04:57 AM   #4
Human being with feelings
Join Date: Jul 2018
Posts: 3

I formatted it and put new system on empty disk.
The problem exist on other computers and systems too.
fanatic606 is offline   Reply With Quote
Old 07-12-2018, 09:35 AM   #5
Human being with feelings
Join Date: Sep 2010
Posts: 7,573

You didn't mention what kind of hard drive you installed. If it's the original 5400rpm HDD that came with the machine, it's very likely the bottleneck. In that case, install a SSD and let that machine actually perform to its potential.

The issue could be with the B-word interface. Make sure you have the correct driver installed for the version of OSX.

On changing the block size and sample rate:
Doing anything that converts the sample rate on the fly is a CPU hog! The best performance is always running at the same sample rate as the audio you are working with. No exceptions!

Block size is your latency control. Only set this low if you are actually doing live sound or live performance. If you are recording or mixing only, set this large (eg. 1024 samples).

Maybe the B-word interface needs to have sample rate and block size controlled from a 3rd party control panel app? First choice is to control this from Reaper Preferences/Audio/Device page. To control this from a 3rd party app, untick the boxes in Reaper Preferences/Audio/Device next to sample rate and block size to disable Reaper from controlling these and then go to the 3rd party app in question. Reaper lets you do this just for such stubborn interfaces.

Either wav or aiff will be native to Reaper and give the best performance. Degrading 24 bit to 16 bit should not be required and sure wouldn't be wanted.
serr is online now   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT -7. The time now is 01:05 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.