COCKOS
CONFEDERATED FORUMS
Cockos : REAPER : NINJAM : Forums
Forum Home : Register : FAQ : Members List : Search :
Old 09-18-2018, 07:29 AM   #1
Dizzee
Human being with feelings
 
Join Date: Aug 2018
Posts: 12
Default Starting SWS GUI config

Hello,

I am trying to change the GUI of the Notes in the SWS extensions but i'm struggling to start as i have never used XCode or haven't programmed in a while. I do know how to read the code. Can anyone suggest me where can i start please? When i used to work with visual studio i remember i had the design view and then the code behind. I am struggling a bit on finding the same design view on XCode.

Thank you
Dizzee is offline   Reply With Quote
Old 09-18-2018, 08:00 AM   #2
Xenakios
Human being with feelings
 
Xenakios's Avatar
 
Join Date: Feb 2007
Location: Oulu, Finland
Posts: 7,344
Default

As far as I know, you won't be able to do it visually in XCode. (You could maybe attempt to edit the .rc files manually in a text editor, though.)

The GUI resources for Reaper and Reaper extensions are supposed to be done on Windows in Visual Studio, and for OS-X they are translated from the Microsoft resource files into C++ code with the PHP script (mac_resgen.php) that is included in the WDL/SWELL source tree.
__________________
For info on SWS Reaper extension plugin (including Xenakios' previous extension/actions) :
http://www.sws-extension.org/
https://github.com/Jeff0S/sws
--
Xenakios blog (about HourGlass, Paul(X)Stretch and λ) :
http://xenakios.wordpress.com/
Xenakios is online now   Reply With Quote
Old 09-18-2018, 08:41 AM   #3
Dizzee
Human being with feelings
 
Join Date: Aug 2018
Posts: 12
Default

Quote:
Originally Posted by Xenakios View Post
(You could maybe attempt to edit the .rc files manually in a text editor, though.)
The issue is that i want to add icons on the notes window that link back to actions on reaper main window. It would be a bit hard to position them just through the code no? visually i could just place them and in the back code link them
Dizzee is offline   Reply With Quote
Old 10-10-2018, 07:50 AM   #4
Dizzee
Human being with feelings
 
Join Date: Aug 2018
Posts: 12
Default

I am having another issue that is, my extensions project is not identifiyng the WDL library. i have followed the https://github.com/reaper-oss/sws/wi...-SWS-Extension with spliting it into two different folders but when i open the project inside the sws folder, i can't reference the library. Can anyone help me please?
Dizzee is offline   Reply With Quote
Old 10-10-2018, 08:10 AM   #5
cfillion
Human being with feelings
 
cfillion's Avatar
 
Join Date: May 2015
Location: Québec, Canada
Posts: 2,198
Default

You need to have both the WDL and sws repositories cloned in the same parent directory (as described under the "File structure notes" section in the wiki page you linked). You should find a WDL subfolder in the WDL folder.

Last edited by cfillion; 10-10-2018 at 08:15 AM.
cfillion is offline   Reply With Quote
Old 10-10-2018, 08:15 AM   #6
Dizzee
Human being with feelings
 
Join Date: Aug 2018
Posts: 12
Default

Quote:
Originally Posted by cfillion View Post
You need to have both the WDL and sws repositories cloned in the same directory (as described under the "File structure notes" section in the wiki page you linked). You should have a WDL subfolder in the WDL folder.
What i have atm is a folder with two folders inside. One called sws with all the sws files and then another named WDL with the WDL library. To start it, i am opening the folder on VS. After that i don't know what is the next step
Dizzee is offline   Reply With Quote
Old 10-10-2018, 08:20 AM   #7
cfillion
Human being with feelings
 
cfillion's Avatar
 
Join Date: May 2015
Location: Québec, Canada
Posts: 2,198
Default

Your directory structure sounds correct. If I understand correctly, you have opened the .vcxproj project file in Visual Studio (which version?), started the build and it complains it can't find some files from WDL? Please copy/paste the exact error messages.
cfillion is offline   Reply With Quote
Old 10-10-2018, 08:32 AM   #8
Dizzee
Human being with feelings
 
Join Date: Aug 2018
Posts: 12
Default

Your directory structure sounds correct. If I understand correctly, you have opened the .vcxproj project file in Visual Studio (which version?), started the build and it complains it can't find some WDL files? Please copy/paste the exact error messages

I am using the VS2017, the latest. I am getting "Error MSB8020 The build tools for v120 (Platform Toolset = 'v120') cannot be found. To build using the v120 build tools, please install v120 build tools. Alternatively, you may upgrade to the current Visual Studio tools by selecting the Project menu or right-click the solution, and then selecting "Retarget solution"" and many undentified and not allowed
Dizzee is offline   Reply With Quote
Old 10-10-2018, 08:41 AM   #9
cfillion
Human being with feelings
 
cfillion's Avatar
 
Join Date: May 2015
Location: Québec, Canada
Posts: 2,198
Default

This has nothing to do with WDL. You are seeing this message because the project was made for VS2013. Do the "Retarget solution" it suggests.

SWS can be made to build fine with VS2017 (that's what I use too) but be aware WDL's JNetLib needs to be patched for it (otherwise the SWS auto-update feature won't work properly): https://github.com/cfillion/WDL/comm...82ad08d2.patch.

Also the sws repository contains pre-built versions of TagLib (a bad idea in my opinion, but I digress...). You'll either need to go through the trouble of rebuilding it with VS2017 or just add NO_TAGLIB to the pre-processor definitions to disable that feature entirely.
cfillion is offline   Reply With Quote
Old 10-10-2018, 08:51 AM   #10
Dizzee
Human being with feelings
 
Join Date: Aug 2018
Posts: 12
Default

I have done the retarget recomended and i have patched it on the netinc.h file. The rebuilding part i do not understand sorry. Could you explain it please?
Dizzee is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 09:41 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.