Old 02-22-2012, 04:14 PM   #1
nofish
Human being with feelings
 
nofish's Avatar
 
Join Date: Oct 2007
Location: home is where the heart is
Posts: 9,050
Default trying to get OSC parameter feedback with Usine

Warning - total OSC noob !

So I just did my first test with OSC, Reaper and Usine.
Learning and controlling a Reaper parameter from Usine worked instantly with the 'OSC send' modul. Very nice, I imagined the setup to be more difficult than it was.

[img]http://img69.**************/img69/4683/oscsetup1.png[/img]


I'm having trouble though getting the parameter feedback from Reaper back to Usine to work though.
Usine is receiving 'something' (the red arrows in the following pic), but I can't make any sense of it.
And the 'OSC receive' modul in Usine doesn't show any changes.

[img]http://img828.**************/img828/5886/oscfeedb2.png[/img]

Any help ?
nofish is offline   Reply With Quote
Old 02-22-2012, 04:46 PM   #2
Banned
Human being with feelings
 
Banned's Avatar
 
Join Date: Mar 2008
Location: Unwired (probably in the proximity of Amsterdam)
Posts: 4,868
Default

It looks like you need to connect the "data 1" outlet on the on the OSC receive module to the inlet (?) on the left side of the fader. Just a guess, I'm not a Usine user. You're probably getting data alright, you're simply not doing anything with it (like, connecting back for a feedback loop).
__________________
˙lɐd 'ʎɐʍ ƃuoɹʍ ǝɥʇ ǝɔıʌǝp ʇɐɥʇ ƃuıploɥ ǝɹ,noʎ
Banned is offline   Reply With Quote
Old 02-22-2012, 05:18 PM   #3
nofish
Human being with feelings
 
nofish's Avatar
 
Join Date: Oct 2007
Location: home is where the heart is
Posts: 9,050
Default

Thanks for chiming in Banned.

Yes, what you're saying would of course be the logical step.

But thing is, as can be seen in the pics, 'data 1' in the 'OSC receive' modul always stays 0, that's the value that is supposed to change if the feedback would work.
Unless that value doesn't change (ie reflect the parameter change from Reaper) there's no point in connecting it to the fader (actually I've done it nevertheless before the screenshot just to be sure, but, as I had expected, it didn't work).

Any other ideas ?

And another question:

How come those many 'squares' that can be seen in Usine's OSC trace log ?
Is this normal ?

Last edited by nofish; 02-22-2012 at 05:25 PM.
nofish is offline   Reply With Quote
Old 02-23-2012, 04:30 AM   #4
mim
Human being with feelings
 
Join Date: Mar 2009
Posts: 346
Default

1)The squares (# ?) means Reaper is sending bunduled OSC, but from what I experienced either Usine doesn't seems to understand Reaper's bundled message well, either I don't know how to "unbundel" it properly.

You have to put "0" in the Max packet send size in Reaper's OSC setup, to force Reaper to send single message and not bundled messages. No more # then ...

2)Each OSC Receive only receive one value for one adress. In your example the adress of your receive is /usine/, but reaper doesn't send anything there (at least with the default pattern) so your value will be 0. "Data's" output is supposed to be used when receiving bundled osc, but as I state in 1), I'm not sure it's working well ... need to try more deeply though

If you put /focfx/fxparam/3/value in the [addr] field of the receiver then patch data 1 to the input of the fader (left square), your fader will have feedback from the third parameter of the focused fx.

Of course Usine is modular so you can patch everything, and for exemple change the osc send adress on the fly depending of virtually anything.

I'd suggest you to try the OSC pack for usine, it's on the website in the add on section, where you can go even if you are only a Usine free user. Try to change values of the adresses, to make it Reaper work with it. Might take a little time to make it work at first.

Sometime Usine switch off the monitor local host, but it seems still activated in the OSC setup. Uncheck and check it back, and it should work.

By the way, the OSC settings dialog I see in your screenshot means your Usine is not up to date, since no the OSC setup is in the main setup window.
mim is offline   Reply With Quote
Old 02-23-2012, 09:47 AM   #5
nofish
Human being with feelings
 
nofish's Avatar
 
Join Date: Oct 2007
Location: home is where the heart is
Posts: 9,050
Default

Thanks for your reply mim, it helped a lot.
Nice to meet a fellow Reaper/Usine user.

Quote:
Originally Posted by mim View Post
You have to put "0" in the Max packet send size in Reaper's OSC setup, to force Reaper to send single message and not bundled messages. No more # then ...
Ah, got it. Good to know.

Quote:

If you put /focfx/fxparam/3/value in the [addr] field of the receiver then patch data 1 to the input of the fader (left square), your fader will have feedback from the third parameter of the focused fx.
Excellent. That was the part I was missing. Got it working now basically.



Now I'm wondering how can I find out about these messages like '/focfx/fxparam/3/value' ?
My original goal was to get parameter feedback for the volume fader of Reaper track 1. What would I have to put in the [addr] field instead ?
Are these messages listed somewhere ?

But I'm happy I got it basically working now, that's a good start.
Will be experimenting some more.
Thanks again.

Quote:
By the way, the OSC settings dialog I see in your screenshot means your Usine is not up to date, since no the OSC setup is in the main setup window.
Yes, you're right. It's because my gold account ended some time ago and I haven't renewd it yet.
nofish is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 08:38 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.