Go Back   Cockos Incorporated Forums > REAPER Forums > MIDI Hardware, Control Surfaces, and OSC

Reply
 
Thread Tools Display Modes
Old 04-10-2020, 06:23 AM   #1
mjwolf
Human being with feelings
 
Join Date: Jun 2018
Posts: 7
Default Weirdest Kontrol S88 MK1 issue - transport buttons and piano keys have swapped!

Hi everyone - I'm setting up a new PC workstation and have encountered the weirdest issue with my Komplete Kontrol S88 MK1 keyboard. I'm using the latest version of Reaper on a brand new PC with Windows 10 installed.

In preferences I have enabled MIDI input for the option KOMPLETE KONTROL DAW - 1. When I play the piano keys no information is getting to my virtual instruments. However, other kinds of information is getting sent - if I go into "Edit" after playing a chromatic scale down the keyboard, all sorts of actions have taken place, such as markers being added, Changes to track record parameters, Changes to media item selections, and so on.

When I press the transport buttons, however, they are sending note information to the virtual instrument ("Loop" is triggering D6, "RWD" is G6, "FWD" is G#6, "Play" is A#6, "REC" is B6, and "Stop" is A6!).

So, it looks like the function buttons and the keyboard buttons have somehow got swapped around! Have any of you encountered this before and found a solution?

Many thanks.
mjwolf is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 12:50 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.