Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 08-15-2021, 05:08 AM   #1
FeedTheCat
Human being with feelings
 
FeedTheCat's Avatar
 
Join Date: May 2019
Posts: 642
Default Media Explorer toolbar: Can't run custom actions or scripts

Even a simple script like

Code:
reaper.ShowConsoleMsg("I'm a problematic toolbar button :)")
won't run when assigned to a toolbar button in the media explorer toolbar (but runs fine when executed from the action list).

Tested on Linux

Last edited by FeedTheCat; 08-15-2021 at 03:40 PM. Reason: Realized that custom actions don't work as well
FeedTheCat is online now   Reply With Quote
Old 08-15-2021, 03:38 PM   #2
FeedTheCat
Human being with feelings
 
FeedTheCat's Avatar
 
Join Date: May 2019
Posts: 642
Default

Custom actions don't work as well.

Last edited by FeedTheCat; 08-19-2021 at 01:18 PM.
FeedTheCat is online now   Reply With Quote
Old 08-19-2021, 01:19 PM   #3
FeedTheCat
Human being with feelings
 
FeedTheCat's Avatar
 
Join Date: May 2019
Posts: 642
Default

Confirmed on Windows/MacOS.
FeedTheCat is online now   Reply With Quote
Old 08-20-2021, 07:52 AM   #4
Daodan
Human being with feelings
 
Join Date: Jan 2011
Posts: 275
Default

Confirmed on Windows
Daodan is offline   Reply With Quote
Old 09-14-2021, 01:19 PM   #5
ricoinaz
Human being with feelings
 
Join Date: Jul 2021
Location: Arizona USA
Posts: 3
Default Confirmed Here Too!

Custom actions for media explorer via OSC/MIDI all do not work. I would like to use media explorer to play playlists before our show. Works just fine manually from the actions list popup, but you can't trigger any of these events via OSC/MIDI.

This problem is everywhere in Reaper. I posted a similar problem in OSC thread.
ricoinaz is offline   Reply With Quote
Old 09-15-2021, 03:03 AM   #6
FeedTheCat
Human being with feelings
 
FeedTheCat's Avatar
 
Join Date: May 2019
Posts: 642
Default

Quote:
Originally Posted by ricoinaz View Post
Custom actions for media explorer via OSC/MIDI all do not work. I would like to use media explorer to play playlists before our show. Works just fine manually from the actions list popup, but you can't trigger any of these events via OSC/MIDI.

This problem is everywhere in Reaper. I posted a similar problem in OSC thread.
Hmmm, that seems to work over here on Linux. The media explorer needs to have focus but I can make a custom action and trigger it from my MIDI keyboard.
FeedTheCat is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 05:44 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.