COCKOS
CONFEDERATED FORUMS
Cockos : REAPER : NINJAM : Forums
Forum Home : Register : FAQ : Members List : Search :
Old 05-21-2008, 01:40 PM   #1
Stefan-Tiedje
Human being with feelings
 
Join Date: Sep 2006
Posts: 2
Default How to compile Ninjam on Linux

The instruction coming with the Ninjam source for compilation is far from being instructive for people like me, who maybe once a year have to touch the console.

What I did:

I am running a recent (8.04) Ubuntu Linux

I downloaded the sources, checked with Synaptic that all of the metioned packages are installed.

cd into the folder ninjam/cursesclient and as the compiling instruction sugested, typed "make"

I got a g++ cmmand not found error...

ok, I installed g++ (needs to be mentioned)

Then make did something: a long list of warnings (mostly about old style conversion in "char"), and an even longer list of errors (mostly about not defined variables and something not being of Type...)

I'd love to get more complete instructions... Or a binary...

I am not a programmer, programmers talk won't help... ;-)

NinJam is a great tool, I'd love to run it on Linux...

All the best
Stefan-Tiedje is offline   Reply With Quote
Old 10-03-2011, 01:26 AM   #2
MtM
Human being with feelings
 
Join Date: Mar 2011
Location: Greensboro, NC
Posts: 1
Default

bump.

I'm in the exact same situation. Any help would be greatly appreciated.
MtM is offline   Reply With Quote
Old 12-21-2011, 05:42 AM   #3
turion
Human being with feelings
 
Join Date: Jul 2011
Posts: 9
Default

If you're still having problems, have a look if you can compile wahjam (https://wahjam.org)
turion is offline   Reply With Quote
Old 11-19-2018, 07:33 PM   #4
hppy420
Human being with feelings
 
Join Date: May 2012
Location: Portland oregon
Posts: 14
Default

Hey there: I know this comes incredibly long after you posted, so you've probably figured out how to do the compile by now. If not, this is what you may need to do. It worked for me anyhow.
In the /cursesclient directory there is a file called Makefile, note that the m is capitalized.
You mentioned an Ubuntu distro, so:
sudo nano Makefile
and look for the line below else where you'll see some option flags.
The one you'll want to change is
-malign-double
You want to change it to read:
-falign-jumps
Now save the file with control-x and answer y to the prompt, and hit enter.
Now that's saved, so just run as normal user:
make
and it should compile after this provided everything it needs is there.
I had better luck with 32-bit systems, the one system I tried it on which was also an Ubuntu system seemed to require Jack to be installed, that was the one from the ninjam-master Github repo.
I think the one from the Ninjam site worked for me as I recall but the computer didn't play nice with the screen reader and Ninjam so I abandoned it. I suspect that crap on-board sound card.
Hope that helps a little.
Take care.
Cheereo.
hppy420 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 02:40 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.