Old 02-09-2017, 04:10 AM   #1
X-Raym
Human being with feelings
 
X-Raym's Avatar
 
Join Date: Apr 2013
Location: France
Posts: 4,917
Default [SOLVED] Packed Theme and Backgroud Icons

Hi

Background buttons doesn't appear in themes zipped, but only uncompressed.
Here is zip:



Here is uncompressed:


No Background Icon Panel

Quote:
Originally Posted by [URL="http://forum.cockos.com/member.php?u=108122"
Never[/URL]]
This is actually the case with ALL packed themes that contain uncomposited
toolbar icons, in the toolbar customization window, they all show just
the uncomposited icon illustration with no toolbar blank underneath, until they are unpacked,
You can test with my theme, X-Raym Analog.

Thanks!

Last edited by X-Raym; 12-05-2017 at 11:22 PM.
X-Raym is offline   Reply With Quote
Old 12-01-2017, 05:10 AM   #2
jrengmusic
Human being with feelings
 
jrengmusic's Avatar
 
Join Date: Jun 2015
Location: New York
Posts: 402
Default

Confirmed.

This happened not only for toolbar but also for other images.
__________________
JRENG! | M E T R I C
jrengmusic is online now   Reply With Quote
Old 12-01-2017, 09:15 PM   #3
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 11,231
Default

Fixing two bugs here, one is the toolbar-specific one, the other is that zipped themes were limited to 2048 files (perhaps this was your bug, jrengmusic?)
Justin is offline   Reply With Quote
Old 12-02-2017, 07:50 AM   #4
X-Raym
Human being with feelings
 
X-Raym's Avatar
 
Join Date: Apr 2013
Location: France
Posts: 4,917
Default

@Justin
Thanks ! Can't wait to try that
X-Raym is offline   Reply With Quote
Old 12-02-2017, 08:44 AM   #5
Bri1
Human being with feelings
 
Bri1's Avatar
 
Join Date: Dec 2016
Location: England
Posts: 1,689
Default

Quote:
Fixing two bugs here, one is the toolbar-specific one, the other is that zipped themes were limited to 2048 files (perhaps this was your bug, jrengmusic?)
Hey Justin- um- this may,or not be related-- but a while ago was seeing threads about how reaper was really slow to open-- this i found was due to sws extentions-- if user creates a massive database with the sws resources - this is causing severe lag on 1st boots..ok.
Think it's the images there_.
Many thanx for fixings!
Bri1 is offline   Reply With Quote
Old 12-02-2017, 11:07 AM   #6
X-Raym
Human being with feelings
 
X-Raym's Avatar
 
Join Date: Apr 2013
Location: France
Posts: 4,917
Default

@Bri1
Please don't go off topic, thanks !
X-Raym is offline   Reply With Quote
Old 12-02-2017, 12:45 PM   #7
Bri1
Human being with feelings
 
Bri1's Avatar
 
Join Date: Dec 2016
Location: England
Posts: 1,689
Default

Quote:
@Bri1
Please don't go off topic, thanks !
X-Raym-it's on topic-- it's image related- and reaper is the host-- if devs are looking at images etc etc..it makes sense to fix them now does it not?
sws should not be supported if cockos can not fix it--right? or wrong?

I'm feking done with all this people trying to tell me 'what-to-do'.
Am out.
Bri1 is offline   Reply With Quote
Old 12-03-2017, 08:49 AM   #8
jrengmusic
Human being with feelings
 
jrengmusic's Avatar
 
Join Date: Jun 2015
Location: New York
Posts: 402
Default

Quote:
Originally Posted by Justin View Post
Fixing two bugs here, one is the toolbar-specific one, the other is that zipped themes were limited to 2048 files (perhaps this was your bug, jrengmusic?)
Justin, i developed theme which contain less than 2048 files. But some images (not only toolbars), was still unreadable. It was fine when unpacked.

I have tried several tests with folder naming and compression method, the only workaround which work so far is not using OSX built in compressor for zipping. I manage to get it work using Keka which basically 7-zip port on OSX. But it only works when i compress the *.ReaperTheme and ui_images folder by dragging to the app.

Even using Keka, REAPER failed to read the toolbar and some of other images from the *.ReaperThemeZip if i compressed it via context menu on Finder.
__________________
JRENG! | M E T R I C
jrengmusic is online now   Reply With Quote
Old 12-03-2017, 09:01 AM   #9
jrengmusic
Human being with feelings
 
jrengmusic's Avatar
 
Join Date: Jun 2015
Location: New York
Posts: 402
Default

I'm on OSX High Sierra 10.13.1. Tested on REAPER 5.65pre16/64.

Theme zipped via Finder context menu.

It was missing toolbar, scrollbar, tcp_bgsel, some transport buttons, mcp knob_stack, etc.


Theme zipped using Keka, dragging *.ReaperTheme & ui_images folder to Keka apps.

Looks fine, exactly the way it suppose to be when unpacked.

The theme only contain 1130 files.
__________________
JRENG! | M E T R I C
jrengmusic is online now   Reply With Quote
Old 12-05-2017, 07:06 PM   #10
jrengmusic
Human being with feelings
 
jrengmusic's Avatar
 
Join Date: Jun 2015
Location: New York
Posts: 402
Default

Fixed on 5.65rc3.

JREEEENNNNGG!
__________________
JRENG! | M E T R I C
jrengmusic is online now   Reply With Quote
Old 12-05-2017, 11:20 PM   #11
X-Raym
Human being with feelings
 
X-Raym's Avatar
 
Join Date: Apr 2013
Location: France
Posts: 4,917
Default

My toolbar buttons are fixed for me too Solved !
X-Raym is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 03:17 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.