Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 08-09-2013, 12:27 PM   #1
Tale
Human being with feelings
 
Tale's Avatar
 
Join Date: Jul 2008
Location: The Netherlands
Posts: 2,939
Default Glitches when recording square automation envelope

When I record a linear automation envelope everything is fine, but when I record a square automation envelope I get glitches:



Steps to reproduce:

1. Add a VST to a track, e.g. ReaPitch.
2. Set track automation mode to write.
3. Select a on/off type plug-in parameter (e.g. the Enabled parameter of ReaPitch).
4. Set the default envelope shape to square.
5. Start playback.
6. Switch the parameter on/off in the plug-in GUI to record the parameter changes.

The glitches don't appear when I set the envelope shape to e.g. linear. They happen not only for on/off style parameters, but also for "range" style parameters (e.g. knobs or sliders), but only when the value changes suddenly (e.g. when you reset the value).

I have used ReaPitch as an example here, but this also happens with other (third party) plug-ins.
Tale is offline   Reply With Quote
Old 09-01-2013, 03:59 AM   #2
Tale
Human being with feelings
 
Tale's Avatar
 
Join Date: Jul 2008
Location: The Netherlands
Posts: 2,939
Default

*bump* Can anyone confirm?
Tale is offline   Reply With Quote
Old 09-10-2013, 04:38 AM   #3
Tale
Human being with feelings
 
Tale's Avatar
 
Join Date: Jul 2008
Location: The Netherlands
Posts: 2,939
Default

I just noticed that are considerably less (almost no) glitches when I record-arm the track disable anticipative FX processing.

Anyhow, I guess I should just stop using square envelopes, and just use linear envelopes instead...
Tale is offline   Reply With Quote
Old 10-05-2013, 06:32 AM   #4
Tale
Human being with feelings
 
Tale's Avatar
 
Join Date: Jul 2008
Location: The Netherlands
Posts: 2,939
Default

FYI: This bug has been fixed in v4.53. I still get the occasional glitch, but not anymore like in the LICEcap in OP.
Tale is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 02:19 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.