Old 12-13-2008, 10:02 AM   #1
nofish
Human being with feelings
 
nofish's Avatar
 
Join Date: Oct 2007
Location: home is where the heart is
Posts: 8,846
Default release of Asio driver not immediately

This is bugging me a little for quite some time now:

I have 'close audio device when stopped and application is inactive' checked in options but when I minimise Reaper to system tray it still locks the Asio driver, so I can't use another Audio app.

I get around this by clicking the Hz/Bit/latency display in the right corner (close audio device) and then quickly minimise Reaper to system tray before the pref's window appeares, but this is quirky. (edit: And doesn't seem to work anymore in the latest beta).
Also I have experienced that the Asio driver sometimes isn't released when opening an Audio clip with an external editor.

Anybody else experiencing this?
Shouldn't the Asio driver be released immediately when Reaper is minimised to tray or in the background?

Last edited by nofish; 12-13-2008 at 10:09 AM.
nofish is offline   Reply With Quote
Old 12-13-2008, 10:21 AM   #2
MichaJo
Human being with feelings
 
MichaJo's Avatar
 
Join Date: Oct 2008
Location: Germany
Posts: 1,767
Default

I don't have this problem.
Windows XP SP3, EMU 0404.
Immediately when changing to another application i can see the "OFFLINE" text at the audio items in Reaper.
I'm using ProteuxVX as standalone or Wavosaur for example. Both with the EMU ASIO driver.

Michael
MichaJo is offline   Reply With Quote
Old 12-13-2008, 10:37 AM   #3
nofish
Human being with feelings
 
nofish's Avatar
 
Join Date: Oct 2007
Location: home is where the heart is
Posts: 8,846
Default

Interesting.
Is ASIO always released when you minimise to tray?
Here it's always active.
nofish is offline   Reply With Quote
Old 12-13-2008, 05:43 PM   #4
LOSER
Human being with feelings
 
Join Date: May 2006
Posts: 2,373
Default

You got monitoring enabled? Because this will keep the driver loaded in REAPER. The other option "Close audio device when minimized and tracks are armed" may cure that.
Also "Close audio device when active" might be a good try as well to see if it does any better (as in closing the device faster/earlier/at all).
I didn't have any problems (the few times I minimized and needed the driver in another application anyway), so maybe this is also driver (that is soundcard) related, maybe the driver doesn't close that fast or hangs or something.
LOSER is offline   Reply With Quote
Old 06-13-2009, 01:16 AM   #5
c1isc1
Human being with feelings
 
Join Date: Jul 2006
Posts: 23
Default

I have also noticed this behavior. It's only when minimizing REAPER that the audio device fails to be released here. Switching directly to another application releases the device as expected.
c1isc1 is offline   Reply With Quote
Old 06-14-2009, 07:11 AM   #6
nofish
Human being with feelings
 
nofish's Avatar
 
Join Date: Oct 2007
Location: home is where the heart is
Posts: 8,846
Default

Quote:
Originally Posted by c1isc1 View Post
I have also noticed this behavior. It's only when minimizing REAPER that the audio device fails to be released here. Switching directly to another application releases the device as expected.
Exactly !
That's what I'm talking about, thanks.
Still bugging me...

Coming from Cubendo where it works like it should (minimizing releases Asio driver immediately), I'm so used to minimizing before switching to another Audio app that I go "D'oh" several times a day.

Please fix this.
nofish is offline   Reply With Quote
Old 06-14-2009, 09:51 AM   #7
SiKo
Human being with feelings
 
SiKo's Avatar
 
Join Date: Aug 2008
Location: dusty hot place
Posts: 1,492
Default

Quote:
Originally Posted by c1isc1 View Post
I have also noticed this behavior. It's only when minimizing REAPER that the audio device fails to be released here. Switching directly to another application releases the device as expected.
I got Reaper x64 to crash on minimizing/restoring several times via the taskbar (crash was in audio driver, in my case the emu0404 pci driver).

I started doing this after I found that sometimes reaper didnt respond to a minimize 'click' on the icon in the taskbar.

Weird behavior.
__________________
... yOu aNd mE are ...
SiKo is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 08:38 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.