Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 12-04-2019, 06:33 PM   #1
Dhekke
Human being with feelings
 
Join Date: Mar 2015
Posts: 5
Default [6.0/64] HiDPI rendering issues when mixer is too tall (FIXED)

Looks like some textures end up where they shouldn't be when you hover over a track, after the mixer is past a certain "height" - not sure the exact number. This happens only in HiDPI themes I tried (Commala Retina Mod, Default 5.0 and Default 6.0) and has been going on for at least 18 months, so it's not specific to 6.0.

It never really bugged me, as I just reverted back to the regular DPI themes, but 6.0 looks sooo nice in HiDPI and I want to enjoy that very much.

iMac (Retina 4K, 21.5-inch, 2017)

OS: macOS Mojave 10.14.16 (but also happened on High Sierra)
REAPER: 5 and 6, 64-bits

Steps to Reproduce
  • Open mixer window
  • Make it as tall as possible on a HiDPI display
  • Hover mouse over arm/monitoring/input buttons

Expected Result
Nice graphical highlight

Actual Result
Textures end up in weird places


Last edited by Dhekke; 12-06-2019 at 06:13 PM.
Dhekke is offline   Reply With Quote
Old 12-04-2019, 06:59 PM   #2
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 12,632
Default

Odd! Does it do it in 5.99 or did you mean +devXYZ?

If you disable Metal support in preferences/general/advanced and restart REAPER does that fix?

I can't duplicate here but I don't have that large of a display. I'll stop by the Apple store tomorrow... (to test, not to buy one)
Justin is offline   Reply With Quote
Old 12-04-2019, 07:31 PM   #3
Dhekke
Human being with feelings
 
Join Date: Mar 2015
Posts: 5
Default

Quote:
Originally Posted by Justin View Post
Odd! Does it do it in 5.99 or did you mean +devXYZ?

If you disable Metal support in preferences/general/advanced and restart REAPER does that fix?

I can't duplicate here but I don't have that large of a display. I'll stop by the Apple store tomorrow... (to test, not to buy one)
I'm sorry I can't be very precise, but I'm sure it's been happening at least since REAPER v5.941 (That's when I moved to a new apartment, and I know the bug is older than that.

After testing, the issue still happens with both "Force classic" and "Disable all optimized drawing".
It also happens with any of the layout options for mixer tracks, on all themes.

I just tested re-scaling the display and no changes there, also.

Even if you don't buy it, going to an Apple store just to test a bug is still amazing commitment.
Dhekke is offline   Reply With Quote
Old 12-04-2019, 09:31 PM   #4
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 12,632
Default

Quote:
Originally Posted by Dhekke View Post
Even if you don't buy it, going to an Apple store just to test a bug is still amazing commitment.
The good part about living in a place like NYC is that you can stop by places like that on a bicycle and it only takes a few minutes
Justin is offline   Reply With Quote
Old 12-05-2019, 01:12 PM   #5
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 12,632
Default

Duplicated, thanks! And fixing (hopefully)
Justin is offline   Reply With Quote
Old 12-05-2019, 07:05 PM   #6
Dhekke
Human being with feelings
 
Join Date: Mar 2015
Posts: 5
Default

Awesome! I'm glad the information helped.

Hope the Apple store people don't get too angry at you downloading all the dev tools and sitting at the iMac for like 6 hours trying to debug and fix it.

Thanks!
Dhekke is offline   Reply With Quote
Old 12-06-2019, 06:13 PM   #7
Dhekke
Human being with feelings
 
Join Date: Mar 2015
Posts: 5
Default

Gone after 6.01.

Thanks!
Dhekke is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 09:02 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.