Old 08-15-2016, 04:49 AM   #1
brynolf
Human being with feelings
 
Join Date: Jan 2015
Posts: 157
Default Render level meter differs slightly

Hi! (This is not really another "my renders are too quiet" thread)

The master level meter in my mixer is at -0.1 peak. But the level meter in the Render window shows max -0.2, which I find a bit wierd. You'd think the meters would be in exact agreement... Anyone knows what could be up here?
brynolf is offline   Reply With Quote
Old 08-15-2016, 05:06 AM   #2
OPI
Human being with feelings
 
OPI's Avatar
 
Join Date: Nov 2014
Posts: 1,884
Default

Hm.. Thats such a small amount though. Do you have lots of time based effects? Synths? Live fx can vary in sound. Unless everything is rendered out the way you want, there will be slight differences due to the randomness Of (especially time based) fx. Unless they were designed to playback exactly the same each time, they won't. Some synths won't play back exactly the same each time either. Something to do with the oscillator starting position.
OPI is offline   Reply With Quote
Old 08-15-2016, 05:24 AM   #3
brynolf
Human being with feelings
 
Join Date: Jan 2015
Posts: 157
Default

Sure, I have lots of plugins which probably could randomize things a bit. But the mixer never ever shows anything but -0.1 after a complete playthrough and the render meter always shows -0.2. And I have noticed it on several different projects, using different master limiters etc. So I don't think the plugins are the culprits.

It's a really small difference, yes. So I'm not really troubled by it. It's more of a curiosity.
brynolf is offline   Reply With Quote
Old 08-15-2016, 07:22 AM   #4
Judders
Human being with feelings
 
Join Date: Aug 2014
Posts: 10,138
Default

Have you checked the level of the actual rendered file? It could just be a different rounding method for the rendering window.

I mean, if you've got a mono file panned hard right it doesn't show anything at all in the meters! So I wouldn't trust them
Judders is offline   Reply With Quote
Old 08-15-2016, 12:33 PM   #5
brynolf
Human being with feelings
 
Join Date: Jan 2015
Posts: 157
Default

Quote:
Originally Posted by Judders View Post
Have you checked the level of the actual rendered file? It could just be a different rounding method for the rendering window.

I mean, if you've got a mono file panned hard right it doesn't show anything at all in the meters! So I wouldn't trust them
Yes, when I import the rendered wav into an empty project, the levels are still peaking at -0.1

Although when I mini-nudge the master fader a wee smidgerino the master and render meters show the same value. So yes, it might just be different rounding methods. But if that's what's cooking, you really want to ask WHY, don't you? What reason could there be to round the values differently?
brynolf is offline   Reply With Quote
Old 08-15-2016, 03:08 PM   #6
EpicSounds
Human being with feelings
 
EpicSounds's Avatar
 
Join Date: Jul 2009
Posts: 6,102
Default

-0.1 or -0.2 is still "wrong" and will clip after any format conversion like wav to mp3 and when played through a streaming service.
__________________
REAPER Video Tutorials, Tips & Tricks and more at The REAPER Blog
EpicSounds is offline   Reply With Quote
Old 08-15-2016, 04:35 PM   #7
Judders
Human being with feelings
 
Join Date: Aug 2014
Posts: 10,138
Default

Quote:
Originally Posted by brynolf View Post
Yes, when I import the rendered wav into an empty project, the levels are still peaking at -0.1

Although when I mini-nudge the master fader a wee smidgerino the master and render meters show the same value. So yes, it might just be different rounding methods. But if that's what's cooking, you really want to ask WHY, don't you? What reason could there be to round the values differently?
I suspect that's a question only the devs can answer.
Judders is offline   Reply With Quote
Old 08-16-2016, 03:41 AM   #8
brynolf
Human being with feelings
 
Join Date: Jan 2015
Posts: 157
Default

Quote:
Originally Posted by EpicSounds View Post
-0.1 or -0.2 is still "wrong" and will clip after any format conversion like wav to mp3 and when played through a streaming service.
Well whaddyaknow, you learn something everyday. Thanks!
brynolf is offline   Reply With Quote
Old 08-16-2016, 09:42 AM   #9
EpicSounds
Human being with feelings
 
EpicSounds's Avatar
 
Join Date: Jul 2009
Posts: 6,102
Default

setting limiter ceiling to -1 is best practice these days.
__________________
REAPER Video Tutorials, Tips & Tricks and more at The REAPER Blog
EpicSounds is offline   Reply With Quote
Old 08-17-2016, 06:19 AM   #10
brynolf
Human being with feelings
 
Join Date: Jan 2015
Posts: 157
Default

Quote:
Originally Posted by EpicSounds View Post
setting limiter ceiling to -1 is best practice these days.
The rendered mp3 imported back into Reaper peaks peaks at +0.4. As I understand it, the conversions are difficult to anticipate so I'd say -1.0 is a good round number to set the limiter at, just to get a little wiggle room.

Interesting OOT aside, if anyone has a clue regarding the original question, I consist entirelly of ears.
brynolf is offline   Reply With Quote
Old 01-05-2018, 01:16 AM   #11
jazznfunk
Human being with feelings
 
Join Date: Aug 2012
Location: Riga Latvia
Posts: 112
Default

Lossy formats can (and do) "distort" waveform. Especially on low bitrates. You can check Yourself easy - squash audio with some good brickwall limiter (like Waves L2) with some -3 dBFS margin (for easy seeing), render lossless and many lossy formats, then make new project and compare waveforms of files.

+1 for rendering @ -1 dBFS.

P.S. This is important when doing CD ripping (oh, that's probably part of history) or lossless to lossy encoding Your "digibuy" to some portable device. "Mind the gap!" of -1 dB in Your favorite music player converter DSP setting when doing that. I recomend foobar2000. But, of course, Reaper's Batch converter is mighty also.

Last edited by jazznfunk; 01-05-2018 at 01:18 AM. Reason: typo
jazznfunk is offline   Reply With Quote
Old 09-23-2019, 05:42 AM   #12
brynolf
Human being with feelings
 
Join Date: Jan 2015
Posts: 157
Default

Oi, after three years I found the answer. I have always had a "js master limiter" last on my master bus. This was the culprit. Time to get a "real" limiter...
brynolf is offline   Reply With Quote
Old 12-29-2020, 10:57 AM   #13
brynolf
Human being with feelings
 
Join Date: Jan 2015
Posts: 157
Default

Hm, since last post I have had a Waves L2 limiter on the master bus, and the peak numbers always add up. Yesterday I bought the Fabfilter Pro-L2 though, and the numbers are off again. The limiter clearly says "-1.0" but the master track's meter says "-1.1".


Edit: It's related to True peak. If I turn that off, the numbers are in sync but with True peak on, Reaper thinks it's -1.1 while Fab says -1.0.

Last edited by brynolf; 12-29-2020 at 11:31 AM.
brynolf is offline   Reply With Quote
Old 12-29-2020, 11:57 AM   #14
karbomusic
Human being with feelings
 
karbomusic's Avatar
 
Join Date: May 2009
Posts: 27,334
Default

Quote:
Originally Posted by brynolf View Post
Edit: It's related to True peak. If I turn that off, the numbers are in sync but with True peak on, Reaper thinks it's -1.1 while Fab says -1.0.
Sounds likely since true peak is a bit of a guess of what might happen in analog playback via intersample peaks.

Unrelated to Reaper and as someone else noted, living in that only .1 dB away from 0 dBFS world causes more anomalies and concerns than anything it solves. Give it some more wiggle room like .5 or more, and/or just live with the occasional peak that may never be heard in the final result anyway.
__________________
Music is what feelings sound like.
karbomusic is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 08:43 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.