Old 05-14-2020, 02:29 PM   #1
XilburQost
Human being with feelings
 
XilburQost's Avatar
 
Join Date: Apr 2019
Location: Chicago
Posts: 50
Default MIDI notes will not align to track grid; how to fix?

I'm working on a project using REAPER v6.10 under Windows 10. The problem is that somehow the MIDI notes that I've manually added are no longer aligning to the grid.

I have the snap setting at 1/4 notes, but the notes are not snapping to the 1/4 position on the grid, rather they are consistently offset by a small amount (64th?) to the right.

UPDATE: I think I found the solution: In the MIDI editor, select the option View > Piano Roll Timebase, and select Source Beats.

Thanks.

Last edited by XilburQost; 05-14-2020 at 03:09 PM.
XilburQost is offline   Reply With Quote
Old 05-14-2020, 05:27 PM   #2
xpander
Human being with feelings
 
xpander's Avatar
 
Join Date: Jun 2007
Location: Terra incognita
Posts: 6,021
Default

Quote:
Originally Posted by XilburQost View Post
UPDATE: I think I found the solution: In the MIDI editor, select the option View > Piano Roll Timebase, and select Source Beats.
I wouldn't recommend that as a fix to snap problems. That timebase has limitations which might bite you later, especially if you forget that setting.

I would rather change the MIDI editor mouse modifiers to better suit the snapping. Check the context for the note insert method you are using and change the default to snapping action, or use the modifiers which already have snapping in there.

As an example, if you use left drag to draw the notes, the default action in MIDI piano roll left drag context is Insert note, drag to extend or change pitch. That will snap to grid, but if you also have Ignoring snap selected in there, that's what happens.
xpander is online now   Reply With Quote
Old 05-14-2020, 06:35 PM   #3
XilburQost
Human being with feelings
 
XilburQost's Avatar
 
Join Date: Apr 2019
Location: Chicago
Posts: 50
Default

Thanks xpander. I've been using REAPER for about two years and this is the first time I've seen this issue.

In this project I initially laid down some guitar audio tracks, playing along with the metronome, then began adding MIDI tracks. I was slicing up the MIDI tracks into individual measures and copy-pasting them. Somewhere along the way I began to notice the MIDI notes weren't aligning to the track grid, even though quarter note snapping had been enabled all along. Still not sure why notes started being misaligned by such a small, but noticeable amount.

My experience is that configuring note snapping in REAPER is tricky and confusing. The primary reason I use gross snapping is so I can move blocks of MIDI code around without having to worry about small miss-alignments. Again, seems there's a whole angle to this I'm not understanding.

Last edited by XilburQost; 05-14-2020 at 06:43 PM.
XilburQost is offline   Reply With Quote
Old 05-14-2020, 07:19 PM   #4
Goldreap
Human being with feelings
 
Join Date: Feb 2009
Location: UK
Posts: 1,315
Default

Are the offsets actually much smaller than 64ths? If so, I have a feeling the following might explain it.

The source grid for MIDI is measured in MIDI ticks and starts from where the item was first created which was probably not snapped to the project grid.

By setting timebase to source beats you're just changing your view, not the actual timing of the notes.
To avoid all this I always create a MIDI item snapped to grid before entering or recording any notes into it.

Mind you, the offsets are so small they don't really matter (you can't hear it), but yes, it's disconcerting seeing it when you zoom in.

See this thread::
https://forum.cockos.com/showthread....ght=MIDI+ticks

Last edited by Goldreap; 05-15-2020 at 09:59 AM.
Goldreap is offline   Reply With Quote
Old 05-15-2020, 07:18 AM   #5
XilburQost
Human being with feelings
 
XilburQost's Avatar
 
Join Date: Apr 2019
Location: Chicago
Posts: 50
Default

Thank you Goldreap for your reply and link. Attached is a screenshot of the misalignment I'm seeing. The vertical magenta lines are 64ths. I could hear the misalignment (which is what alerted me to the problem), but that may be because I'm layering MIDI piano over acoustic guitar finger-picking.

I'll take a look at your suggestions. Thanks again.
Attached Images
File Type: jpg reaper_note_misalignment.jpg (58.9 KB, 16 views)
XilburQost is offline   Reply With Quote
Old 05-15-2020, 10:11 AM   #6
Goldreap
Human being with feelings
 
Join Date: Feb 2009
Location: UK
Posts: 1,315
Default

Hmm, your offset seems to be about a quarter of a 64th note which is still much larger than the tick offset I was talking about. So maybe it's not what I was suggesting.
Out of interest could you check how far your item start is off the grid? Is it the same as the notes offset?
Goldreap is offline   Reply With Quote
Old 05-15-2020, 02:08 PM   #7
XilburQost
Human being with feelings
 
XilburQost's Avatar
 
Join Date: Apr 2019
Location: Chicago
Posts: 50
Default

Quote:
Originally Posted by Goldreap View Post
Hmm, your offset seems to be about a quarter of a 64th note which is still much larger than the tick offset I was talking about. So maybe it's not what I was suggesting.
Out of interest could you check how far your item start is off the grid? Is it the same as the notes offset?
I want to say that item starts were offset at some point, but poking around older versions of the file hasn't yielded any concrete examples.

This may be magical thinking, but at the beginning of the project I laid down guitar audio tracks. The guitar starts on the first down beat, and initially I had the guitar audio item start trimmed to the 1. I then dragged the guitar audio item start slightly left (by a dotted 32nd) of the 1, opening it up so you could hear the slight string attack that precedes the 1. So maybe when I added my first MIDI track item I aligned its start to the offset guitar audio start, and that started the misalignment?

Again, I seem to have fixed it by applying the following to each MIDI track: MIDI editor, select the option View > Piano Roll Timebase, and select Source Beats.

When I did this, everything dutifully snapped in place. Then I glued all the MIDI items together for good measure. Per your feedback, I went back to the Piano Roll Timebase, and re-selected Project Beats. So far, so good.
XilburQost is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 10:38 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.