Old 05-16-2011, 11:43 AM   #81
clerks
Human being with feelings
 
Join Date: May 2010
Posts: 439
Default

Axel, attend un peu avant de retourner ton Nocturne, je crois que je viens de trouver une solution... j’essaie de faire une petite LICE-CAP...
clerks is offline   Reply With Quote
Old 05-16-2011, 11:59 AM   #82
achambily
Human being with feelings
 
achambily's Avatar
 
Join Date: Sep 2010
Location: Capesterre-Belle-Eau
Posts: 1,650
Default

ahhhhhh
pas de pb, prend ton temps
__________________
Axel Casadesus
http://soundcloud.com/axel-casadesus/sets
achambily is offline   Reply With Quote
Old 05-16-2011, 12:35 PM   #83
clerks
Human being with feelings
 
Join Date: May 2010
Posts: 439
Default

Bon pour l'instant j'arrive pas à mettre une image GIF (LiceCap) dans mon poste
clerks is offline   Reply With Quote
Old 05-16-2011, 12:49 PM   #84
clerks
Human being with feelings
 
Join Date: May 2010
Posts: 439
Default

En gros la manip consiste à mettre ReamidiControl avant ton instrument dans le FX de ta piste. Ensuite dans celui ci tu coche Raw-mode et Enable dans la partie control change, toujours dans la partie contrôl change, tu choisi dans liste le cc1 (modwheel). Sur ton Nocturne tu passe en Mode User, tu affecte un CC1 à un de tes contrôleurs de ton choix. Et là quand tu bouge ton contrôleur sur le nocturne cela fais bouge le CC1 dans le plug ReaMidiControl. Ensuite tu vas clicker sur le bouton paramètres ,toujours dans le plug ReaMidiControl, dans dans la liste déroulante tu choisi "shox track enveloppe". Ensuite tu passe en mode Write, et enfin tu peux pilote ton CC1... Même chose pour le reste bien sur, désolé pour l’animation, quand je saurai comment la poster je te la montre bien entendu...
Reaper est capricieux, car même avec d'autre contrôleur, j'ai eu des soucis, il a fallu que je fasse plusieurs fois la manip et que je charge un instrument VSTi avant que le plug ReaMidControl daigne réagir au sollicitations, ensuite ça a fonctionné...
clerks is offline   Reply With Quote
Old 05-16-2011, 01:29 PM   #85
Kill Bel
Human being with feelings
 
Join Date: Mar 2011
Location: France
Posts: 3,455
Default

te fatigue pas pour le LiceCap... Feusté l'a déjà posté ...

et on a déjà remarqué que les codeurs du nocturn ne fonctionnaient pas dans cette manip (après une bonne tapée d'essais) : tu veux dire qu'une fois pris en compte, ça marche à les coups par la suite ?

je pensais le montrer par un LiceCap, mais la fenêtre Automap se met en avant plan et ne sera donc pas visible
__________________
BR
Kill Bel is offline   Reply With Quote
Old 05-16-2011, 02:01 PM   #86
Feusté
Human being with feelings
 
Feusté's Avatar
 
Join Date: Dec 2010
Location: Colombes,France
Posts: 1,680
Default

clerks a l'air de dire qu'il faut charger le reacontrolmidi avant le VST,je sais pas si ça change quelque chose.
Feusté is offline   Reply With Quote
Old 05-16-2011, 02:03 PM   #87
Kill Bel
Human being with feelings
 
Join Date: Mar 2011
Location: France
Posts: 3,455
Default

c'est ce que j'avais fait dès le début bien évidemment
(et s'il est après, ça ne change rien)
__________________
BR
Kill Bel is offline   Reply With Quote
Old 05-16-2011, 02:10 PM   #88
Feusté
Human being with feelings
 
Feusté's Avatar
 
Join Date: Dec 2010
Location: Colombes,France
Posts: 1,680
Default

bon, y a plus que Sherlock Holmes ou Maigret pour débrouiller le truc.
Feusté is offline   Reply With Quote
Old 05-16-2011, 04:20 PM   #89
clerks
Human being with feelings
 
Join Date: May 2010
Posts: 439
Default

Bonsoir,
non non pas besoin de sherlock j'ai bien réussi à écrire une automation du cc1 avec le Nocturn, mais par contre je sais pas comment vous le montrer , car je ne sais pas comment mettre mon gif dans mon post (il me demande un lien URL et moi c'est là que je bloque, j'imagine qu'il faut uploader mon GIF quelque part, sur le site mais je sais pas trop comment m'y prendre).

Par contre c'est vraiment bizarre parce-que j'ai fais cette manip (écrire cc1 mode-wheel, en passant par ReaMidiControl) une première fois, et ensuite quand j'ai ré essayé pour faire un Licecap ça ne marchais plus, ensuite j'ai insisté, en mettant d'abord un synthé (j'ai utilisé Fab filter twin2) ça voulais toujours pas fonctionner, j'ai fais un learn sur celui ci puis finalement ReaMidicontrole c'est remis à réagir, ensuite j'ai tout viré pour faire un nouvel essais avec Licecap et là c'était bon. Petite precision je l'ai fais avec Reaper 3.76, pas essayé encore avec la V4 beta.

Je viens de refaire un essais et ça fonctionne encore??? Bref si une âme charitable m'aide à intégrer un GIF dans mon post je pourrais vous montrer ça (excepter que la fenêtre automap n'apparais pas, même si je la met en "opaque")
clerks is offline   Reply With Quote
Old 05-16-2011, 11:36 PM   #90
Kill Bel
Human being with feelings
 
Join Date: Mar 2011
Location: France
Posts: 3,455
Default

oui, la fenêtre automap se met en avant-plan devant licecap

pour le gif, il faut l'héberger quelque par et mettre le lien http:// entre les [img] et [/img]

mais qu'y a-t-il de différent avec ce qu'a montré Feusté ? (à part le VST en plus)

ce qui serait intéressant, ce serait tes réglages dans les préférences (midi devices et control surface) et dans automap)

de mon côté j'avais encore tenté la manip une dizaine de fois, en recommençant tout, en reréglant ... rien à faire. Et pourtant, avec la version Keyboard, les modwheel et le Pitchbend sont toujours pris en compte, sans problème
__________________
BR
Kill Bel is offline   Reply With Quote
Old 05-17-2011, 08:31 AM   #91
Feusté
Human being with feelings
 
Feusté's Avatar
 
Join Date: Dec 2010
Location: Colombes,France
Posts: 1,680
Default

je ne me sert pas de surface de control ,donc je ne peux pas vous être d'un grand secours.Clerk il faut que tu t'inscrive chez un hébergeur d'images et mettre le lien qu'il te donneront dans ton post.
Feusté is offline   Reply With Quote
Old 05-17-2011, 09:30 AM   #92
Kill Bel
Human being with feelings
 
Join Date: Mar 2011
Location: France
Posts: 3,455
Default

Quote:
Originally Posted by Kill Bel View Post
pour le gif, il faut l'héberger quelque par et mettre le lien http:// entre les [img] et [/img]
désolé, j'ai oublié le "t" à "quelque par..t"
des hébergeurs gratuits, il y en a des milles et des cents
__________________
BR
Kill Bel is offline   Reply With Quote
Old 05-17-2011, 11:12 AM   #93
clerks
Human being with feelings
 
Join Date: May 2010
Posts: 439
Default

Ouiap pour l’hébergeur d'image j'ai essayé hier soir, mais j'avais pas trop de temps et comme mon gif faisais +de 5Mo (5210Ko) ben les deux que j'ai essayé non pas fonctionné. Du coup j'ai pas eu le temps. Je ré essayerai tout à l'heure, en refaisant un Gif moins lourding...
Pour les préférences je vous les montrerai, mais j'ai activé dans les préférences midi msg(ou note) + cc (je crois) sur Automap midi... Autre précision, j'ai eu exactement les mêmes soucis avec mes contrôleurs de ma tables qui passe par ma carte Raydat (port midi 16) ... donc je me suis dit que le soucis venais de plutôt de Reaper.. Mais bon, je referai tout ça tout à l'heure.
Autre truc, comme je ne me servais pas du protocole hui (je pilote que mes plugs), j'ai testé au passage et ça ne fonctionnais pas, du coup j'ai désinstallé et réinstallé Automap, ensuite ça fonctionnait sauf que ... mon driver Zed R16 lui à "dégagé" (bon je m'en fou, je me sert de ma table en ADAT avec une carte Raydat), et en fait il y a bien un soucis de driver entre Automap et Allen&Heath, soit j'installe Automap soit ZED, mais pas les deux en même temps...
clerks is offline   Reply With Quote
Old 05-17-2011, 01:01 PM   #94
clerks
Human being with feelings
 
Join Date: May 2010
Posts: 439
Default

Ben si vous connaissez un hébergeur d'images qui fonctionne bien, parce que là j'en suis au 4eme et apparemment ils ne fonctionnent pas et ça commence à me courir .... Ha enfin un qui fonctionne bien , au cas ou ça en interesse d'autre : www.PixyUp.com
Autre précision, je viens d'essayer avec Reaper V4, et ça fonctionne mieux qu'avec la V3, mais dans mes préférences il a fallu que je vire la partie contrôle surface (Partial Hui) et là ça fonctionne.

OUF voici donc l'affaire :


Apparemment le Modwheel est fait par MMC(comme souvent les commandes de transport) et non des Contrôle Change, il faut que je vérifie, mais cela expliquerai pourquoi on galère à piloter ces paramètres avec des CC. Il faut que je regarde. Donc pour la config, contrôle surface dans Reaper : Aucune. Pour les paramètres Midi ben on les voit sur ce Gif. Dans Automap ben j'ai suivi les conseil de Kil Bell Mode User, et puis je crois que c'est tout.

Last edited by clerks; 05-17-2011 at 01:43 PM.
clerks is offline   Reply With Quote
Old 05-17-2011, 02:04 PM   #95
sardonicus
Human being with feelings
 
sardonicus's Avatar
 
Join Date: Jan 2010
Posts: 6,736
Default

Dropbox... Pratique parce qu'en plus ç'est aussi une zone de stockage/synchro entre PC, 2 gigas en version gratuite.
__________________
Ignorance ou indifférence: J'en sais rien et je m'en fous.
sardonicus is offline   Reply With Quote
Old 05-17-2011, 02:28 PM   #96
Kill Bel
Human being with feelings
 
Join Date: Mar 2011
Location: France
Posts: 3,455
Default

super clerks ! bonne nouvelle


on avance et les nouvelles que voici que voilà vont être bonnes elles aussi :

.....on peut parfaitement conserver la surface de contrôle HUI !!

les modes "mixer" ET "inst" ET "user" fonctionnent donc en parallèle

j'ajoute à ta présentation qu'il faut également activer "automap MIDI" dans "settings / MIDI output ports" et "settings / MIDI input ports" de l'automap
(c'est ce que j'avais omis et voilà pourquoi je n'arrivais à rien !)

allez, on va se boire une bière maintenant

Axel... t'es sauvé ...
__________________
BR
Kill Bel is offline   Reply With Quote
Old 05-17-2011, 02:45 PM   #97
Kill Bel
Human being with feelings
 
Join Date: Mar 2011
Location: France
Posts: 3,455
Default Bug sur mon clavier NOCTURN

Tiens clerks (et tous ceux qui ont du novation bien sûr), vu qu'on s'amuse comme des fous avec nos configs, ce serait dommage de s'arrêter, non ? le mode "mix" fonctionne-t-il correctement chez toi ?

J'ai un petit soucis (rien de grave, je m'en sors avec une astuce, mais quand même...) et chez Novation ils n'arrivent pas à trouver la faille :

en mode mixer (HUI) les leds de la première piste tombent toujours à zéro
- quand j'ajoute une nouvelle piste (en fait au deuxième ajout de piste)
- quand j'arme ou désarme une piste (c'est ce que j'ai affecté aux poussoirs) (en fait au deuxième appui)
alors que le fader de cette première piste ne bouge pas dans reaper

et quand je manipule le codeur, le fader de reaper tombe donc immédiatement à zéro... ce fameux saut que les codeurs sont justement sencés éviter

j'ai la version clavier, peut-être que ça lui est propre

et ce bug n'est qu'avec Reaper (V3 et V4 alphas et betas) : aucun soucis avec Tracktion (démo) ni Live8

merci
__________________
BR
Kill Bel is offline   Reply With Quote
Old 05-17-2011, 03:37 PM   #98
clerks
Human being with feelings
 
Join Date: May 2010
Posts: 439
Default

Salut,
Bon ben pourvu qu'Axel s'en sorte, ce serai cool.
Quant au bug, Kil ben là il est tard et je m'en vais rejoindre les bras de m..a dulcinée, je regarde ça demain et je vous tiens au jus...
Merci Sardonicus pour le tuyau (enfin pour le site j'voulais dire), je vais regarder ça aussi..
clerks is offline   Reply With Quote
Old 05-17-2011, 06:12 PM   #99
Kill Bel
Human being with feelings
 
Join Date: Mar 2011
Location: France
Posts: 3,455
Default

y en a qui ne dorment jamais quand c'est la pleine lune ... soyons nocturn !


???????????????? je me demande si on a besoin du plug ReaControlMidi ?????????????????????????

en tout cas, chez moi ça roule sans ce plug


__________________________________________________ ___

donc pour résumer :

1. Settings de la fenêtre Automap (si on souhaite utiliser le Nocturn en tant que surface de contrôle et non seulement comme un simple contrôleur MIDI, "Use Automap HUI" doit être coché... et il faut terminer son installation en sélectionnant "Continuer" quand c'est demandé, attention cette nouvelle fenêtre peut être cachée !!)

Egalement régler les Midi ports et Channel comme suit, mais seulement pour la manip demandée par Axel (accès au CC)




2. Dans Reaper, activer la surface de contrôle en mode HUI (on profitera pleinement du Novation à la fois pour mixer dans Reaper et aussi pour contrôler les VSTi et VST dans les meilleures conditions)

Surface offset à 0 pour inclure la piste master




3. Régler les devices MIDI dans Reaper de la manière suivante (ceci c'est pour la manip de Axel : accéder aux CC non détectés par l'Automap HUI)




4. retour sur le Nocturn :

mode "mixer" pour mixer"

mode "inst" et "fx" pour les VSTi et VST automappés

mode "User" (le "spécial Axel" ) : cliquer dans la fenêtre Automap sur le contrôleur souhaité (n'importe quel codeur ou le fader horizontal ou quoi que ce soit d'autre selon le modèle) et sélectionner le bon numéro de CC dans le champ "Parameters"




Donc sans plug supplémentaire, ça marche très bien. A vérifier sur vos installations

@+
__________________
BR

Last edited by Kill Bel; 05-17-2011 at 06:34 PM.
Kill Bel is offline   Reply With Quote
Old 05-18-2011, 03:37 AM   #100
Kill Bel
Human being with feelings
 
Join Date: Mar 2011
Location: France
Posts: 3,455
Default

Axel ... donnes-nous de tes nouvelles !

A ce point, est-ce bon ?

Parce qu'il nous reste alors à discuter de l'automation ... (pas aussi évident à gérer que dans les LicepCap ci-dessus
__________________
BR
Kill Bel is offline   Reply With Quote
Old 05-18-2011, 04:05 AM   #101
clerks
Human being with feelings
 
Join Date: May 2010
Posts: 439
Default

Salut Kil,
J'ai essayé de maniper avec le nocturne et donc j'ai bien le même bug que tu as décris :
Quote:
en mode mixer (HUI) les leds de la première piste tombent toujours à zéro
- quand j'ajoute une nouvelle piste (en fait au deuxième ajout de piste)
- quand j'arme ou désarme une piste (c'est ce que j'ai affecté aux poussoirs) (en fait au deuxième appui)
Et merci pour la synthèse que tu as fait, je la trouve très claire.

d'autre part, en voulant ré-essayé en mode user j'ai moi aussi galéré : pour que le contrôle des CC se fassent par le Nocturne ou d'autre encodeurs (ceux de ma table par exemple) il faut que:
1 - la piste sur lequel est le VSTi soit armée (ce qui parait logique il me semble, mais faut pas l'oublier, et donc j'ai oublié ce détail ce matin)
2 - si comme moi le clavier qui pilote l'instrument et les encodeurs midi (Nocturne) sont séparés (ce qui mon cas pour ma table ou le Nocturne), il faut mettre "l'entrée" de la piste en ALL MIDI, afin que celle ci reçoive les messages du clavier et des CC, le Nocturne en ce qui nous concerne.

Et pour finir Axel t'es où? parti en vacances ? Ça vas ?
clerks is offline   Reply With Quote
Old 05-18-2011, 04:36 AM   #102
sardonicus
Human being with feelings
 
sardonicus's Avatar
 
Join Date: Jan 2010
Posts: 6,736
Default

Ian Anderson, tu peux nous faire un chouette résumé pour les "comment faire"?
__________________
Ignorance ou indifférence: J'en sais rien et je m'en fous.
sardonicus is offline   Reply With Quote
Old 05-18-2011, 04:57 AM   #103
achambily
Human being with feelings
 
achambily's Avatar
 
Join Date: Sep 2010
Location: Capesterre-Belle-Eau
Posts: 1,650
Default

désolé les gars, je suis débordé en ce moment et j'ai pas eu le temps de regarder
mais ça m'a l'air foutrement compliqué pour un malheureux modwheel qui, si j'ai bien compris n'est pas automationnable ?...
sinon, j'ai lu en diagonale et moi aussi j'ai constaté que dès que je tournais un potard de volume la première fois ça me mettait le fader à zero dans reaper !
et du coup je perd ce que j'avais mis...
__________________
Axel Casadesus
http://soundcloud.com/axel-casadesus/sets
achambily is offline   Reply With Quote
Old 05-18-2011, 05:07 AM   #104
clerks
Human being with feelings
 
Join Date: May 2010
Posts: 439
Default

Mais non c'est pas si compliqué, c'est juste que quand tu détailles tout, ça fais vite épais.

Perso j'y ai passé 2 fois 15min, le plus long ça été de faire un Licecap et de le poster pour toi... ça m'a pris au moins un heure ou deux (et la prochaine fois ça me prendra 10 min) .

Quand on fais les choses pour la première fois et qu'il y a personne pour t'aider là c'est compliqué.

Je n'ai jamais eu autant d'aide que ça quand j'ai commencé à mettre les mains dans le "Camboui MAO".

J’espère que tu aura le temps et le courage de surpasser ton a priori... Surtout que tu es un peu vexant, on passe un certain nombre de post pour trouver la solution, tu lis en diagonale et seul le "bug" retiens ton attention. Quant à ce "bug" moi comme ça vu que c'est toujours sur la première piste, ben je mettrai un piste inutilisée par exemple, Kil à dis qu'il avait une "bidouille", elle peut être plus intéressant que ce que je viens de proposer, mais ce bug il est en mode Hui, donc rien avoir avec tes problèmes pour piloter PLAY. Allez un peu de courage je suis sur que tu vas finir par réussir à piloter ton Vsti.

Last edited by clerks; 05-18-2011 at 05:56 AM.
clerks is offline   Reply With Quote
Old 05-18-2011, 05:32 AM   #105
Kill Bel
Human being with feelings
 
Join Date: Mar 2011
Location: France
Posts: 3,455
Default

@ Sardonicus : yeah, je vais tenter de souffler dans le pipeau pour pondre un tuto qui ne soit pas du pipeau... je vais prendre un peu de temps pour être exhaustif, et ça c'est pas simple juste avec un licecap

@ achambilly : si, c'est automatisable !! mais il faut faire gaffe (tiens je vais poster le complément dans le prochain message). T'inquiète, on reprendra le tout à zéro, comme t'es débordé ça tombe bien, j'aurais le temps de le préparer.
Ce que tu décris ne correspond pas au bug dont j'ai parlé, il me semble que simplement tu n'utilises pas le mode HUI (allez, garde ton nocturn et je ferais signe pour un tuto en règle)

@ clerks : ça a donc l'air d'un bug. J'ai encore une manip à essayer (ce soir tard) indiquée par Novation, sans quoi ils me demandent d'échanger le clavier. Mais je suis convaincu qu'il s'agit d'un bug par rapport à Reaper puisqu'il n'y a aucun soucis avec Tracktion et Live8. Pourtant, il disent qu'ils n'arrivent pas à provoquer ce comportement avec Reaper !
Tiens, si tu peux faire l'essai, voici ce que Novation demande de tester ... mais oui, ça se fait pas de publier directement un mail privé, alors je traduis :

1. quitte toutes les applications, et dans "démarrer / tous les programmes" lancer l'automap server par clic droit / exécuter en tant qu'administrateur

2. fais pareil avec Reaper

3. nouveau projet et Options > Preferences > Control Surfaces

4. supprime HUI partial control surface et recharge-en une nouvelle, Automap HUI en entrée et en sortie

5. créé 8 pistes et vois si le bug persiste (auquel cas : retour au magasin... mais si c'est pareil pour toi, c'est plutôt un problème soft, non ?)

j'ajoute que j'ai testé le clavier sur un autre ordinateur, avec le même résultat

ce que je fais en pratique : je mets la reverb générale en piste 1, que je ne touche jamais au mixage

c'est dommage, parce que le reste de l'automap est absolument génial ! ça vaut le coup d'y passer un peu de temps
__________________
BR
Kill Bel is offline   Reply With Quote
Old 05-18-2011, 05:48 AM   #106
Kill Bel
Human being with feelings
 
Join Date: Mar 2011
Location: France
Posts: 3,455
Default

voilà, donc mon post #99 un peu plus haut, c'est la manip pour accéder à la fois aux paramètres automappés (l'idéal !) mais aussi aux paramètres non reconnus comme le CC1 de PLAY

pour l'automation de ces derniers paramètres, il y a deux choses ( @ Axel : pour que la complexité ne s'ajoute à la complexité, vérifie d'abord que tu accèdes bien au crossfade comme décrit ci-dessus, avant de lire la suite) :

2 solutions donc :

1. on peut mettre la piste en enregistrement, jouer et manipuler les codeurs (sans le plug ReaControlMidi supplémentaire)

l'automation se traduira par des événements MIDI qu'on trouvera dans l'item MIDI (en bas de la fenêtre d'édition MIDI, sélectionner le paramètre à rendre visible : ici, ModWheel). Il s'agit des barres verticales en bas d'item

2. faire la manip montrée par Feusté et clerks dans leurs LiceCaps

cela donnera une enveloppe d'automation

Alors évidemment, dans ce deuxième cas de figure, on aura les événements Midi d'une part ET l'enveloppe d'automation d'autre part qui piloteront simultanément le même paramètre. Pour l'instant, pas de soucis puisque l'un et l'autre sont identiques.

Mais si on modifie l'enveloppe d'automation, il y aura conflit entre les deux commandes et le paramètre aura un comportement hératique non utilisable.

Alors soit on filtre les événements MIDI concernés et on travaille sur l'enveloppe d'automation,
soit on se passe d'enveloppe (on n'utilise PAS ReaControlMidi) et on travaille les événements Midi dans l'éditeur Midi

Sur cette illustration : les événements Midi dans l'item et l'enveloppe en-dessous

__________________
BR
Kill Bel is offline   Reply With Quote
Old 05-18-2011, 09:17 AM   #107
achambily
Human being with feelings
 
achambily's Avatar
 
Join Date: Sep 2010
Location: Capesterre-Belle-Eau
Posts: 1,650
Default

Quote:
Originally Posted by clerks View Post
Mais non c'est pas si compliqué, c'est juste que quand tu détailles tout, ça fais vite épais.

Perso j'y ai passé 2 fois 15min, le plus long ça été de faire un Licecap et de le poster pour toi... ça m'a pris au moins un heure ou deux (et la prochaine fois ça me prendra 10 min) .

Quand on fais les choses pour la première fois et qu'il y a personne pour t'aider là c'est compliqué.

Je n'ai jamais eu autant d'aide que ça quand j'ai commencé à mettre les mains dans le "Camboui MAO".

J’espère que tu aura le temps et le courage de surpasser ton a priori... Surtout que tu es un peu vexant, on passe un certain nombre de post pour trouver la solution, tu lis en diagonale et seul le "bug" retiens ton attention. Quant à ce "bug" moi comme ça vu que c'est toujours sur la première piste, ben je mettrai un piste inutilisée par exemple, Kil à dis qu'il avait une "bidouille", elle peut être plus intéressant que ce que je viens de proposer, mais ce bug il est en mode Hui, donc rien avoir avec tes problèmes pour piloter PLAY. Allez un peu de courage je suis sur que tu vas finir par réussir à piloter ton Vsti.
Je suis désolé, je ne voulais pas que ma réponse soit prise comme ça J'ai justement pris le temps de faire un post pour dire que j'étais pas mort et que je m'en foutais pas du tout ! Mais je suis vraiment débordé et je sais même pas si je trouverai le temps aujourd'hui de tester tout ça... Sinon, c'est sûr que je n'aime pas trop me retrouver dans ce genre de situation où tu passes énormément de temps sur la technique (pour faire un truc très simple au final) et pas à faire de la musique
En plus j'ai un autre pb encore plus urgent que je vais exposer dans un autre post...
Mais en attendant, merci pour votre patience et votre pugnacité à résoudre le pb (que je pensais très simple au départ, pensant que c'était moi qui ratait un truc).
__________________
Axel Casadesus
http://soundcloud.com/axel-casadesus/sets
achambily is offline   Reply With Quote
Old 05-18-2011, 09:22 AM   #108
achambily
Human being with feelings
 
achambily's Avatar
 
Join Date: Sep 2010
Location: Capesterre-Belle-Eau
Posts: 1,650
Default

Quote:
Originally Posted by Kill Bel View Post
@il me semble que simplement tu n'utilises pas le mode HUI
j'ai pourtant bien coché ça lors de l'install, comme tu me l'avais dit et comme me l'avait confirmé le tuto pour reaper de la derni_re version d'automap
__________________
Axel Casadesus
http://soundcloud.com/axel-casadesus/sets
achambily is offline   Reply With Quote
Old 05-18-2011, 09:23 AM   #109
achambily
Human being with feelings
 
achambily's Avatar
 
Join Date: Sep 2010
Location: Capesterre-Belle-Eau
Posts: 1,650
Default

Quote:
Originally Posted by Kill Bel View Post
voilà, donc mon post #99 un peu plus haut, c'est la manip pour accéder à la fois aux paramètres automappés (l'idéal !) mais aussi aux paramètres non reconnus comme le CC1 de PLAY

pour l'automation de ces derniers paramètres, il y a deux choses ( @ Axel : pour que la complexité ne s'ajoute à la complexité, vérifie d'abord que tu accèdes bien au crossfade comme décrit ci-dessus, avant de lire la suite) :

2 solutions donc :

1. on peut mettre la piste en enregistrement, jouer et manipuler les codeurs (sans le plug ReaControlMidi supplémentaire)

l'automation se traduira par des événements MIDI qu'on trouvera dans l'item MIDI (en bas de la fenêtre d'édition MIDI, sélectionner le paramètre à rendre visible : ici, ModWheel). Il s'agit des barres verticales en bas d'item

2. faire la manip montrée par Feusté et clerks dans leurs LiceCaps

cela donnera une enveloppe d'automation

Alors évidemment, dans ce deuxième cas de figure, on aura les événements Midi d'une part ET l'enveloppe d'automation d'autre part qui piloteront simultanément le même paramètre. Pour l'instant, pas de soucis puisque l'un et l'autre sont identiques.

Mais si on modifie l'enveloppe d'automation, il y aura conflit entre les deux commandes et le paramètre aura un comportement hératique non utilisable.

Alors soit on filtre les événements MIDI concernés et on travaille sur l'enveloppe d'automation,
soit on se passe d'enveloppe (on n'utilise PAS ReaControlMidi) et on travaille les événements Midi dans l'éditeur Midi

Sur cette illustration : les événements Midi dans l'item et l'enveloppe en-dessous

bah je sais pas si ça simplifie les choses mais je travaille en 2 temps :
1. j'enregistre les notes via mon clavier midi
2. j'ajoute les éléments d'expression (crescendi, articulations) après
__________________
Axel Casadesus
http://soundcloud.com/axel-casadesus/sets
achambily is offline   Reply With Quote
Old 05-18-2011, 12:34 PM   #110
achambily
Human being with feelings
 
achambily's Avatar
 
Join Date: Sep 2010
Location: Capesterre-Belle-Eau
Posts: 1,650
Default

salut Kil,
j'ai fait tous les réglages comme tu as indiqué (de façon très claire je dois dire) dans le post 99.
Ensuite pour faire un test, j'ai posé une note longue sur une piste.
Puis j'ai armé la piste en enregistrement en mode midi overdub avec pour source midi input/automap midi/channel 1 (je suppose que c ça kil fo mettre ça m'a paru logique avec les réglages précédents).
J'ai lancé l'enregistrement puis bougé le codeur du nocturn. Ben il se passe rien. Aucun CC produit ni enregistré
__________________
Axel Casadesus
http://soundcloud.com/axel-casadesus/sets
achambily is offline   Reply With Quote
Old 05-18-2011, 12:56 PM   #111
Kill Bel
Human being with feelings
 
Join Date: Mar 2011
Location: France
Posts: 3,455
Default

attends, tu brûles les étapes !!

- d'abord, fais les réglages indiqués pour Reaper et Automap

- ensuite joue normalement au clavier (sans enregistrer !) et manipule ton contrôleur (celui que tu as affecté à ce CC1)

est-ce que tu entend bien le crossfade opérer ... ?

STP réponds OUI

si c'est NON, revérifie le tout.

__________________________________________________ ___

Si c'est OUI, c'est que ton Nocturn pilote maintenant le CC1 et il reste donc l'automation


Si tu préfères travailler avec les enveloppes plutôt qu'avec les évènements MIDI (voir la seconde démo ci-dessous), tu ajoutes ReaControlMidi AU-DESSUS de PLAY dans la liste des FX INSERTS et pour le régler c'est plus simple en fait que les démos de Feusté et clerks (excusez-moi les amis !)
... il suffit de sélectionner ce qui suit
... on y voit en même temps cette installation

note : là où j'ai Absynth, tu auras PLAY





Ensuite, on peut s'y prendre de différentes façons.

On voit notamment que travailler avec les évènements MIDI ne nécessite PAS l'installation de ReaControlMidi.

A chacun de choisir :





@+
__________________
BR

Last edited by Kill Bel; 05-18-2011 at 01:01 PM.
Kill Bel is offline   Reply With Quote
Old 05-18-2011, 01:23 PM   #112
Feusté
Human being with feelings
 
Feusté's Avatar
 
Join Date: Dec 2010
Location: Colombes,France
Posts: 1,680
Default

Quote:
Originally Posted by Kill Bel View Post
et pour le régler c'est plus simple en fait que les démos de Feusté et clerks (excusez-moi les amis !)
excuse me!j'ai pas compris ce qui est plus simple?bouger le fader dans reacontrol fait s'afficher l’enveloppe dans les pistes?
Feusté is offline   Reply With Quote
Old 05-18-2011, 01:41 PM   #113
Kill Bel
Human being with feelings
 
Join Date: Mar 2011
Location: France
Posts: 3,455
Default

les réglages et le learn par le bouton "param"

et comme Axel trouve tout cela bien compliqué, j'allais au plus juste

... voulais pas te vexer !
__________________
BR
Kill Bel is offline   Reply With Quote
Old 05-18-2011, 01:44 PM   #114
Feusté
Human being with feelings
 
Feusté's Avatar
 
Join Date: Dec 2010
Location: Colombes,France
Posts: 1,680
Default

pas vexer! voulait juste être sur
Feusté is offline   Reply With Quote
Old 05-18-2011, 01:46 PM   #115
achambily
Human being with feelings
 
achambily's Avatar
 
Join Date: Sep 2010
Location: Capesterre-Belle-Eau
Posts: 1,650
Default

ah bah de toutes façons, pour que mon clavier fasse entendre un son, fo que j'ai une piste armée en enregistrement
(meme si je n'enregistre pas)
là je reviens de tester avec input all midi all channels
(ratissons large hein !)
ça maaaarche !
(mais bizarre, quand je tripote le nocturn ça ne provoque pas d'activité midi sur la piste - trucs rouges qui bougent -)
en tous cas j'entends bien le crescendo maintenant
reste à passer à l'automation maintenant...
__________________
Axel Casadesus
http://soundcloud.com/axel-casadesus/sets

Last edited by achambily; 05-18-2011 at 01:53 PM.
achambily is offline   Reply With Quote
Old 05-18-2011, 02:02 PM   #116
Kill Bel
Human being with feelings
 
Join Date: Mar 2011
Location: France
Posts: 3,455
Default

oui, armer la piste et toussa, je ne refais pas toute la doc non plus

mais fallait pas vouloir automatiser dans la foulée, il faut sérier les éléments

(Feusté : c'est moi)
__________________
BR
Kill Bel is offline   Reply With Quote
Old 05-18-2011, 02:05 PM   #117
achambily
Human being with feelings
 
achambily's Avatar
 
Join Date: Sep 2010
Location: Capesterre-Belle-Eau
Posts: 1,650
Default

Quote:
Originally Posted by Kill Bel View Post
oui, armer la piste et toussa, je ne refais pas toute la doc non plus ;-)

(Feusté : c'est moi)
oui, mais c'était pour te dire que je brulais pas les étapes
du coup, finalement, l'automation serait presque pas nécessaire car j'ai enregistré le CC1 en midi overdub et ça le fait pas mal...
(petite remarque : ça réagit très lentement, fo que j'anticipe vachement mon mouvement sur le nocturn pour qu'il soit enregistré sur la bonne note)
__________________
Axel Casadesus
http://soundcloud.com/axel-casadesus/sets
achambily is offline   Reply With Quote
Old 05-18-2011, 02:17 PM   #118
Feusté
Human being with feelings
 
Feusté's Avatar
 
Join Date: Dec 2010
Location: Colombes,France
Posts: 1,680
Default

Quote:
Originally Posted by achambily View Post
ça réagit très lentement, fo que j'anticipe vachement mon mouvement sur le nocturn pour qu'il soit enregistré sur la bonne note)
si tu as trop de latence tu peux toujours déplacer tes données de CC après coup,et plus facilement si t'enregistre ton CC sur un item séparé avec propriete de l'item.
Feusté is offline   Reply With Quote
Old 05-19-2011, 12:08 AM   #119
Kill Bel
Human being with feelings
 
Join Date: Mar 2011
Location: France
Posts: 3,455
Default

oui, bonne idée

et dans le cas précis où on automatise APRES avoir joué les notes, on peut se demander si n'intervient pas la latence humaine : le temps d'entendre le son (qui déjà n'a pas une attaque hyper franche), de réagir, de tourner le bouton, et hop c'est trop tard ...
__________________
BR
Kill Bel is offline   Reply With Quote
Old 05-19-2011, 03:10 AM   #120
Kill Bel
Human being with feelings
 
Join Date: Mar 2011
Location: France
Posts: 3,455
Default

voilà voilà, la question posée est résolue et achambily est content (enfin non, pas tout-à-fait)

je tiens à remercier Feusté et clerks d'avoir apporté leurs contributions à ce sujet

on apprend toujours quelque chose, et ainsi on peut éviter de perdre du temps à l'avenir
__________________
BR
Kill Bel is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 02:02 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.