Old 05-10-2019, 09:33 PM   #1
xpander
Human being with feelings
 
xpander's Avatar
 
Join Date: Jun 2007
Location: Terra incognita
Posts: 4,683
Default v5.978 - May 10 2019

v5.978 - May 10 2019

+ ARA: improve drag and drop behavior when copying to other tracks
+ ARA: improve selection/undo history behavior when adding ARA plug-ins to existing FX chain [p=2131258]
+ Automation items: fix issues with bypass envelopes and PDC [t=220633]
+ Linux: implement memory use warnings, memory use in help text
+ Notation editor: improve phrase handling when some notes are filtered out [t=220652]
+ Theme: fix grid line draw mode loading/saving on macOS/Linux
+ VST: use VST3 enum steps for generic parameter UI
+ Windows: fix potential memory error when performance meter is open (thanks Gabriel Ivancescu)
+ linux: use realtime for reaper_host_xxx if REAPER running realtime
+ macOS: improve behavior when closing file/directory browse windows

This thread is for pre-release features discussion. Use the Feature Requests forum for other requests.

Changelog - Pre-Releases

Generated by X-Raym's REAPER ChangeLog to BBCode
xpander is offline   Reply With Quote
Old 05-11-2019, 12:43 AM   #2
playtimer
Human being with feelings
 
Join Date: Mar 2014
Posts: 166
Default

Just lovely! Cockos in on the roll with quick and very nice updates
Thank you, devs!
playtimer is offline   Reply With Quote
Old 05-12-2019, 04:27 PM   #3
Commala
Human being with feelings
 
Join Date: Feb 2014
Posts: 603
Default

5.978 x64 W10

Not sure when this happened, but I am unable to export notation to xml and import it to Musescore successfully. Importing to Musescore hangs the program, I tested on a version 2.3.2 of Musescore that I have not updated since I last did a successful xml import from Reaper. Also tested on Musescore 3, same thing.
Commala is offline   Reply With Quote
Old 05-12-2019, 04:43 PM   #4
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 12,114
Default

Quote:
Originally Posted by Commala View Post
5.978 x64 W10

Not sure when this happened, but I am unable to export notation to xml and import it to Musescore successfully. Importing to Musescore hangs the program, I tested on a version 2.3.2 of Musescore that I have not updated since I last did a successful xml import from Reaper. Also tested on Musescore 3, same thing.
Can you post a .rpp that when exported to MusicXML hangs Musescore?
Justin is offline   Reply With Quote
Old 05-12-2019, 08:17 PM   #5
Commala
Human being with feelings
 
Join Date: Feb 2014
Posts: 603
Default

Yes, this one does it. Sorry I had to go to a backup to get a version that reproduces this again, I've been working on this one, changed some things and now the import is successful. Since this backup was made, I've changed the tempo, time signature, glued the MIDI item after stretching it to the new time signature, input more notes, etc.

https://stash.reaper.fm/v/36359/test.rpp
Commala is offline   Reply With Quote
Old 05-13-2019, 04:06 AM   #6
schwa
Administrator
 
schwa's Avatar
 
Join Date: Mar 2007
Location: NY
Posts: 10,087
Default

If I export from that project as xml, it imports successfully into MuseScore 3.0.5.5992. Is that the same version you are on?

(It does warn about a stray ' ' character (which we'll fix) but that doesn't affect the import.)
schwa is offline   Reply With Quote
Old 05-13-2019, 06:23 AM   #7
bFooz
Human being with feelings
 
bFooz's Avatar
 
Join Date: Jul 2010
Location: Slovakia
Posts: 939
Default

This one does crash. Musescore version 3.0.5.5992, rev 58dd23d, Win7 x64.

https://drive.google.com/file/d/1-wQ...ew?usp=sharing
__________________
Donations | Mixing & Mastering Services
bFooz is online now   Reply With Quote
Old 05-13-2019, 06:32 AM   #8
bFooz
Human being with feelings
 
bFooz's Avatar
 
Join Date: Jul 2010
Location: Slovakia
Posts: 939
Default

Dorico imports properly, but is giving a lot of these warnings:


ERROR - Element 'slur', attribute 'number': [facet 'maxInclusive'] The value '19' is greater than the maximum value allowed ('6').
At line 2101 of D:/Studio/Orchester/Scoreclub/Export/test-musxmlexporttomusescore.xml

ERROR - Element 'slur', attribute 'number': '19' is not a valid value of the atomic type 'number-level'.
At line 2101 of D:/Studio/Orchester/Scoreclub/Export/test-musxmlexporttomusescore.xml
__________________
Donations | Mixing & Mastering Services
bFooz is online now   Reply With Quote
Old 05-13-2019, 07:15 AM   #9
robgb
Human being with feelings
 
Join Date: Apr 2017
Location: Los Angeles, CA
Posts: 126
Default

Quote:
Originally Posted by xpander View Post
+ macOS: improve behavior when closing file/directory browse windows
I'm curious. Does anyone know what behavior needed improving? I have found Reaper slower to respond lately, but figured that was because I upgraded to Mojave.
robgb is offline   Reply With Quote
Old 05-13-2019, 07:29 AM   #10
schwa
Administrator
 
schwa's Avatar
 
Join Date: Mar 2007
Location: NY
Posts: 10,087
Default

Fixed a couple of musicxml bugs for the next build, thanks.
schwa is offline   Reply With Quote
Old 05-13-2019, 07:57 AM   #11
bFooz
Human being with feelings
 
bFooz's Avatar
 
Join Date: Jul 2010
Location: Slovakia
Posts: 939
Default

When you're at it, there is still this bug with MuseScore: dynamics are always placed at the start of the measure.

Bellow imported into MuseScore. Both dynamics should be under notes.


XML attached.

Or should I rather report to MuseScore?
Attached Files
File Type: xml test-dynamics2.xml (5.6 KB, 22 views)
__________________
Donations | Mixing & Mastering Services
bFooz is online now   Reply With Quote
Old 05-13-2019, 10:04 AM   #12
Commala
Human being with feelings
 
Join Date: Feb 2014
Posts: 603
Default

Quote:
Originally Posted by schwa View Post
If I export from that project as xml, it imports successfully into MuseScore 3.0.5.5992. Is that the same version you are on?

(It does warn about a stray ' ' character (which we'll fix) but that doesn't affect the import.)
I tried with Musescore 2.3.2 and 3.0.5.5992 rev 58dd23d, both were hanging the other night. Now when I try with the project I posted, Musescore 3 loads correctly, but Musescore 2 still hangs.

Apologies, I had only test imported the xml into Musescore 2 before posting the pared down rpp (after having both definitely hang earlier last night), because Musescore 3 takes an age to open on my computer, a common problem as I understand it. Perhaps there was something I changed when I pared down the rpp that made it load correctly in Musescore 3, after all
Commala is offline   Reply With Quote
Old 05-13-2019, 10:16 AM   #13
schwa
Administrator
 
schwa's Avatar
 
Join Date: Mar 2007
Location: NY
Posts: 10,087
Default

There was a bug with how REAPER was exporting multiple slurs, which MuseScore didn't like. That should be fixed for the next build.
schwa is offline   Reply With Quote
Old 05-15-2019, 06:34 AM   #14
John Patrick
Human being with feelings
 
John Patrick's Avatar
 
Join Date: Nov 2008
Posts: 29
Default JSFX Missing

I can't find "JS: Video sampler peeker" in Reaper 5.978, It's all right in previous versions and in 5.978 + dev0514
John Patrick is offline   Reply With Quote
Old 05-24-2019, 12:51 PM   #15
daxliniere
Human being with feelings
 
daxliniere's Avatar
 
Join Date: Nov 2008
Location: London, UK
Posts: 1,905
Default

Automation Item bug:
Enlarge a looped AI, then disable loop, 'end point' is still shown and you can't move automation points past it.

Attached Images
File Type: jpg REAPER_BUG_AI_LoopOff.jpg (31.8 KB, 353 views)
__________________
Dax Liniere
London's newest premium studio complex! (Facebook)
[i7-4790K, 12Gb RAM, Win8.1x64, NVidia GT710, UAD2-OCTO, FireFaceUFX, REAPER x64]
daxliniere is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 11:18 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.