Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER for Linux

Reply
 
Thread Tools Display Modes
Old 05-06-2019, 06:08 AM   #681
SuperEB
Human being with feelings
 
Join Date: Jan 2016
Posts: 25
Default

Quote:
Originally Posted by osxmidi View Post
There is a mfc140.dll override that I've done for some plugins.

Waves need a whole procedure, so check the Waves section in the LinVst readme.
Thanks osxmidi, I've had waves plugins working on two different installs. This one was working up until last week when I ignorantly checked the "Enable GTK3 theming" box in winecfg. Couldn't get my plugins working again, so did a fresh install of MX Linux 18.2.

Either there is another step that I'm blind to, or something has changed with software.

Below are the exact steps I followed, in order. I worked from this list to avoid skipping a step or doing something out of order.

*** Removed list to help keep the internet clean. Problem solved a few posts down!

Last edited by SuperEB; 05-08-2019 at 03:30 PM.
SuperEB is offline   Reply With Quote
Old 05-07-2019, 04:25 PM   #682
brainwreck
Human being with feelings
 
Join Date: Jul 2006
Posts: 20,593
Default

Is there a preferred Wine version these days? I'm looking to run Addictive Drums and Amplitube on Manjaro. I'm gtting some crackling with more than one instance of Amplitube with the latest Wine stable. I see that some of you are running Amplitube. Maybe I'm missing some gotcha.
brainwreck is offline   Reply With Quote
Old 05-07-2019, 05:22 PM   #683
Glennbo
Human being with feelings
 
Glennbo's Avatar
 
Join Date: Mar 2008
Location: Planet Earth
Posts: 3,315
Default

Quote:
Originally Posted by brainwreck View Post
Is there a preferred Wine version these days? I'm looking to run Addictive Drums and Amplitube on Manjaro. I'm gtting some crackling with more than one instance of Amplitube with the latest Wine stable. I see that some of you are running Amplitube. Maybe I'm missing some gotcha.
I'm using Wine-Staging 4.0rc1 from https://www.winehq.org/

I'm sure it's been updated since I switched to it a few months ago so I could install Kontakt. I had been running Wine-Stable from the distro I run Xubuntu, but when I decided to get serious and try getting Kontakt installed, the recommended Wine version was Staging.
__________________
Glennbo
Hear My Music - Click Me!!!
--
Glennbo is offline   Reply With Quote
Old 05-07-2019, 05:34 PM   #684
brainwreck
Human being with feelings
 
Join Date: Jul 2006
Posts: 20,593
Default

Thanks Glennbo. I'll give staging a try.
brainwreck is offline   Reply With Quote
Old 05-08-2019, 03:27 PM   #685
SuperEB
Human being with feelings
 
Join Date: Jan 2016
Posts: 25
Default

I don't know which solved my issue with Waves plugins, but it had to be one of these two:

One of the winetricks installs mfc140.dll in syswow64, I was copying (over the winetricks version) a different version of this driver from an existing W10 installation.

I used winetricks mfc42 instead of copying mfc42 and mfc42u into the system32 folder.

I think during my previous successful attempt I forgot to copy mfc140 over the existing winetricks version so it worked. It was probably mfc140, but I can't say for 100% certain. Its's working now, so I'm not going to try and find out!

Last edited by SuperEB; 05-08-2019 at 03:41 PM.
SuperEB is offline   Reply With Quote
Old 05-10-2019, 06:51 AM   #686
Equal
Human being with feelings
 
Join Date: Jun 2018
Posts: 51
Default Kontakt 6 Crashing

Hi guys hopefully you can help me!

I am running ubuntu 18.04 and the most recent linvst + most recent wine devel version.
For some reason kontakt and some other virtual instruments keep crashing when I want to load them. The strange thing is, if I open a project where they are already loaded (an old project) they run perfectly fine.
I have all the necessary .dll overrides that are recommended in the linvst guide.

Attached is the crash report.
Attached Files
File Type: txt backtrace.txt (18.9 KB, 22 views)
Equal is offline   Reply With Quote
Old 05-11-2019, 10:38 AM   #687
SuperEB
Human being with feelings
 
Join Date: Jan 2016
Posts: 25
Default

What DAW are you using? Have you tried creating a new session since this problem began? Iím wondering if it is caused by a corrupt session file for a specific session.
SuperEB is offline   Reply With Quote
Old 05-12-2019, 10:42 AM   #688
Equal
Human being with feelings
 
Join Date: Jun 2018
Posts: 51
Default

I use Reaper linux native version 64 bit.

This problem occurs in every project where I want to add a new instance of Kontakt. New or old projects, there is no difference.
Strangely enough when I load track templates that already have Kontakt on them there is no problem.
Equal is offline   Reply With Quote
Old 05-19-2019, 09:19 AM   #689
Tobbe
Human being with feelings
 
Tobbe's Avatar
 
Join Date: Sep 2009
Location: Backe, Jšmtland, Sweden
Posts: 302
Default Spitfire Audio LABS - All are not working?

Hi,

Have any of you installed Spitfire Audio LABS and got every free instrument to work? I don't. I have these working:



But those is impossible to get to work:



I get Error #2 and I followed the YT video but no go. Doesn't matter in which order I install them, I still get this Error #2 message.

Installed Modular Piano


Terminal say this:
Code:
jack: created client
jack: setting TIME_CRITICAL = 89
jack: activated client
DSSI VST plugin server v0.986
Copyright (c) 2012-2013 Filipe Coelho
Copyright (c) 2010-2011 Kristian Amlie
Copyright (c) 2004-2006 Chris Cannam
LinVst version 2.5
Loading  /home/tobbe/VST/Spitfire LABS/LABS (64 Bit).dll
011a:fixme:ver:GetCurrentPackageId (0x145fdc0 (nil)): stub
0119:fixme:win:RegisterTouchWindow (0x10096 00000000): stub
0119:fixme:msg:ChangeWindowMessageFilterEx 0x10096 233 1 (nil)
0119:fixme:msg:ChangeWindowMessageFilterEx 0x10096 4a 1 (nil)
0119:fixme:msg:ChangeWindowMessageFilterEx 0x10096 49 1 (nil)
0119:err:ole:CoGetClassObject class {4ce576fa-83dc-4f88-951c-9d0782b4e376} not registered
0119:err:ole:create_server class {4ce576fa-83dc-4f88-951c-9d0782b4e376} not registered
0119:err:ole:CoGetClassObject no class object {4ce576fa-83dc-4f88-951c-9d0782b4e376} could be created for context 0x6
0119:fixme:ntdll:NtLockFile I/O completion on lock not implemented yet

(reaper:3904): Gdk-WARNING **: gdk_window_set_user_time called on non-toplevel

jack: deactivated client
jack: close client
0119:fixme:font:RemoveFontMemResourceEx (0x878cbbb1) stub
0119:fixme:font:RemoveFontMemResourceEx (0x87881871) stub
0119:fixme:font:RemoveFontMemResourceEx (0x878d46f1) stub
0119:fixme:font:RemoveFontMemResourceEx (0x878eb091) stub
dssi-vst-server[1]: exiting
Anyone has some wise words to share?
__________________
OS: MX-Linux 5.0.0-18.1-liquorix-amd64 #1 ZEN SMP PREEMPT liquorix (64Bit), Reaper For Linux (64Bit) (16GB RAM), HoRNet VST Plugin, Amplesound Bass & Acoustic (Free) and many other free stuff. Behringer U-PHORIA UMC22.
Tobbe is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 02:21 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.