Old 11-17-2018, 06:57 AM   #1
Vollgerd
Human being with feelings
 
Vollgerd's Avatar
 
Join Date: Sep 2009
Location: Monnem
Posts: 843
Default Reaper und Linux

Hallo,
Vermutlich git es in Deutschland nur wenige Reaperleute, die Linux verwenden.
Bei meinen bisherigen Linuxexperimenten ist das wohl auch verständlich.

Trotzdem versuche ich hier mal nach Anwtorten zu suchen.
Verweise auf das englischsprachige Forum ist nicht zielführend.
Das habe ich alles gelesen und bin nur in wenigen Fällen weitergekommen.

Ich starte Reaper mit wine.
bislang hat das auch soweit funktioniert.

mein aktuelles Hauptbroblem ist das einbinden bzw. sogar schon das Installieren von wineasio.
Mir wäre es auch recht, wenn man Jack als Asiotreiber einbinden könnte.
Reaper bietet mir aber auch diesen nicht an. (obwohl installiert).

Ich nutze Linux mint. Vermutlich wichtig, weil bei allen Anleitungen es wohl wichtig ist welches Linux man verwendet.

Zur Frage:
Die scheinbar einfachste Installation habe ich hier gefunden.
https://lkubuntu.wordpress.com/2014/...t-up-wineasio/

Zum Thema Installieren wird hier folgendes vorgeschlagen:

sudo apt-get install software-properties-common wget
sudo add-apt-repository ppa:kxstudio-debian/kxstudio
sudo apt-get update
sudo apt-get install kxstudio-repos
sudo apt-get update
sudo apt-get install wineasio

Offenbar ist kxstudio die entscheidende App.
Leider scheitere ich schon bei der zweiten Zeile.
sudo add-apt-repository ppa:kxstudio-debian/kxstudio
Mein Terminal bringt da die Fehlermeldung, dass der Pfad nicht gefunden wurde.

vermutlich muss man da vorher noch etwas einrichten.
Ich bin da für jede Hilfe dankbar.
Evtl kennt jemand eine aktuelle Installation die einfach ist.

Ich nutze linux mint 64 Bit.
(Reaper für Linux habe ich auch installiert, dort habe ich aber u.a. Probleme mit dem Einbinden meiner midi-instrumente wie keyboard etc. die über USB angebunden sind.)

Gruß Gerd
Vollgerd is offline   Reply With Quote
Old 11-17-2018, 11:48 AM   #2
Drumfix
Human being with feelings
 
Join Date: Oct 2007
Posts: 39
Default

Lade folgende Datei herunter;

https://launchpad.net/~kxstudio-debi...tudio3_all.deb

Dann

sudo dpkg -i kxstudio-repos_9.5.1~kxstudio3_all.deb
sudo apt-get update
sudo apt-get install wineasio
Drumfix is offline   Reply With Quote
Old 11-17-2018, 05:29 PM   #3
Vollgerd
Human being with feelings
 
Vollgerd's Avatar
 
Join Date: Sep 2009
Location: Monnem
Posts: 843
Default

Hallo Drumfix,

vielen Dank für deine freundliche unterstützung.
Das ganze scheint aber leider nicht so ganz einfach zu sein.
Zumindest nicht bei mir.

Ich habe die Datei runtergeladen. (im Ordner Downlaads).
Habe die aber auch direkt installieren lassen (Beim Anklicken des Links kann man die gleich installieren lassen.

Aber leider erhalte ich nach

sudo dpkg -i kxstudio-repos_9.5.1~kxstudio3_all.deb

folgenden Fehler:
kxstudio-repos (9.5.1~kxstudio3) wird eingerichtet ...
Sie sind dabei das folgende PPA hinzuzufügen:
KXStudio-Debian Ubuntu PPA
==============================

Contains Ubuntu-specific packages that should not be installed on regular Debian systems.

DO NOT USE THIS PPA DIRECTLY!

Please follow the proper instructions here instead:
http://kxstudio.linuxaudio.org/Repositories
Mehr Informationen: https://launchpad.net/~kxstudio-debi...ubuntu/ubuntus
Warning: apt-key should not be used in scripts (called from postinst maintainerscript of the package kxstudio-repos)
Executing: /tmp/apt-key-gpghome.9waWgcHoNM/gpg.1.sh --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 2BD84BD9
gpg: Schlüssel F8599E482BD84BD9: "Launchpad PPA for KXStudio Debian" nicht geändert
gpg: Anzahl insgesamt bearbeiteter Schlüssel: 1

Sheint also das falsche Ubuntu zu sein.

Allerdings hat der Automatische Installer (beim anklicken des Links)
berichtet, dass kxstudio bereits installiert wäre.

Davon gehe ich auch. Weil ich es auf andere, Nach Vorgabe des Herstellers auf dessen Seite auch installiert habe.

Bei Eingabe des Befahls
sudo apt-get install wineasio
kam folgende Fehlermeldung:

Einige Pakete konnten nicht installiert werden........

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
wineasio : Hängt ab von: wineasio-amd64 soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

diese Meldung erhielt ich auch, nach der Installationanleitung des Herstellers.

Bin langsam am verzweifeln.

Gestern erhielt ich noch die Fehlermeldung, dass winasio -i386 oder so ähnlich fehlt.

das scheint aber mittels kx studio nicht mehr erforderlich zu sein.

Evtl hast Du da noch wietere Vorschläge.
Evtl muss ich da etwas wieder deinstallieren. Keine Ahnung wie.

Ich nutze linux mint erst seit knapp einer Woche.

Gruß
Gerd
Vollgerd is offline   Reply With Quote
Old 11-17-2018, 06:25 PM   #4
lilith93
Human being with feelings
 
lilith93's Avatar
 
Join Date: Apr 2018
Location: Karlsruhe
Posts: 216
Default

Als erstes würde ich versuchen die eingebundenen repos wieder zu löschen und dann nach der Anleitung von

http://kxstudio.linuxaudio.org/Repositories

vorgehen. Du kannst auch hier mal nachfragen:

https://www.sequencer.de/synthesizer/forums/linux.94/

Mit winasio habe ich keine Erfahrung.

Was kommt bei sudo apt-get install wineasio-amd64?
__________________
https://soundcloud.com/lilith_93

Debian - Stretch / XFCE
lilith93 is offline   Reply With Quote
Old 11-18-2018, 07:30 AM   #5
Vollgerd
Human being with feelings
 
Vollgerd's Avatar
 
Join Date: Sep 2009
Location: Monnem
Posts: 843
Default

Hallo lilith93,
danke auch dir für deine Hilfe.

Ich hatte vorher schon genau nach dem von dir vorgeschlagenen Link versucht zu installieren.
Da kam dann auch die von mir beschriebene Fehlermeludung.

Dein tipp den asiotreber AMD64 bit alleine zu installieren, war wohl Gold werd.
Der wurde dann auch anstandslos installiert. Zumindest keine Fehlermeldung.

Anschließend habe ich dann nochmals alles genau nach der Anleitung deiner Vorgeschlagenen Seite nachvollzogen.

Jetzt kam keine Fehlermeldung mehr.
Sollte also alles in bester Ordnung sein.

Aber Reaper zeigt mir immer noch an, dass kein Asio-Treiber vorhanden wäre.

Evtl muss man da noch etwas laden. kxStudio steht leider nicht im Menü.

Evtl kommt aber auch da noch ein hilfreicher Lösungsvorschlag.

Nebenbei meine Frage: Wenn du keinen Asiotreiber nutzt, wie ist dann deine Einstellung bei Reaper?

Gruß
Gerd
Vollgerd is offline   Reply With Quote
Old 11-18-2018, 08:25 AM   #6
lilith93
Human being with feelings
 
lilith93's Avatar
 
Join Date: Apr 2018
Location: Karlsruhe
Posts: 216
Default

Hi Gerd,

super! Das wird schon. KXStudio wird bei Reaper sicher nicht stehen. Mit den Befehlen werden ja nur die KXStudio Repositories eingebunden, über die dann zusätzlich Software geladen werden kann. Also VST- Instrumente, Cadence (ein Jack Client), Carla (eine Patchbay), etc.

Ich habe entweder Jack oder Alsa als Einstellung in Reaper am Laufen. Jack hat den Vorteil, dass man von anderen Anwendungen Audio in Reaper routen und auch miteinander synchronisieren kann. Zudem besteht damit auch die Möglichkeit z.B. den Sound vom Browser in Jack zu routen. D.h. ich kann Musik in Reaper machen und auch mal kurz ein Video im Browser gucken ohne irgendwelche Audioserver zu stoppen und neu zu starten.

Also wenn du keine Windows VSTs brauchst, würde ich versuchen die Linux-Reaper Version mit Jack/Alsa zu nutzen.

Hast du hier mal geschaut? https://wiki.linuxaudio.org/wiki/wineasio_and_reaper


Was für eine Wine Version verwendest du? Ich glaube da gab es einen Haken... man muß wohl Wine Staging verwenden.

https://wiki.winehq.org/Wine-Staging
__________________
https://soundcloud.com/lilith_93

Debian - Stretch / XFCE

Last edited by lilith93; 11-18-2018 at 08:34 AM.
lilith93 is offline   Reply With Quote
Old 11-18-2018, 11:22 AM   #7
Vollgerd
Human being with feelings
 
Vollgerd's Avatar
 
Join Date: Sep 2009
Location: Monnem
Posts: 843
Default

Hallo lilith93,
Klasse, ich glaube wir kommen der Sache schon etwas näher.

https://wiki.linuxaudio.org/wiki/wineasio_and_reaper
Diese Seite kenne ich schon, wusste aber nichts damit anzufangen. (zumal wineasio ja nicht installiert war.

Interessant scheint mir diese Aussage:
KXStudio includes WineASIO which provides an ASIO to JACK driver for Wine. This allows ASIO-compatible Windows software running under Wine to access your JACK device/server as if it was an ASIO device.

Dafür benötigt man aber wohl wieder eine entsprechende Anwendung mit dem Namen Cadence. Ich muss mal schauen, ob die über die normale Appinstallation installierbar ist, oder über die kxstudio Seite. (Dafür muss ich aber erst mal den Rechner wechseln.)

Reaper für Linux habe ich auch installiert.
Da gibt es aber auch noch einige Probleme, z.b. mein Masterkeyboard und andere Geräte einzubinden. Dafür mach ich aber ggf. ein eigenes thema auf, Wenn ich bei meinen Recherchen in eine Sackgasse laufe
Da ich schon ordentlich Geld in Windows-VSTs infestiert habe (NI, Sampletank, Miroslav, und etliche andere Kaufsoftware) muss ich die Windowsversion von Reaper verwenden. Es sei denn ich finde einen Weg auch diese VST mit Reaper-Linux starten zu können. Soweit bin ich aber noch lange nicht.

Welche wine version ich habe, kann ich nicht einmal sagen. Es müsste aber die neueste sein. Weil ich die ja erst heute installiert habe.
Wine-stagging muss ich mir mal ansehen. Danke für den LInk.
Irgend jemand hat im eng.Forum auch geschrieben, dass er wineasio nach irgend einem update nicht mehr gefunden hat. Ich muss das mal wieder suchen. Mal sehen, wie der das gelöst hat.

Wenn Du Jack nutzt hast Du wohl Reaper-Linux am laufen?

Ich melde mich wieder, wenn ich deine weiteren Tipps alle ausprobiert habe. Das wird diese Woche aber wohl nix mehr.

Gruß
Gerd
Vollgerd is offline   Reply With Quote
Old 11-21-2018, 04:25 PM   #8
Vollgerd
Human being with feelings
 
Vollgerd's Avatar
 
Join Date: Sep 2009
Location: Monnem
Posts: 843
Default

So, hier bin ich wieder,

nach einigen Versuchen hatte ich plötzlich gar keinen Ton mehr.
Nicht bei Reaper, aber weder bei Youtube noch mit dem internen Mediaplayer von linux mint.
Eine Anfrage im Linux Mint Forum hat auch nichts gebracht. Niemand hat geantwortet.
Nach weiteren Versuchen konnte ich plötzlich auch Linux mint nicht mehr starten. (Es fehlte irgendwas)

also alles neu installiert (man hat ja Zeit)

Dann zuerst wine installiert (wird für wineasio ja benötigt.
Anschliesend wineasio genau nach der Anleitung:
http://kxstudio.linuxaudio.org/Repositories

Reaper hat trotzdem nichts gefunden.

Anscheinend muss man wineasio aber noch bei Wine registrieren.

regsvr32 wineasio
wine64 regsvr32 wineasio

In beiden Fällen wurde eine erfolgreiche Registierung gemeldet.

Und Reaper findet jetzt auch den wineasiotreiber.
Klasse!!!!!

Allerdings kann Reaper weder die Eingänge noch die Ausgänge finden.

"Beim Öffnen der Audio-Hardware ist ein Fehler aufgetreten:
Fehler beim Initialisieren des ASIO-Treibers"

Auch der Button "Asiokonfiguration" funktioniert nicht.
In Windows konnte man die Ein-bzw. Ausgänge von Asio konfigurieren.
Das Symbol wurde unten in der Leiste angezeigt.

Mit cadence kann man das wohl zuordnen.
Cadence wird aber bei den installierbaren Anwendungen nicht angezeigt.
(auch nicht mit dem Suchbegriff Jack)

Evtl hat noch jemand eine Idee, wie ich da weiterkommen könnte?

Gruß
Gerd
Ps cadence habe ich gefunden und auch installiert.
auch alles nach Anweisung der KXstudio seite erledigt.
Reaper findet die Ein und Ausgänge nicht.
Meine Ein und Ausgänge sind z.Zt. die normalen PC ein und Ausgänge

Last edited by Vollgerd; 11-21-2018 at 05:19 PM.
Vollgerd is offline   Reply With Quote
Old 11-22-2018, 06:25 AM   #9
lilith93
Human being with feelings
 
lilith93's Avatar
 
Join Date: Apr 2018
Location: Karlsruhe
Posts: 216
Default

Versuche mal in Cadence Jack zu starten und dann Reaper. Ich könnte mir vorstellen, dass das alles über Catia (Cadence -> Tools) läuft. Das ist eine Patchbay über die du dann die Verbindungen machen kannst. Ich habe leider keine Ahnung von Asio ...
__________________
https://soundcloud.com/lilith_93

Debian - Stretch / XFCE
lilith93 is offline   Reply With Quote
Old 11-22-2018, 08:17 AM   #10
Vollgerd
Human being with feelings
 
Vollgerd's Avatar
 
Join Date: Sep 2009
Location: Monnem
Posts: 843
Default

Quote:
Originally Posted by lilith93 View Post
Ich habe leider keine Ahnung von Asio ...
Hallo lillith93
das ist schade. Aber da haben wir was gemeinsam.
Ich habe natürlich an allen Rädern von Cadence und Carla und Catia geschraubt.
Aber Reaper wollte nie die Verbinungen übernehmen.
Bei der Gelegenheit habe ich auch das ganze System wieder abgeschossen.

Auch Jack verhält sich merkwürdig. Einmal hat er Reaper angezeigt. Das nächste mal wieder nicht.

Das ist schon zum Haare raufen.

trotzdem Danke für deine Hilfe.

Gruß
Gerd
Vollgerd is offline   Reply With Quote
Old 11-22-2018, 12:27 PM   #11
lilith93
Human being with feelings
 
lilith93's Avatar
 
Join Date: Apr 2018
Location: Karlsruhe
Posts: 216
Default

Versuch doch mal AVlinux von Stick zu booten
Meines Wissens ist dort mit Asio und Wine schon alles vorkonfiguriert. Ist halt Debian, kann es aber nur empfehlen.

Marco
__________________
https://soundcloud.com/lilith_93

Debian - Stretch / XFCE
lilith93 is offline   Reply With Quote
Old 11-23-2018, 09:54 AM   #12
Vollgerd
Human being with feelings
 
Vollgerd's Avatar
 
Join Date: Sep 2009
Location: Monnem
Posts: 843
Default

hm,
leider habe ich z.Zt. wohl wenig Glück.
Ich hab emir avlinux besorgt und auf stick installiert.
Erstes Problem war schon die Tatsache, dass man ein Kennwort benötigt.
Man wird dann nur als Gast angemeldet. Was einige Aktionen schon unmöglich macht.
Es war aber tatsächlich winasio vorinstalliert.
Man konnte es sogar aufrufen und erhält wohl ein Menü um es zu registrieren.
Das war es aber auch schon.
bei Wine wollte das System was runterladen, was nicht gelang, weil die Internetverbindung ständig abbrach (max. eine Minute. Das gleiche Problem hatte ich schon bei LMde.)
Reaper konnte ich nicht laden.

Dann habe ich das gleiche mit UbuntuStudio versucht.
Stabiles Internet, aber leider kein Wine und kein Wineasio. Ubuntustudio ist wohl nur für Linuxanwendungen ausgelegt.

Da Linux mint inzwischen mal wieder abgeschmiert und nicht mehr ladbar war, habe ich es nochmals installiert.

Jetzt bekomme ich merkwürdigerweise beim Versuch Wineasio über KXstudio zu installieren ständig Fehlermeldungen, dass irgendwelche Pfade nicht gefunden werden. Auch registrieren funktioniert nicht.

Schon mehr als merkwürdig.
Trotzdem habe ich Cadence installiert.
Reaper findet trotzdem keinen Asiotreiber.

cadence findet merkwürdigerweise Jack, obwohl nicht installiert (ist in KXStudio wohl enthalten.) Auch den Asiobutton kann man öffnen und einstellen.
Natürlich war danach der Ton wieder komplett weg. Bei Reaper funktionierte der Playbutton nicht mehr. (Der Curser bleibt einfach stehen) Auch MP3 funktioniert mit dem internen Player nicht.

Soweit meine Erfahrungsberichte mit Linux. Es lebe Windows 10!!!!!!!

Ich brauch jetzt erst mal eine Pause.

Gruß
gerd
Vollgerd is offline   Reply With Quote
Old 11-24-2018, 06:33 AM   #13
lilith93
Human being with feelings
 
lilith93's Avatar
 
Join Date: Apr 2018
Location: Karlsruhe
Posts: 216
Default

Die Kennwörter für AVLinux stehen im Manual:

AV Linux 32bit :
Username: isotester
Password: avl32
Root Password: avl32admin

AV Linux 64bit :
Username: isotester
Password: avl64
Root Password: avl64admin

https://bandshed.net/pdf/AVL2018UserManual.pdf

Vielleicht nochmal versuchen
__________________
https://soundcloud.com/lilith_93

Debian - Stretch / XFCE
lilith93 is offline   Reply With Quote
Old 11-25-2018, 06:41 AM   #14
Vollgerd
Human being with feelings
 
Vollgerd's Avatar
 
Join Date: Sep 2009
Location: Monnem
Posts: 843
Default

Hallo lilith93,
danke nochmals für deine unermütliche Hilfe.
Das Kennwort habe ich gefunden und konnte AVLinux auch starten.

Mein Problem ist die Internetverbindung und den Zugang als Gast.
Wenn die Internetverbindung ständig abbricht, kann man natürlich auch nichts nachinstallieren, ggf nicht einmal AVLLinux fest installieren.
Ich hab keine Ahnung woran das liegt. das gleiche Problem hatte ich bereits bei LMDE.
Das basiert auch direkt auf Debian. Evtl liegt es daran.

Aber ich werde es trotzdem nochmal probieren.
Inzwischen habe ich auch gelesen, dass es bei Linux mint 19 Probleme mit dem Sound gäbe.

Also habe ich testweise Linux mint 18.3 installiert.
Wine installiert, JACK installiert, anschließen wineasio über kxstudio.
Da gingen dann die Probleme wieder los.
Fehlermeldung: Irgendeine Datei oder Pfad wird nicht gefunden (schon beim ersten Befehl). Das problem hatte ich noch nie.
Irgendwann hat es dann doch geklappt, aber wineasio ließ sich nicht registrieren.
Es gibt auch dem ganzen PC auch kein wineasio =Ordner bzw. irgendeine wineasio Datei.
Mein Verdacht ist auch, dass wineasio beim Installieren nach einem Ordner "wine" sucht. Den gibt es aber auch nicht. Weil bei der neuesten Version von wine nur ein Ordner wineasio-stabel angelegt wird.
Aber auch beim Nachinstallieren einer älteren Version wird kein wine ordner angelegt.
Übrigens kann ich plötzlich auch cadence nicht mehr installieren. Fehlermedung: Paket nicht gefunden.

Ich glaube ich versuche jetzt mal einen anderen Weg probieren.
Reaper-linux und versuchen VST mit LinVST zu starten.

Gott sei dank habe ich noch ein gut funktioneirendes Windows 10.

Linux wollte ich auf einem alten ausgedienten PC mit windows 7 ausprobieren. (Der PC landet früher oder später eh auf dem Müll.)

auch wenn die meisten sich bei diesem Thema wohl eher langweilen, werde ich weiter berichten.

Gruß
gerd
Vollgerd is offline   Reply With Quote
Old 11-28-2018, 02:50 AM   #15
monty
Human being with feelings
 
monty's Avatar
 
Join Date: Dec 2015
Posts: 148
Default

Installiere Kubuntu:
https://kubuntu.org/

Nach der Installation in den Einstellungen, erst einmal alle Effekte deaktivieren, Suche indexing ALLES deaktivieren und die Plasma Widgets Suchmodule deaktivieren.
Energieverwaltung alles mit Standby deaktivieren.

Kubuntu optimieren:
sudo apt-get install linux-lowlatency
update-grub
reboot

sudo apt-get install cpufrequtils
sudo nano /etc/default/cpufrequtils
ENABLE="true"
GOVERNOR="performance"
MAX_SPEED="0"
MIN_SPEED="0"

sudo systemctl disable ondemand

sudo usermod -a -G audio DeinUsername
sudo usermod -a -G disk DeinUsername

sudo su
nano /etc/default/grub
GRUB_CMDLINE_LINUX=""
ändern zu
GRUB_CMDLINE_LINUX="threadirqs"

dann
grub-mkconfig -o /boot/grub/grub.cfg
update-grub

echo "@audio - rtprio 99" >> /etc/security/limits.d/audio.conf
echo "@audio - memlock unlimited" >> /etc/security/limits.d/audio.conf

sudo nano /etc/pam.d/common-session
session required pam_limits.so

sudo nano /etc/pam.d/common-session-noninteractive
session required pam_limits.so

sudo nano /etc/sysctl.conf
dev.hpet.max-user-freq=3072

sudo nano /etc/rc.local
echo 3072 >/sys/class/rtc/rtc0/max_user_freq
echo 160000 > /proc/sys/fs/inotify/max_user_watches

sudo nano /etc/sudoers.d/sysadmin
einfügen
# This file is managed by Chef.
# Do NOT modify this file directly.
%sysadmin ALL=(ALL) ALL


sudo nano /etc/sysctl.conf
dev.hpet.max-user-freq=3072
vm.swappiness = 10
vm.dirty_ratio = 6
vm.dirty_background_ratio = 3
vm.vfs_cache_pressure = 50

balooctl disable

Software Pakete de-installieren:
sudo apt purge accountwizard akonadi-backend-mysql akonadi-server akregator kaddressbook kdepim-addons kdepim-runtime kdepim-themeeditors kleopatra kmail knotes kontact korganizer ktnef mbox-importer pim-data-exporter pim-sieve-editor osspd prelink preload gjs cups kdevelop gnome desktop cryptsetup-initramfs

sudo apt-get autoremove
sudo apt-get clean
sudo update-initramfs -u

reboot

Kxstudio repos wie hier installieren - beide
http://kxstudio.linuxaudio.org/Repositories

sudo apt-get install winetricks
sudo apt-get update && sudo apt-get upgrade

sudo apt install jackd2 pulseaudio-module-jack pavucontrol cadence carla-git carla-lv2 carla-vst mididings pulseaudio-module-jack guitarix

sudo nano /etc/apt/sources.list
hinzufügen:
deb https://dl.winehq.org/wine-builds/ubuntu/ bionic main

sudo dpkg --add-architecture i386
sudo apt-get clean
wget -nc https://dl.winehq.org/wine-builds/Release.key
sudo apt-key add Release.key

sudo apt-get update
sudo apt-get install --install-recommends winehq-staging
sudo apt-get install wineasio

winecfg
regsvr32 wineasio
wine64 regsvr32 wineasio


reboot

Dann die Reaper Linux Version downloaden
http://reaper.fm/download.php

entpacken
und den Ordner REAPER in dein Home Verzeichnis kopieren

auf dem Desktop einen Programm Starter anlegen
Befehl:
/home/DeinUsername/REAPER/reaper

Das ganze kann dann noch weiter optimiert werden siehe Reaper Linux Forum.
__________________
KDE Neon (lowlatency) AMD FX-8350, 16GB, GT 630 (nvidia-415), Multiscreen (2x 22", 1x 15"), Reaper (latest) Theme: iLogic Next, Interface: Tascam US-16x08, ControlSurface: Tascam US-2400, Monitors: JBL 4412A, Tascam VL-S3 & Alesis Elevate 3 mkII
monty is offline   Reply With Quote
Old 11-29-2018, 05:16 AM   #16
Vollgerd
Human being with feelings
 
Vollgerd's Avatar
 
Join Date: Sep 2009
Location: Monnem
Posts: 843
Default

Hallo monty,
danke für die wirklich ausführliche und tolle Anleitung.
Das ist mal wieder ein Beweis dafür, dass das Reaperforum eins der besten Foren ist, die ich kenne.

Deine Anleitung werde ich mir auf jeden Fall Kopieren und abspeichern.
teile deiner Codes werde ich auch noch ausführen.

Mein Reaper und wineasio funktioniert seit gestern Mittag.
Leider kann ich überhaupt nicht nachvollziehen, warum.
Vorgestern habe ich mal wieder einiges versucht. auch zwischendurch neu gestartet. Ergebnislos. Und gestern Jack und cadence aufgerufen und anschließend Reaper und es hat funktioniert.

Ich glaube man muss eine bestimmte Reihenfolge einhalten.

Trotz deiner Anleitung bescheibe ich nochmals wie ich zu Ziel kam.
Könnte für andere ja interessant sein.

Direkt von KXStudio wineasio zu installieren (ohne vorher Jack und wine installiert zu haben funktioniert nicht. Ich erhielt immer die Fehlermeldung, dass das Paket nicht gefunden wurde.

Also Schritt 1)
Wine installieren. Kann man über die interne Anwendungsverwaltung machen, oder nach dieser Anleitung (in Youtube enthaltenen Link für code öffnen)
https://www.youtube.com/watch?v=YtZfYTZE3uY&t=674s

Anschließend Jack installieren. (QJackCtl)
Danach Wineasio über
http://kxstudio.linuxaudio.org/Repositories

Ich habe es über eine anderen Anleitung installiert:

https://lkubuntu.wordpress.com/2014/...t-up-wineasio/

ganz wichtig, um zu testen, ob überhaupt installiert wurde. (bei der Installation nach der KXStudio Seite erhielt ich kein Fehlermeldung. Wusste aber nicht, ob es installiert ist.)

Wineasio MUSS registriert werden:
regsvr32 wineasio
wine64 regsvr32 wineasio

Wenn hier keine Fehlermeldung kommt, funktioniert zu mindest Wineasio schon mal.

Cadence habe ich hier runtergeladen.

https://kxstudio.linuxaudio.org/Appl...dence#Download

Ganz wichtig ist in Cadence die Startseite. (erstes Bild der o.g.Seite)
Es muss ein Haken bei "user in audio group" sein.
Da war bei mir ein X.

Ich glaube der von dir beschriebene code war da die Lösung.

sudo usermod -a -G audio DeinUsername

Allerding bekam ich da eine Fehlermeldung. Ich habe es dann ohne -a versucht.

In Jack wird nun auch mein Keyboard angezeigt. (war vorher nciht der Fall)
Und ein Eintrag: PulseAudio JACK sink.

Jetzt habe ich nur noch zwei kleine Probleme:

1.) Ich muss immer zuerst Jack starten und dann erst Reaper.
2.) Mein Audointerface wird zwar in Cadence angezeigt, funktioniert aber icht in Reaper. D.h. der Ton kommt immer noch aus den am PC angeschlossenen Boxen an und nicht über das audiointerface. (allerdings habe ich auch den Treiber (exe-Datei) nicht installiert.

So, mal wieder viel geschrieben, aber evtl hilft es anderen noch weiter.

Gruß
Gerd
Vollgerd is offline   Reply With Quote
Old 11-29-2018, 05:38 AM   #17
monty
Human being with feelings
 
monty's Avatar
 
Join Date: Dec 2015
Posts: 148
Default

autostart usw. kann man im cadence einstellen

https://i.ibb.co/cT9nxYk/Screenshot-20181129-133215.png

https://i.ibb.co/Ykxkxq1/Screenshot-20181129-133403.png
__________________
KDE Neon (lowlatency) AMD FX-8350, 16GB, GT 630 (nvidia-415), Multiscreen (2x 22", 1x 15"), Reaper (latest) Theme: iLogic Next, Interface: Tascam US-16x08, ControlSurface: Tascam US-2400, Monitors: JBL 4412A, Tascam VL-S3 & Alesis Elevate 3 mkII
monty is offline   Reply With Quote
Old 11-29-2018, 05:51 AM   #18
Vollgerd
Human being with feelings
 
Vollgerd's Avatar
 
Join Date: Sep 2009
Location: Monnem
Posts: 843
Default

Hallo monty,
danke nochmal.
Muss ich mal versuchen.

Gruß
Gerd
Vollgerd is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 03:28 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.