Old 04-05-2019, 10:03 PM   #1
relimbeck
Human being with feelings
 
Join Date: Jan 2015
Posts: 12
Default Focusrite Scarlett 2i4 after Mojave Upgrade

Greetings,

I just upgraded to OS X Mojave and now I'm having a problem getting Reaper to communicate with my Focusrite 2i4 interface. I would not consider myself a newbie, as I've recorded with this interface thousands of times with no problems, but I feel like this is a total noob issue.

My interface's MIDI is working fine. I can use my midi keyboard to play my VST drums and other instruments, but it's the audio that's not working. When I plug my guitar in or my mic in, Reaper doesn't "see" the signal. The green light on the interface comes on, so I know the interface is detecting the guitar signal, but there's a problem somewhere between the interface and Reaper.

My guitar is plugged in to input 1, my track is armed on input 1, record monitoring is on, and in my preferences, "Scarlett 2i4 USB" is selected as my audio device. I'm using Waves GTR modeling. Also, my interface's blend knob is set to playback, which should still generate sound through my amp modeling. When I move this knob, the dry signal does come through on the left side only.

All of this was working fine before I upgraded to Mojave. Again, I've done this thousands of times before and it's worked, but now for some reason there is a disconnect somewhere between the interface and Reaper. Can someone recommend some troubleshooting?? Thanks so much!
relimbeck is offline   Reply With Quote
Old 04-06-2019, 12:57 AM   #2
solger
Human being with feelings
 
solger's Avatar
 
Join Date: Mar 2013
Posts: 3,522
Default

Quote:
When I plug my guitar in or my mic in, Reaper doesn't "see" the signal.
Most likely related to the Mic Privacy Settings in Mojave which are blocking audio input in general:
__________________
ReaLauncher
solger is online now   Reply With Quote
Old 04-06-2019, 06:31 AM   #3
relimbeck
Human being with feelings
 
Join Date: Jan 2015
Posts: 12
Default

Solger,

Thank you very much! That perfectly solved the problem.

For anyone else having this issue. Go to your Apple preferences (Not Reaper). Click the Apple icon in the taskbar. Go to "System Preferences," Go to "Security and Privacy," and at the top click on "Privacy."

On the left menu navigate to "Microphone," then select REAPER from the program list.


Thanks again!
relimbeck is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 11:42 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.