Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER General Discussion Forum

Reply
 
Thread Tools Display Modes
Old 01-20-2019, 10:32 AM   #1
earhax
Human being with feelings
 
Join Date: Nov 2015
Posts: 113
Default rpp files open in 32-bit REAPER, can't change default to 64-bit

When I open a rpp file from any folder in Finder, it will open in REAPER 32-bit. If I right click>open with it shows REAPER.spp (default) (5.96.500), and REAPER64.app (5.96.500) just below that. If I 'get info' on a rpp file, it shows open with REAPER.app. If I change it to REAPER64.app, then click "Change All..." and "Continue" to change all rpp files to open with REAPER64.app, the selected app in the Open with dropdown immediately changes back to the default 32-bit REAPER.app.

How can I make the default app for all rpp files the REAPER64.app instead of the 32-bit version?

The weird thing is this was working fine before I upgraded both 64 and 32 bit apps earlier today to the latest release. So I don't know how upgrading them caused this issue, but hope I find some way to resolve it. Please help if anyone knows how. Thanks!
earhax is offline   Reply With Quote
Old 01-20-2019, 10:44 AM   #2
DarkStar
Human being with feelings
 
DarkStar's Avatar
 
Join Date: May 2006
Location: Surrey, UK
Posts: 17,708
Default

Possibly the association of the .rpp files is set to whichever Reaper edition was installed last???

But why install both, anyway? Stick to Reaper 64.
__________________
DarkStar ... interesting, if true. . . . Inspired by ...
DarkStar is online now   Reply With Quote
Old 01-20-2019, 12:16 PM   #3
earhax
Human being with feelings
 
Join Date: Nov 2015
Posts: 113
Default

Quote:
Originally Posted by DarkStar View Post
Possibly the association of the .rpp files is set to whichever Reaper edition was installed last???

But why install both, anyway? Stick to Reaper 64.
I have some old plugins that are only 32 bit, so sometimes I need to run a project in 32 bit format if I want to use one of them.

I thought it might be something like what you mentioned, so tried installing the 64 bit version again. But the problem persists. Later I'll probably try restarting the system to see if that will fix it. Hopefully it will. But too busy to shut everything down and restart right now.
earhax is offline   Reply With Quote
Old 01-20-2019, 08:05 PM   #4
MrMoto
Human being with feelings
 
MrMoto's Avatar
 
Join Date: Jun 2009
Location: Atlanta, GA
Posts: 207
Default

Quote:
Originally Posted by earhax View Post
How can I make the default app for all rpp files the REAPER64.app instead of the 32-bit version?
You can change the .rpp and .rpp-bak extension settings in Control Panel.

Go to Programs -> Default Programs -> Set Associations

Scroll down to the .rpp extension and double click on it. This will give you the option to pick the REAPER version you want to open when you double click on the .rpp extension. Since you have 2 REAPER versions in use it may not be clear at first which is the correct one.

You can also use the "More Options" in that little window and go to the 64-bit REAPER folder using the "Look for another App on this PC", at the bottom of the list, and hand pick the 64-bit REAPER.EXE file.

Do the same thing for the .rpp-bak extension and you're all set.

There may be some minor differences in how it's worded depending on the Windows version, but I'm sure you can figure it out.
__________________
Without music, life is a journey through a desert.
MrMoto is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 05:47 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.